summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorBjørn Forsman <bjorn.forsman@gmail.com>2014-08-24 16:21:08 +0200
committerBjørn Forsman <bjorn.forsman@gmail.com>2014-08-24 22:31:37 +0200
commitc9baba9212feb6e39151118647d45b34b029a6df (patch)
tree48dc0df228a071cc5639fe51bfce55d621a3a8f1 /pkgs/games
parent2a6c7e2874a3ada9b1c544db61402e03091556db (diff)
downloadnixlib-c9baba9212feb6e39151118647d45b34b029a6df.tar
nixlib-c9baba9212feb6e39151118647d45b34b029a6df.tar.gz
nixlib-c9baba9212feb6e39151118647d45b34b029a6df.tar.bz2
nixlib-c9baba9212feb6e39151118647d45b34b029a6df.tar.lz
nixlib-c9baba9212feb6e39151118647d45b34b029a6df.tar.xz
nixlib-c9baba9212feb6e39151118647d45b34b029a6df.tar.zst
nixlib-c9baba9212feb6e39151118647d45b34b029a6df.zip
Fix many package descriptions
(My OCD kicked in today...)

Remove repeated package names, capitalize first word, remove trailing
periods and move overlong descriptions to longDescription.

I also simplified some descriptions as well, when they were particularly
long or technical, often based on Arch Linux' package descriptions.

I've tried to stay away from generated expressions (and I think I
succeeded).

Some specifics worth mentioning:
 * cron, has "Vixie Cron" in its description. The "Vixie" part is not
   mentioned anywhere else. I kept it in a parenthesis at the end of the
   description.

 * ctags description started with "Exuberant Ctags ...", and the
   "exuberant" part is not mentioned elsewhere. Kept it in a parenthesis
   at the end of description.

 * nix has the description "The Nix Deployment System". Since that
   doesn't really say much what it is/does (especially after removing
   the package name!), I changed that to "Powerful package manager that
   makes package management reliable and reproducible" (borrowed from
   nixos.org).

 * Tons of "GNU Foo, Foo is a [the important bits]" descriptions
   is changed to just [the important bits]. If the package name doesn't
   contain GNU I don't think it's needed to say it in the description
   either.
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/banner/default.nix2
-rw-r--r--pkgs/games/chessdb/default.nix2
-rw-r--r--pkgs/games/construo/default.nix2
-rw-r--r--pkgs/games/crafty/default.nix2
-rw-r--r--pkgs/games/eboard/default.nix2
-rw-r--r--pkgs/games/openspades/default.nix2
-rw-r--r--pkgs/games/openttd/default.nix2
-rw-r--r--pkgs/games/opentyrian/default.nix2
-rw-r--r--pkgs/games/teeworlds/default.nix2
9 files changed, 9 insertions, 9 deletions
diff --git a/pkgs/games/banner/default.nix b/pkgs/games/banner/default.nix
index b4e61b6d1d1f..b443a76b9a77 100644
--- a/pkgs/games/banner/default.nix
+++ b/pkgs/games/banner/default.nix
@@ -36,7 +36,7 @@ mkDerivation "banner-1.3.2" "0dc0ac0667b2e884a7f5ad3e467af68cd0fd5917f8c9aa19188
 
   meta = {
     homepage = "http://shh.thathost.com/pub-unix/";
-    description = "print large banners to ASCII terminals";
+    description = "Print large banners to ASCII terminals";
     license = stdenv.lib.licenses.gpl2;
 
     longDescription = ''
diff --git a/pkgs/games/chessdb/default.nix b/pkgs/games/chessdb/default.nix
index 381e35632a6e..224eb6f594a0 100644
--- a/pkgs/games/chessdb/default.nix
+++ b/pkgs/games/chessdb/default.nix
@@ -24,6 +24,6 @@ stdenv.mkDerivation {
 
   meta = {
     homepage = http://chessdb.sourceforge.net/;
-    description = "ChessDB is a free chess database";
+    description = "A free chess database";
   };
 }
diff --git a/pkgs/games/construo/default.nix b/pkgs/games/construo/default.nix
index 57d055ed3d3d..f94b489908eb 100644
--- a/pkgs/games/construo/default.nix
+++ b/pkgs/games/construo/default.nix
@@ -24,6 +24,6 @@ stdenv.mkDerivation rec {
 	builder = writeScript (name + "-builder")
 		(textClosure localDefs ["preConfigure" "doConfigure" "doMakeInstall" "doForceShare" "doPropagate"]);
 	meta = {
-		description = "Construo masses and springs simulation";
+		description = "Masses and springs simulation game";
 	};
 }
diff --git a/pkgs/games/crafty/default.nix b/pkgs/games/crafty/default.nix
index 0e2796df22d8..351e25388e17 100644
--- a/pkgs/games/crafty/default.nix
+++ b/pkgs/games/crafty/default.nix
@@ -659,7 +659,7 @@ stdenv.mkDerivation rec {
 
   meta = {
     homepage = http://www.craftychess.com/;
-    description = "Crafty is a free, open-source computer chess program developed by Dr. Robert M. Hyatt";
+    description = "Chess program developed by Dr. Robert M. Hyatt";
     license = stdenv.lib.licenses.unfree;
     platforms = stdenv.lib.platforms.unix;
     maintainers = [ stdenv.lib.maintainers.jwiegley ];
diff --git a/pkgs/games/eboard/default.nix b/pkgs/games/eboard/default.nix
index 1decee4264a4..8dd06fa6a281 100644
--- a/pkgs/games/eboard/default.nix
+++ b/pkgs/games/eboard/default.nix
@@ -14,6 +14,6 @@ stdenv.mkDerivation {
 
   meta = {
     homepage = http://www.bergo.eng.br/eboard/;
-    description = "eboard is a chess interface for Unix-like systems";
+    description = "Chess interface for Unix-like systems";
   };
 }
diff --git a/pkgs/games/openspades/default.nix b/pkgs/games/openspades/default.nix
index 7f11fc829032..c2218d033d79 100644
--- a/pkgs/games/openspades/default.nix
+++ b/pkgs/games/openspades/default.nix
@@ -28,7 +28,7 @@ stdenv.mkDerivation rec {
     else null;
 
   meta = with stdenv.lib; {
-    description = "OpenSpades is a compatible client of Ace of Spades 0.75";
+    description = "A compatible client of Ace of Spades 0.75";
     homepage    = "https://github.com/yvt/openspades/";
     license     = licenses.gpl3;
     platforms   = platforms.linux;
diff --git a/pkgs/games/openttd/default.nix b/pkgs/games/openttd/default.nix
index 1b6b7f26a41e..ff96622cb59c 100644
--- a/pkgs/games/openttd/default.nix
+++ b/pkgs/games/openttd/default.nix
@@ -24,7 +24,7 @@ stdenv.mkDerivation rec {
   '';
 
   meta = {
-    description = ''OpenTTD is an open source clone of the Microprose game "Transport Tycoon Deluxe"'';
+    description = ''Open source clone of the Microprose game "Transport Tycoon Deluxe"'';
     longDescription = ''
       OpenTTD is a transportation economics simulator. In single player mode,
       players control a transportation business, and use rail, road, sea, and air
diff --git a/pkgs/games/opentyrian/default.nix b/pkgs/games/opentyrian/default.nix
index cfae6a4bb3e8..c435bbe5887f 100644
--- a/pkgs/games/opentyrian/default.nix
+++ b/pkgs/games/opentyrian/default.nix
@@ -29,7 +29,7 @@ stdenv.mkDerivation rec {
   ";
 
   meta = {
-    description = ''OpenTyrian is an open source port of the game "Tyrian".'';
+    description = ''Open source port of the game "Tyrian"'';
     homepage = https://opentyrian.googlecode.com/;
     # This does not account of Tyrian data.
     # license = stdenv.lib.licenses.gpl2;
diff --git a/pkgs/games/teeworlds/default.nix b/pkgs/games/teeworlds/default.nix
index c685f11c4c16..5276ec4cc34f 100644
--- a/pkgs/games/teeworlds/default.nix
+++ b/pkgs/games/teeworlds/default.nix
@@ -51,7 +51,7 @@ EOF
   '';
 
   meta = {
-    description = "Teeworlds, a retro multiplayer shooter game";
+    description = "Retro multiplayer shooter game";
 
     longDescription = ''
       Teeworlds is a free online multiplayer game, available for all