summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorTuomas Tynkkynen <tuomas.tynkkynen@iki.fi>2016-01-10 16:45:25 +0200
committerTuomas Tynkkynen <tuomas@tuxera.com>2017-02-14 15:45:09 +0200
commitc86798125b85a6c4fc49520e79b59ed2299f2885 (patch)
treec4941b2be2e751744360cbd35fcd2cf5b3de5f9f /pkgs/games
parentcc442cbdba0d7f4139c3e31b10d407a38bf71c7b (diff)
downloadnixlib-c86798125b85a6c4fc49520e79b59ed2299f2885.tar
nixlib-c86798125b85a6c4fc49520e79b59ed2299f2885.tar.gz
nixlib-c86798125b85a6c4fc49520e79b59ed2299f2885.tar.bz2
nixlib-c86798125b85a6c4fc49520e79b59ed2299f2885.tar.lz
nixlib-c86798125b85a6c4fc49520e79b59ed2299f2885.tar.xz
nixlib-c86798125b85a6c4fc49520e79b59ed2299f2885.tar.zst
nixlib-c86798125b85a6c4fc49520e79b59ed2299f2885.zip
amoeba: init at 1.1
This uses all the patches from Debian since otherwise it would work on
i686 among other things.
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/amoeba/data.nix24
-rw-r--r--pkgs/games/amoeba/default.nix45
-rw-r--r--pkgs/games/amoeba/include-string-h.patch12
3 files changed, 81 insertions, 0 deletions
diff --git a/pkgs/games/amoeba/data.nix b/pkgs/games/amoeba/data.nix
new file mode 100644
index 000000000000..b5c7f4b730b8
--- /dev/null
+++ b/pkgs/games/amoeba/data.nix
@@ -0,0 +1,24 @@
+{ stdenv, fetchurl }:
+
+stdenv.mkDerivation rec {
+  name = "amoeba-data-${version}";
+  version = "1.1";
+
+  src = fetchurl {
+    url = "http://http.debian.net/debian/pool/non-free/a/amoeba-data/amoeba-data_${version}.orig.tar.gz";
+    sha256 = "1bgclr1v63n14bj9nwzm5zxg48nm0cla9bq1rbd5ylxra18k0jbg";
+  };
+
+  installPhase = ''
+    mkdir -p $out/share/amoeba
+    cp demo.dat $out/share/amoeba/
+  '';
+
+  meta = with stdenv.lib; {
+    description = "Fast-paced, polished OpenGL demonstration by Excess (data files)";
+    homepage = https://packages.qa.debian.org/a/amoeba-data.html;
+    license = licenses.unfree;
+    maintainers = [ maintainers.dezgeg ];
+    platforms = platforms.all;
+  };
+}
diff --git a/pkgs/games/amoeba/default.nix b/pkgs/games/amoeba/default.nix
new file mode 100644
index 000000000000..4e5f85f7d5ae
--- /dev/null
+++ b/pkgs/games/amoeba/default.nix
@@ -0,0 +1,45 @@
+{ stdenv, fetchurl, amoeba-data, alsaLib, expat, freetype, gtk2, libvorbis, mesa_glu, pkgconfig }:
+
+stdenv.mkDerivation rec {
+  name = "amoeba-${version}-${debver}";
+  version = "1.1";
+  debver = "29.1";
+
+  srcs = [
+    (fetchurl {
+      url = "http://http.debian.net/debian/pool/contrib/a/amoeba/amoeba_${version}.orig.tar.gz";
+      sha256 = "1hyycw4r36ryka2gab9vzkgs8gq4gqhk08vn29cwak95w0rahgim";
+    })
+    (fetchurl {
+      url = "http://http.debian.net/debian/pool/contrib/a/amoeba/amoeba_${version}-${debver}.debian.tar.xz";
+      sha256 = "1xgi2sqzq97w6hd3dcyq6cka8xmp6nr25qymzhk52cwqh7qb75p3";
+    })
+  ];
+  sourceRoot = "amoeba-1.1.orig";
+
+  prePatch = ''
+    patches="${./include-string-h.patch} $(echo ../debian/patches/*.diff)"
+  '';
+  postPatch = ''
+    sed -i packer/pakfile.cpp -e 's|/usr/share/amoeba|${amoeba-data}/share/amoeba|'
+    sed -i main/linux-config/linux-config.cpp -e 's|libgdk-x11-2.0.so.0|${gtk2}/lib/&|'
+    sed -i main/linux-config/linux-config.cpp -e 's|libgtk-x11-2.0.so.0|${gtk2}/lib/&|'
+  '';
+
+  nativeBuildInputs = [ pkgconfig ];
+  buildInputs = [ alsaLib expat freetype gtk2 libvorbis mesa_glu ];
+
+  installPhase = ''
+    mkdir -p $out/bin $out/share/man/man1/
+    cp amoeba $out/bin/
+    cp ../debian/amoeba.1 $out/share/man/man1/
+  '';
+
+  meta = with stdenv.lib; {
+    description = "Fast-paced, polished OpenGL demonstration by Excess";
+    homepage = https://packages.qa.debian.org/a/amoeba.html;
+    license = licenses.gpl2; # Engine is GPLv2, data files in amoeba-data nonfree
+    maintainers = [ maintainers.dezgeg ];
+    platforms = platforms.linux;
+  };
+}
diff --git a/pkgs/games/amoeba/include-string-h.patch b/pkgs/games/amoeba/include-string-h.patch
new file mode 100644
index 000000000000..828cab88d989
--- /dev/null
+++ b/pkgs/games/amoeba/include-string-h.patch
@@ -0,0 +1,12 @@
+diff --git a/image/png_image.cpp b/image/png_image.cpp
+index 37875fc..1531d6f 100644
+--- a/image/png_image.cpp
++++ b/image/png_image.cpp
+@@ -4,6 +4,7 @@
+ 
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ 
+ #include <png.h>
+ #include "png_image.h"