summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2013-02-17 08:19:40 -0500
committerShea Levy <shea@shealevy.com>2013-02-17 08:19:40 -0500
commitc42d77aa35c50035304d8c3d3dc9c19981059eab (patch)
tree890403812f124812d134cafe59ef6ada188f2bb8 /pkgs/games
parent1eca5325ebbe2cbe275d8fb277cfc7a9a7a1e860 (diff)
parent9885d040331a9f01fdda4df0ac76e73868667790 (diff)
downloadnixlib-c42d77aa35c50035304d8c3d3dc9c19981059eab.tar
nixlib-c42d77aa35c50035304d8c3d3dc9c19981059eab.tar.gz
nixlib-c42d77aa35c50035304d8c3d3dc9c19981059eab.tar.bz2
nixlib-c42d77aa35c50035304d8c3d3dc9c19981059eab.tar.lz
nixlib-c42d77aa35c50035304d8c3d3dc9c19981059eab.tar.xz
nixlib-c42d77aa35c50035304d8c3d3dc9c19981059eab.tar.zst
nixlib-c42d77aa35c50035304d8c3d3dc9c19981059eab.zip
Merge remote-tracking branch 'upstream/master' into stdenv-updates
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/urbanterror/default.nix67
-rw-r--r--pkgs/games/urbanterror/l_script.patch21
2 files changed, 22 insertions, 66 deletions
diff --git a/pkgs/games/urbanterror/default.nix b/pkgs/games/urbanterror/default.nix
index bffc5ad90d18..535e575fdc40 100644
--- a/pkgs/games/urbanterror/default.nix
+++ b/pkgs/games/urbanterror/default.nix
@@ -1,72 +1,49 @@
 { stdenv, fetchurl, unzip, SDL, mesa, openal, curl }:
 stdenv.mkDerivation rec {
   name = "urbanterror-${version}";
-  version = "4.1";
-  src1 = fetchurl {
-    url = "http://ftp.snt.utwente.nl/pub/games/urbanterror/UrbanTerror_41_FULL.zip";
-    sha256 = "0pr6xpwq8zllc0xsdxl8cfd0zz5fhggw5fsbrizygr6hhdvra1jp";
-  };
-  src2 = fetchurl {
-    url = "http://ftp.snt.utwente.nl/pub/games/urbanterror/iourbanterror/source/complete/ioUrbanTerrorSource_2007_12_20.zip";
-    sha256 = "1s1wq9m7shhvvk7s4400yrmz7dys501i4c9ln1mglc9dhmi8dmcn";
-  };
+  version = "4.2.009";
+  srcs =
+    [ (fetchurl {
+         url = "http://download.urbanterror.info/urt/42/zips/UrbanTerror42_full_009.zip";
+         sha256 = "0m423zy6l1z4kxz55knlh1ypnqq58ghh08i8ziv4lm00ygm6mx2i";
+       })
+      (fetchurl {
+         url = "https://github.com/Barbatos/ioq3-for-UrbanTerror-4/archive/release-4.2.007.tar.gz";
+         sha256 = "1299j0i94697m2bbcgraxfbb7q1g6nc43l1xqlgqvcsjp799mwwn";
+       })
+    ];
   buildInputs = [ unzip SDL mesa openal curl ];
-  unpackPhase = ''
-    mkdir urbanterror
-    cd urbanterror
-    unzip $src1
-    unzip $src2
-  '';
-  patches = [ ./l_script.patch ];
-  patchPhase = ''
-    for d in ioUrbanTerrorClientSource ioUrbanTerrorServerSource
-    do
-      cd "$d"
-      patch -p 0 < "''${patches[0]}"
-      cd ..
-    done
-  '';
+  sourceRoot = "ioq3-for-UrbanTerror-4-release-4.2.007";
   configurePhase = ''
-    cd ioUrbanTerrorClientSource
     echo "USE_OPENAL = 1" > Makefile.local
     echo "USE_OPENAL_DLOPEN = 0" >> Makefile.local
     echo "USE_CURL = 1" >> Makefile.local
     echo "USE_CURL_DLOPEN = 0" >> Makefile.local
-    substituteInPlace code/tools/asm/Makefile --replace -Werror ""
-    cd ..
-  '';
-  buildPhase = ''
-    for d in ioUrbanTerrorClientSource ioUrbanTerrorServerSource
-    do
-      cd $d
-      make
-      cd ..
-    done
   '';
   installPhase = ''
     destDir="$out/opt/urbanterror"
     mkdir -p "$destDir"
     mkdir -p "$out/bin"
-    cp -v ioUrbanTerrorClientSource/build/release-linux-*/ioUrbanTerror.* \
-          "$destDir/ioUrbanTerror"
-    cp -v ioUrbanTerrorServerSource/build/release-linux-*/ioUrTded.* \
-          "$destDir/ioUrTded"
-    cp -rv UrbanTerror/q3ut4 "$destDir"
+    cp -v build/release-linux-*/Quake3-UrT.* \
+          "$destDir/Quake3-UrT"
+    cp -v build/release-linux-*/Quake3-UrT-Ded.* \
+          "$destDir/Quake3-UrT-Ded"
+    cp -rv ../UrbanTerror42/q3ut4 "$destDir"
     cat << EOF > "$out/bin/urbanterror"
-    #!/bin/sh
+    #! ${stdenv.shell}
     cd "$destDir"
-    exec ./ioUrbanTerror "\$@"
+    exec ./Quake3-UrT "\$@"
     EOF
     chmod +x "$out/bin/urbanterror"
     cat << EOF > "$out/bin/urbanterror-ded"
-    #!/bin/sh
+    #! ${stdenv.shell}
     cd "$destDir"
-    exec ./ioUrTded "\$@"
+    exec ./Quake3-UrT-Ded "\$@"
     EOF
     chmod +x "$out/bin/urbanterror-ded"
   '';
   postFixup = ''
-    p=$out/opt/urbanterror/ioUrbanTerror
+    p=$out/opt/urbanterror/Quake3-UrT
     cur_rpath=$(patchelf --print-rpath $p)
     patchelf --set-rpath $cur_rpath:${mesa}/lib $p
   '';
diff --git a/pkgs/games/urbanterror/l_script.patch b/pkgs/games/urbanterror/l_script.patch
deleted file mode 100644
index 8aa176cca8cb..000000000000
--- a/pkgs/games/urbanterror/l_script.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -ur code/botlib/l_script.c kode/botlib/l_script.c
---- code/botlib/l_script.c	2007-10-09 02:47:26.000000000 +0400
-+++ kode/botlib/l_script.c	2012-04-16 02:02:55.170360236 +0400
-@@ -1118,7 +1118,7 @@
- {
- 	if (*string == '\"')
- 	{
--		strcpy(string, string+1);
-+		memmove(string, string+1, strlen(string) - 1);
- 	} //end if
- 	if (string[strlen(string)-1] == '\"')
- 	{
-@@ -1135,7 +1135,7 @@
- {
- 	if (*string == '\'')
- 	{
--		strcpy(string, string+1);
-+		memmove(string, string+1, strlen(string) - 1);
- 	} //end if
- 	if (string[strlen(string)-1] == '\'')
- 	{