summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorAlexander Tsamutali <astsmtl@yandex.ru>2011-10-22 21:04:29 +0000
committerAlexander Tsamutali <astsmtl@yandex.ru>2011-10-22 21:04:29 +0000
commitc10a1a50b81d95a0851dba9730e2983c56eca7e9 (patch)
tree49fee5b77f7843bce18bb7c880190cc6a434a23e /pkgs/games
parent22ff0a19c324681075fa1eb8415f0adf04a1f30b (diff)
downloadnixlib-c10a1a50b81d95a0851dba9730e2983c56eca7e9.tar
nixlib-c10a1a50b81d95a0851dba9730e2983c56eca7e9.tar.gz
nixlib-c10a1a50b81d95a0851dba9730e2983c56eca7e9.tar.bz2
nixlib-c10a1a50b81d95a0851dba9730e2983c56eca7e9.tar.lz
nixlib-c10a1a50b81d95a0851dba9730e2983c56eca7e9.tar.xz
nixlib-c10a1a50b81d95a0851dba9730e2983c56eca7e9.tar.zst
nixlib-c10a1a50b81d95a0851dba9730e2983c56eca7e9.zip
games/alienarena: New nixbuild.
svn path=/nixpkgs/trunk/; revision=29975
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/alienarena/default.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/pkgs/games/alienarena/default.nix b/pkgs/games/alienarena/default.nix
new file mode 100644
index 000000000000..aa7d2f1e9144
--- /dev/null
+++ b/pkgs/games/alienarena/default.nix
@@ -0,0 +1,32 @@
+{ stdenv, fetchurl, pkgconfig, libjpeg, libX11, libXxf86vm, curl, libogg
+, libvorbis, freetype, openal, mesa }:
+stdenv.mkDerivation rec {
+  name = "alienarena-7.52";
+  src = fetchurl {
+    url = "http://icculus.org/alienarena/Files/alienarena-7_52-linux20110929.tar.gz";
+    sha256 = "1s1l3apxsxnd8lyi568y38a1fcdr0gwmc3lkgq2nkc676k4gki3m";
+  };
+  buildInputs = [ pkgconfig libjpeg libX11 curl libogg libvorbis
+                  freetype openal mesa libXxf86vm ];
+  patchPhase = ''
+    substituteInPlace ./configure \
+      --replace libopenal.so.1 ${openal}/lib/libopenal.so.1
+  '';
+  meta = {
+    description = "A free, stand-alone first-person shooter computer game";
+    longDescription = ''
+      Do you like old school deathmatch with modern features? How
+      about rich, colorful, arcade-like atmospheres? How about retro
+      Sci-Fi? Then you're going to love what Alien Arena has in store
+      for you! This game combines some of the very best aspects of
+      such games as Quake III and Unreal Tournament and wraps them up
+      with a retro alien theme, while adding tons of original ideas to
+      make the game quite unique.
+    '';
+    homepage = http://red.planetarena.org;
+    # Engine is under GPLv2, everything else is under
+    license = [ "unfree-redistributable" ];
+    maintainers = with stdenv.lib.maintainers; [ astsmtl ];
+    platforms = with stdenv.lib.platforms; linux;
+  };
+}