summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>2015-05-27 21:56:04 +0200
committerTobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>2015-05-27 22:00:06 +0200
commitb2d7f4b1ba937951fefdd026314512ab0be91508 (patch)
treed1f7fc189bac34f376069294d67abfa3c8551693 /pkgs/games
parent87fd373aac3a1aaa84ddb328d43074aeebc1b133 (diff)
downloadnixlib-b2d7f4b1ba937951fefdd026314512ab0be91508.tar
nixlib-b2d7f4b1ba937951fefdd026314512ab0be91508.tar.gz
nixlib-b2d7f4b1ba937951fefdd026314512ab0be91508.tar.bz2
nixlib-b2d7f4b1ba937951fefdd026314512ab0be91508.tar.lz
nixlib-b2d7f4b1ba937951fefdd026314512ab0be91508.tar.xz
nixlib-b2d7f4b1ba937951fefdd026314512ab0be91508.tar.zst
nixlib-b2d7f4b1ba937951fefdd026314512ab0be91508.zip
Use common licence attributes from lib/licenses.nix
Many (less easily automatically converted) old-style strings
remain.

Where there was any possible ambiguity about the exact version or
variant intended, nothing was changed. IANAL, nor a search robot.

Use `with stdenv.lib` wherever it makes sense.
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/0ad/default.nix7
-rw-r--r--pkgs/games/alienarena/default.nix8
-rw-r--r--pkgs/games/gsb/default.nix6
-rw-r--r--pkgs/games/tremulous/default.nix11
-rw-r--r--pkgs/games/urbanterror/default.nix8
-rw-r--r--pkgs/games/vessel/default.nix6
-rw-r--r--pkgs/games/warsow/default.nix8
-rw-r--r--pkgs/games/worldofgoo/default.nix6
8 files changed, 33 insertions, 27 deletions
diff --git a/pkgs/games/0ad/default.nix b/pkgs/games/0ad/default.nix
index bbcc6f11d1dc..5a0bdcd70a7e 100644
--- a/pkgs/games/0ad/default.nix
+++ b/pkgs/games/0ad/default.nix
@@ -112,10 +112,13 @@ stdenv.mkDerivation rec {
     done <build/resources/0ad.desktop >"$out"/share/applications/0ad.desktop
   '';
 
-  meta = {
+  meta = with stdenv.lib; {
     description = "A free, open-source game of ancient warfare";
     homepage = "http://wildfiregames.com/0ad/";
-    license = [ "GPLv2" "LGPLv2.1" "MIT" "CC BY-SA 3.0" "zlib" ];
+    license = with licenses; [
+      gpl2 lgpl21 mit cc-by-sa-30
+      licenses.zlib # otherwise masked by pkgs.zlib
+    ];
     platforms = [ "x86_64-linux" "i686-linux" ];
   };
 }
diff --git a/pkgs/games/alienarena/default.nix b/pkgs/games/alienarena/default.nix
index b3c2dd14718e..485b52d3d088 100644
--- a/pkgs/games/alienarena/default.nix
+++ b/pkgs/games/alienarena/default.nix
@@ -18,7 +18,7 @@ stdenv.mkDerivation rec {
       --replace libGL.so.1 ${mesa}/lib/libGL.so.1
   '';
 
-  meta = {
+  meta = with stdenv.lib; {
     description = "A free, stand-alone first-person shooter computer game";
     longDescription = ''
       Do you like old school deathmatch with modern features? How
@@ -31,9 +31,9 @@ stdenv.mkDerivation rec {
     '';
     homepage = http://red.planetarena.org;
     # Engine is under GPLv2, everything else is under
-    license = [ "unfree-redistributable" ];
-    maintainers = with stdenv.lib.maintainers; [ astsmtl ];
-    platforms = stdenv.lib.platforms.linux;
+    license = with licenses; unfreeRedistributable;
+    maintainers = with maintainers; [ astsmtl ];
+    platforms = platforms.linux;
     hydraPlatforms = [];
   };
 }
diff --git a/pkgs/games/gsb/default.nix b/pkgs/games/gsb/default.nix
index 642a86ac4de2..a0a25a2ff4b4 100644
--- a/pkgs/games/gsb/default.nix
+++ b/pkgs/games/gsb/default.nix
@@ -54,7 +54,7 @@ stdenv.mkDerivation rec {
     chmod +x $out/bin/GSB
   '';
 
-  meta = {
+  meta = with stdenv.lib; {
     description = "Gratuitous Space Battles";
     longDescription = ''
       a strategy / management / simulation game that does away with all the
@@ -66,8 +66,8 @@ stdenv.mkDerivation rec {
       battle (or at least blow to bits in aesthetically pleasing ways).
     '';
     homepage = http://www.positech.co.uk/gratuitousspacebattles/index.html;
-    license = [ "unfree" ];
-    maintainers = with stdenv.lib.maintainers; [ jcumming ];
+    license = with licenses; unfree;
+    maintainers = with maintainers; [ jcumming ];
     platforms = [ "x86_64-linux" "i686-linux" ] ;
   };
 
diff --git a/pkgs/games/tremulous/default.nix b/pkgs/games/tremulous/default.nix
index 3fcbff42527f..fd80eecfd55c 100644
--- a/pkgs/games/tremulous/default.nix
+++ b/pkgs/games/tremulous/default.nix
@@ -57,7 +57,7 @@ stdenv.mkDerivation rec {
     done
   '';
   dontPatchELF = true;
-  meta = {
+  meta = with stdenv.lib; {
     description = "A game that blends a team based FPS with elements of an RTS";
     longDescription = ''
       Tremulous is a free, open source game that blends a team based FPS with
@@ -70,9 +70,12 @@ stdenv.mkDerivation rec {
       degree), healing functions and much more...
     '';
     homepage = http://www.tremulous.net;
-    license = [ "GPLv2" ];  # media under cc by-sa 2.5
-    maintainers = with stdenv.lib.maintainers; [ astsmtl ];
-    platforms = with stdenv.lib.platforms; linux;
+    license = with licenses; [
+      gpl2
+      cc-by-sa-25 /* media */
+    ];
+    maintainers = with maintainers; [ astsmtl ];
+    platforms = with platforms; linux;
     broken = true;
   };
 }
diff --git a/pkgs/games/urbanterror/default.nix b/pkgs/games/urbanterror/default.nix
index 6b4c6e68bacc..925362be1c58 100644
--- a/pkgs/games/urbanterror/default.nix
+++ b/pkgs/games/urbanterror/default.nix
@@ -47,7 +47,7 @@ stdenv.mkDerivation rec {
     cur_rpath=$(patchelf --print-rpath $p)
     patchelf --set-rpath $cur_rpath:${mesa}/lib $p
   '';
-  meta = {
+  meta = with stdenv.lib; {
     description = "A multiplayer tactical FPS on top of Quake 3 engine";
     longDescription = ''
       Urban Terror is a free multiplayer first person shooter developed by
@@ -57,9 +57,9 @@ stdenv.mkDerivation rec {
       realism". This results in a very unique, enjoyable and addictive game.
     '';
     homepage = http://www.urbanterror.net;
-    license = [ "unfree-redistributable" ];
-    maintainers = with stdenv.lib.maintainers; [ astsmtl ];
-    platforms = stdenv.lib.platforms.linux;
+    license = with licenses; unfreeRedistributable;
+    maintainers = with maintainers; [ astsmtl ];
+    platforms = platforms.linux;
     hydraPlatforms = [];
   };
 }
diff --git a/pkgs/games/vessel/default.nix b/pkgs/games/vessel/default.nix
index cab6a269f93a..4a845a3a17e1 100644
--- a/pkgs/games/vessel/default.nix
+++ b/pkgs/games/vessel/default.nix
@@ -67,7 +67,7 @@ stdenv.mkDerivation rec {
     chmod +x $out/bin/Vessel
   '';
 
-  meta = {
+  meta = with stdenv.lib; {
     description = "A fluid physics based puzzle game";
     longDescription = ''
       Living liquid machines have overrun this world of unstoppable progress,
@@ -76,8 +76,8 @@ stdenv.mkDerivation rec {
       to life, and all the consequences that ensue.
     '';
     homepage = http://www.strangeloopgames.com;
-    license = [ "unfree" ];
-    maintainers = with stdenv.lib.maintainers; [ jcumming ];
+    license = with licenses; unfree;
+    maintainers = with maintainers; [ jcumming ];
   };
 
 }
diff --git a/pkgs/games/warsow/default.nix b/pkgs/games/warsow/default.nix
index 84d15efb810f..83c9b5d52fa5 100644
--- a/pkgs/games/warsow/default.nix
+++ b/pkgs/games/warsow/default.nix
@@ -46,7 +46,7 @@ stdenv.mkDerivation rec {
     cur_rpath=$(patchelf --print-rpath $p)
     patchelf --set-rpath $cur_rpath:${mesa}/lib $p
   '';
-  meta = {
+  meta = with stdenv.lib; {
     description = "Multiplayer FPS game designed for competitive gaming";
     longDescription = ''
       Set in a futuristic cartoon-like world where rocketlauncher-wielding
@@ -56,8 +56,8 @@ stdenv.mkDerivation rec {
     '';
     homepage = http://www.warsow.net;
     # Engine is under GPLv2, everything else is under
-    license = [ "unfree-redistributable" ];
-    maintainers = with stdenv.lib.maintainers; [ astsmtl ];
-    platforms = with stdenv.lib.platforms; linux;
+    license = with licenses; unfreeRedistributable;
+    maintainers = with maintainers; [ astsmtl ];
+    platforms = with platforms; linux;
   };
 }
diff --git a/pkgs/games/worldofgoo/default.nix b/pkgs/games/worldofgoo/default.nix
index 8df3ef1e8403..2382da034534 100644
--- a/pkgs/games/worldofgoo/default.nix
+++ b/pkgs/games/worldofgoo/default.nix
@@ -67,7 +67,7 @@ stdenv.mkDerivation rec {
     chmod +x $out/bin/WorldofGoo
   '';
 
-  meta = {
+  meta = with stdenv.lib; {
     description = "A physics based puzzle game";
     longDescription = ''
       World of Goo is a physics based puzzle / construction game. The millions of Goo
@@ -75,8 +75,8 @@ stdenv.mkDerivation rec {
       game, or that they are extremely delicious.
     '';
     homepage = http://worldofgoo.com;
-    license = [ "unfree" ];
-    maintainers = with stdenv.lib.maintainers; [ jcumming ];
+    license = with licenses; unfree;
+    maintainers = with maintainers; [ jcumming ];
   };
 
 }