summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorJoachim Fasting <joachifm@users.noreply.github.com>2016-04-21 16:21:14 +0200
committerJoachim Fasting <joachifm@users.noreply.github.com>2016-04-21 16:21:14 +0200
commit79de9293c2e797287f917fe61a8ad7eddc6336a3 (patch)
treea69371605cbe66fc255ffa2d8dd30757fa8de8ca /pkgs/games
parenta74aa5bce790b4c334eee51213aba99bb9c03251 (diff)
parentf2cee89b22eb572cfaa24d679a6a6cdf64c5d3d7 (diff)
downloadnixlib-79de9293c2e797287f917fe61a8ad7eddc6336a3.tar
nixlib-79de9293c2e797287f917fe61a8ad7eddc6336a3.tar.gz
nixlib-79de9293c2e797287f917fe61a8ad7eddc6336a3.tar.bz2
nixlib-79de9293c2e797287f917fe61a8ad7eddc6336a3.tar.lz
nixlib-79de9293c2e797287f917fe61a8ad7eddc6336a3.tar.xz
nixlib-79de9293c2e797287f917fe61a8ad7eddc6336a3.tar.zst
nixlib-79de9293c2e797287f917fe61a8ad7eddc6336a3.zip
Merge pull request #14869 from rardiol/factorio
factorio: add explict dependency on cacert for chroot build
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/factorio/fetch.nix4
-rw-r--r--pkgs/games/factorio/fetch.sh2
2 files changed, 3 insertions, 3 deletions
diff --git a/pkgs/games/factorio/fetch.nix b/pkgs/games/factorio/fetch.nix
index 03dc786492a2..78c7faf018ce 100644
--- a/pkgs/games/factorio/fetch.nix
+++ b/pkgs/games/factorio/fetch.nix
@@ -1,4 +1,4 @@
-{ stdenv, curl
+{ stdenv, curl, cacert
 # Begin download parameters
 , username ? ""
 , password ? ""
@@ -20,7 +20,7 @@ stdenv.mkDerivation {
 
   buildInputs = [ curl ];
 
-  inherit url loginUrl username password;
+  inherit url loginUrl username password cacert;
 
   builder = ./fetch.sh;
 
diff --git a/pkgs/games/factorio/fetch.sh b/pkgs/games/factorio/fetch.sh
index ad9766736867..d6549c0a6768 100644
--- a/pkgs/games/factorio/fetch.sh
+++ b/pkgs/games/factorio/fetch.sh
@@ -8,7 +8,7 @@ source $stdenv/setup
 curl="curl \
  --max-redirs 20 \
  --retry 3 \
- --cacert /etc/ssl/certs/ca-bundle.crt \
+ --cacert $cacert/etc/ssl/certs/ca-bundle.crt \
  $curlOpts \
  $NIX_CURL_FLAGS"