summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2017-10-10 19:01:42 -0400
committerJohn Ericson <John.Ericson@Obsidian.Systems>2017-11-05 17:10:53 -0500
commit70d91badf57bbe4cd884e5da22b14662dd36009c (patch)
tree9a69666a2218d4574dbaf8fb852371b8685ae3ec /pkgs/games
parent5ae8f18f4d8216ec987e0f63b7d2b9a416a4ca82 (diff)
downloadnixlib-70d91badf57bbe4cd884e5da22b14662dd36009c.tar
nixlib-70d91badf57bbe4cd884e5da22b14662dd36009c.tar.gz
nixlib-70d91badf57bbe4cd884e5da22b14662dd36009c.tar.bz2
nixlib-70d91badf57bbe4cd884e5da22b14662dd36009c.tar.lz
nixlib-70d91badf57bbe4cd884e5da22b14662dd36009c.tar.xz
nixlib-70d91badf57bbe4cd884e5da22b14662dd36009c.tar.zst
nixlib-70d91badf57bbe4cd884e5da22b14662dd36009c.zip
treewide: Depend on stdenv.cc.bintools instead of binutils directly
One should do this when needed executables at build time. It is more
honest and cross-friendly than refering to binutils directly.
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/brogue/default.nix2
-rw-r--r--pkgs/games/steam/runtime.nix4
2 files changed, 3 insertions, 3 deletions
diff --git a/pkgs/games/brogue/default.nix b/pkgs/games/brogue/default.nix
index 814f4f6c82e6..d48dc8e8006e 100644
--- a/pkgs/games/brogue/default.nix
+++ b/pkgs/games/brogue/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, SDL, ncurses, libtcod, binutils }:
+{ stdenv, fetchurl, SDL, ncurses, libtcod }:
 
 stdenv.mkDerivation rec {
   name = "brogue-${version}";
diff --git a/pkgs/games/steam/runtime.nix b/pkgs/games/steam/runtime.nix
index 82fce93a66ae..1fa17c32d6c7 100644
--- a/pkgs/games/steam/runtime.nix
+++ b/pkgs/games/steam/runtime.nix
@@ -1,4 +1,4 @@
-{ stdenv, steamArch, fetchurl, writeText, python2, dpkg, binutils }:
+{ stdenv, steamArch, fetchurl, writeText, python2, dpkg }:
 
 let input = builtins.getAttr steamArch (import ./runtime-generated.nix { inherit fetchurl; });
 
@@ -7,7 +7,7 @@ let input = builtins.getAttr steamArch (import ./runtime-generated.nix { inherit
 in stdenv.mkDerivation {
   name = "steam-runtime-2016-08-13";
 
-  nativeBuildInputs = [ python2 dpkg binutils ];
+  nativeBuildInputs = [ python2 dpkg stdenv.cc.bintools ];
 
   buildCommand = ''
     mkdir -p $out