summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorOle Jørgen Brønner <olejorgenb@yahoo.no>2017-05-11 08:52:43 +0200
committerJörg Thalheim <Mic92@users.noreply.github.com>2017-05-11 07:52:43 +0100
commit6fef3228f9b7d1ab656f4ba5d7b36ea7b66cd299 (patch)
treeed06c36967c790dead306779de105c36d6fad9ab /pkgs/games
parentfb0410c208b7669327940f7eaabe2e4865c4f198 (diff)
downloadnixlib-6fef3228f9b7d1ab656f4ba5d7b36ea7b66cd299.tar
nixlib-6fef3228f9b7d1ab656f4ba5d7b36ea7b66cd299.tar.gz
nixlib-6fef3228f9b7d1ab656f4ba5d7b36ea7b66cd299.tar.bz2
nixlib-6fef3228f9b7d1ab656f4ba5d7b36ea7b66cd299.tar.lz
nixlib-6fef3228f9b7d1ab656f4ba5d7b36ea7b66cd299.tar.xz
nixlib-6fef3228f9b7d1ab656f4ba5d7b36ea7b66cd299.tar.zst
nixlib-6fef3228f9b7d1ab656f4ba5d7b36ea7b66cd299.zip
sgtpuzzles: fix broken gtk3 file dialog (#25694)
include wrapGAppsHook for file dialog to work
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/sgt-puzzles/default.nix32
1 files changed, 17 insertions, 15 deletions
diff --git a/pkgs/games/sgt-puzzles/default.nix b/pkgs/games/sgt-puzzles/default.nix
index 6718b3b0b5e6..bb9772dae72a 100644
--- a/pkgs/games/sgt-puzzles/default.nix
+++ b/pkgs/games/sgt-puzzles/default.nix
@@ -1,22 +1,25 @@
-{stdenv, gtk3, pkgconfig, libX11, perl, fetchurl, automake115x, autoconf}:
-let
+{ stdenv, fetchurl
+, gtk3, libX11
+, makeWrapper, pkgconfig, perl, autoreconfHook, wrapGAppsHook
+}:
+
+stdenv.mkDerivation rec {
+  name = "sgt-puzzles-r${version}";
   version = "20170228.1f613ba";
-  buildInputs = [
-    gtk3 pkgconfig libX11 perl automake115x autoconf
-  ];
-in
-stdenv.mkDerivation {
+
   src = fetchurl {
    url = "http://www.chiark.greenend.org.uk/~sgtatham/puzzles/puzzles-${version}.tar.gz";
    sha256 = "02nqc18fhvxr545wgk55ly61fi0a06q61ljzwadprqxa1n0g0fz5";
   };
-  name = "sgt-puzzles-r" + version;
-  inherit buildInputs;
+
+  nativeBuildInputs = [ autoreconfHook makeWrapper pkgconfig perl wrapGAppsHook ];
+
+  buildInputs = [ gtk3 libX11 ];
+
   makeFlags = ["prefix=$(out)" "gamesdir=$(out)/bin"];
   preInstall = ''
     mkdir -p "$out"/{bin,share/doc/sgtpuzzles}
     cp gamedesc.txt LICENCE README "$out/share/doc/sgtpuzzles"
-    cp LICENCE "$out/share/doc/sgtpuzzles/LICENSE"
   '';
   # SGT Puzzles use generic names like net, map, etc.
   # Create symlinks with sgt-puzzle- prefix for possibility of
@@ -33,12 +36,11 @@ stdenv.mkDerivation {
     export NIX_CFLAGS_COMPILE="$NIX_CFLAGS_COMPILE -Wno-error"
     cp Makefile.gtk Makefile
   '';
-  meta = {
-    inherit version;
+  meta = with stdenv.lib; {
     description = "Simon Tatham's portable puzzle collection";
-    license = stdenv.lib.licenses.mit ;
-    maintainers = [stdenv.lib.maintainers.raskin];
-    platforms = stdenv.lib.platforms.linux;
+    license = licenses.mit;
+    maintainers = [ maintainers.raskin ];
+    platforms = platforms.linux;
     homepage = "http://www.chiark.greenend.org.uk/~sgtatham/puzzles/";
   };
 }