summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2014-09-08 11:42:09 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2014-09-08 11:42:09 +0200
commit585983bc954d043d40a14b29c0bddca42bb9cdfb (patch)
treef64c271969e6fa21b7e3e49da7653a92f2d6face /pkgs/games
parentff85b53c5f266a6a7bbcf8b30c4eea7c3f6160ee (diff)
parenta71744392b6964e624d3ae968bee660731b7d271 (diff)
downloadnixlib-585983bc954d043d40a14b29c0bddca42bb9cdfb.tar
nixlib-585983bc954d043d40a14b29c0bddca42bb9cdfb.tar.gz
nixlib-585983bc954d043d40a14b29c0bddca42bb9cdfb.tar.bz2
nixlib-585983bc954d043d40a14b29c0bddca42bb9cdfb.tar.lz
nixlib-585983bc954d043d40a14b29c0bddca42bb9cdfb.tar.xz
nixlib-585983bc954d043d40a14b29c0bddca42bb9cdfb.tar.zst
nixlib-585983bc954d043d40a14b29c0bddca42bb9cdfb.zip
Merge remote-tracking branch 'origin/staging'
Conflicts:
	pkgs/applications/version-management/subversion/default.nix
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/spring/default.nix2
-rw-r--r--pkgs/games/warzone2100/default.nix12
2 files changed, 10 insertions, 4 deletions
diff --git a/pkgs/games/spring/default.nix b/pkgs/games/spring/default.nix
index 539be06bf7fa..69387f0cfd3a 100644
--- a/pkgs/games/spring/default.nix
+++ b/pkgs/games/spring/default.nix
@@ -28,6 +28,8 @@ stdenv.mkDerivation rec {
   # reported upstream http://springrts.com/mantis/view.php?id=4305
   #enableParallelBuilding = true; # occasionally missing generated files on Hydra
 
+  NIX_CFLAGS_COMPILE = "-fpermissive"; # GL header minor incompatibility
+
   postInstall = ''
     wrapProgram "$out/bin/spring" \
       --prefix LD_LIBRARY_PATH : "${stdenv.gcc.gcc}/lib64:${stdenv.gcc.gcc}/lib::${systemd}/lib"
diff --git a/pkgs/games/warzone2100/default.nix b/pkgs/games/warzone2100/default.nix
index 284d420fe7f2..248b58a4e1a5 100644
--- a/pkgs/games/warzone2100/default.nix
+++ b/pkgs/games/warzone2100/default.nix
@@ -28,9 +28,13 @@ stdenv.mkDerivation rec {
                       --replace "which %s" "${which}/bin/which %s"
   '';
   configureFlags = "--with-backend=qt --with-distributor=NixOS";
+
+  NIX_CFLAGS_COMPILE = "-fpermissive"; # GL header minor incompatibility
+
   postInstall = []
     ++ stdenv.lib.optional withVideos "cp ${sequences_src} $out/share/warzone2100/sequences.wz";
-  meta = {
+
+  meta = with stdenv.lib; {
     description = "A free RTS game, originally developed by Pumpkin Studios";
     longDescription = ''
         Warzone 2100 is an open source real-time strategy and real-time tactics
@@ -44,8 +48,8 @@ stdenv.mkDerivation rec {
       variety of possible units and tactics. 
     '';
     homepage = http://wz2100.net;
-    license = [ "GPLv2+" ];
-    maintainers = with stdenv.lib.maintainers; [ astsmtl ];
-    platforms = with stdenv.lib.platforms; linux;
+    license = licenses.gpl2Plus;
+    maintainers = [ maintainers.astsmtl ];
+    platforms = platforms.linux;
   };
 }