summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorNathan Moore <nathanmoore@cox.net>2016-07-05 18:33:51 -0700
committerNathan Moore <nathanmoore@cox.net>2016-07-05 18:33:51 -0700
commit09f366a360fee8fae4d0e1aa642725738094ea64 (patch)
tree3897c1b4e65949e08ad1f8ad9ef62c5f93ca512b /pkgs/games
parent6d16ececdd4c59437c7a6db7ab1cb030e24d627e (diff)
downloadnixlib-09f366a360fee8fae4d0e1aa642725738094ea64.tar
nixlib-09f366a360fee8fae4d0e1aa642725738094ea64.tar.gz
nixlib-09f366a360fee8fae4d0e1aa642725738094ea64.tar.bz2
nixlib-09f366a360fee8fae4d0e1aa642725738094ea64.tar.lz
nixlib-09f366a360fee8fae4d0e1aa642725738094ea64.tar.xz
nixlib-09f366a360fee8fae4d0e1aa642725738094ea64.tar.zst
nixlib-09f366a360fee8fae4d0e1aa642725738094ea64.zip
solarus: init at 1.4.5
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/solarus/default.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/pkgs/games/solarus/default.nix b/pkgs/games/solarus/default.nix
new file mode 100644
index 000000000000..32142a2834e3
--- /dev/null
+++ b/pkgs/games/solarus/default.nix
@@ -0,0 +1,32 @@
+{ stdenv, fetchFromGitHub, cmake, luajit,
+  SDL2, SDL2_image, SDL2_ttf, physfs,
+  openal, libmodplug, libvorbis}:
+
+stdenv.mkDerivation rec {
+  name = "solarus-${version}";
+  version = "1.4.5";
+    
+  src = fetchFromGitHub {
+    owner = "christopho";
+    repo = "solarus";
+    rev = "d9fdb9fdb4e1b9fc384730a9279d134ae9f2c70e";
+    sha256 = "0xjx789d6crm322wmkqyq9r288vddsha59yavhy78c4r01gs1p5v";
+  };
+  
+  buildInputs = [ cmake luajit SDL2
+    SDL2_image SDL2_ttf physfs
+    openal libmodplug libvorbis ];
+
+  meta = with stdenv.lib; {
+    description = "A Zelda-like ARPG game engine";
+    longDescription = ''
+      Solarus is a game engine for Zelda-like ARPG games written in lua.
+      Many full-fledged games have been writen for the engine.
+    '';
+    homepage = http://www.solarus-games.org;
+    license = licenses.gpl3;
+    maintainers = [ maintainers.Nate-Devv ];
+    platforms = platforms.linux;
+  };
+  
+}