summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2017-02-21 21:41:45 +0100
committerProfpatsch <mail@profpatsch.de>2017-03-06 19:37:24 +0100
commit07bf113bbe79640ad044177751b2da9dc94b70c2 (patch)
treefd4da7f7c41bb0fc977a048a00d7239b169631e8 /pkgs/games
parent34afc31c49b067879c3c49b29c67e2a1bc806685 (diff)
downloadnixlib-07bf113bbe79640ad044177751b2da9dc94b70c2.tar
nixlib-07bf113bbe79640ad044177751b2da9dc94b70c2.tar.gz
nixlib-07bf113bbe79640ad044177751b2da9dc94b70c2.tar.bz2
nixlib-07bf113bbe79640ad044177751b2da9dc94b70c2.tar.lz
nixlib-07bf113bbe79640ad044177751b2da9dc94b70c2.tar.xz
nixlib-07bf113bbe79640ad044177751b2da9dc94b70c2.tar.zst
nixlib-07bf113bbe79640ad044177751b2da9dc94b70c2.zip
garden-of-coloured-lights: init at 1.0.9
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/garden-of-coloured-lights/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/pkgs/games/garden-of-coloured-lights/default.nix b/pkgs/games/garden-of-coloured-lights/default.nix
new file mode 100644
index 000000000000..b8550b3712e3
--- /dev/null
+++ b/pkgs/games/garden-of-coloured-lights/default.nix
@@ -0,0 +1,27 @@
+{ stdenv, fetchurl, autoconf, automake, allegro }:
+
+stdenv.mkDerivation rec {
+  name = "garden-of-coloured-lights-${version}";
+  version = "1.0.9";
+
+  buildInputs = [ allegro autoconf automake ];
+
+  prePatch = ''
+    noInline='s/inline //'
+    sed -e "$noInline" -i src/stuff.c
+    sed -e "$noInline" -i src/stuff.h
+  '';
+
+  src = fetchurl {
+    url = "mirror://sourceforge/garden/${version}/garden-${version}.tar.gz";
+    sha256 = "1qsj4d7r22m5f9f5f6cyvam1y5q5pbqvy5058r7w0k4s48n77y6s";
+  };
+
+  meta = with stdenv.lib; {
+    description = "Old-school vertical shoot-em-up / bullet hell";
+    homepage = http://garden.sourceforge.net/drupal/;
+    maintainers = with maintainers; [ profpatsch ];
+    license = licenses.gpl3;
+  };
+
+}