summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorWilliam A. Kennington III <william@wkennington.com>2015-05-07 01:44:49 -0700
committerWilliam A. Kennington III <william@wkennington.com>2015-05-07 01:44:49 -0700
commit074c4a7f789449f6212b6e5c5ead26969809e534 (patch)
treef2deafc4e0ba5a95216fe1a09bb8cf2b87fbb25b /pkgs/games
parentd3f3317632f40b403afab3cc055c78ead00e93bd (diff)
parent10bb715c077ced71defbd4318cebe77b64b7a279 (diff)
downloadnixlib-074c4a7f789449f6212b6e5c5ead26969809e534.tar
nixlib-074c4a7f789449f6212b6e5c5ead26969809e534.tar.gz
nixlib-074c4a7f789449f6212b6e5c5ead26969809e534.tar.bz2
nixlib-074c4a7f789449f6212b6e5c5ead26969809e534.tar.lz
nixlib-074c4a7f789449f6212b6e5c5ead26969809e534.tar.xz
nixlib-074c4a7f789449f6212b6e5c5ead26969809e534.tar.zst
nixlib-074c4a7f789449f6212b6e5c5ead26969809e534.zip
Merge remote-tracking branch 'upstream/master' into staging
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/Allure/default.nix19
-rw-r--r--pkgs/games/LambdaHack/default.nix35
-rw-r--r--pkgs/games/hedgewars/default.nix16
-rw-r--r--pkgs/games/uqm/3dovideo.nix13
-rw-r--r--pkgs/games/xmoto/default.nix44
-rw-r--r--pkgs/games/xmoto/src-for-default.nix9
-rw-r--r--pkgs/games/xmoto/src-info-for-default.nix7
7 files changed, 34 insertions, 109 deletions
diff --git a/pkgs/games/Allure/default.nix b/pkgs/games/Allure/default.nix
deleted file mode 100644
index 63d6a0a2fb27..000000000000
--- a/pkgs/games/Allure/default.nix
+++ /dev/null
@@ -1,19 +0,0 @@
-# This file was auto-generated by cabal2nix. Please do NOT edit manually!
-
-{ cabal, enummapsetTh, filepath, LambdaHack, text }:
-
-cabal.mkDerivation (self: {
-  pname = "Allure";
-  version = "0.4.100.0";
-  sha256 = "15rkj5xab23wqr2d44xbri7hggbb3zmmka41xfiscqq4ifagfj4m";
-  isLibrary = false;
-  isExecutable = true;
-  buildDepends = [ enummapsetTh filepath LambdaHack text ];
-  testDepends = [ enummapsetTh filepath LambdaHack text ];
-  meta = {
-    homepage = "http://allureofthestars.com";
-    description = "Near-future Sci-Fi roguelike and tactical squad game";
-    license = "AGPL";
-    platforms = self.ghc.meta.platforms;
-  };
-})
diff --git a/pkgs/games/LambdaHack/default.nix b/pkgs/games/LambdaHack/default.nix
deleted file mode 100644
index 2130c423cfeb..000000000000
--- a/pkgs/games/LambdaHack/default.nix
+++ /dev/null
@@ -1,35 +0,0 @@
-# This file was auto-generated by cabal2nix. Please do NOT edit manually!
-
-{ cabal, assertFailure, async, binary, dataDefault, deepseq
-, enummapsetTh, filepath, gtk, hashable, hsini, keys, miniutter
-, mtl, prettyShow, random, stm, text, transformers
-, unorderedContainers, vector, vectorBinaryInstances, zlib
-}:
-
-cabal.mkDerivation (self: {
-  pname = "LambdaHack";
-  version = "0.4.100.0";
-  sha256 = "15v3aagwsh180603an3wd7rfgbjzgamdw270ciw2m03v8pkg9d28";
-  isLibrary = true;
-  isExecutable = true;
-  buildDepends = [
-    assertFailure async binary dataDefault deepseq enummapsetTh
-    filepath gtk hashable hsini keys miniutter mtl prettyShow random
-    stm text transformers unorderedContainers vector
-    vectorBinaryInstances zlib
-  ];
-  testDepends = [
-    assertFailure async binary dataDefault deepseq enummapsetTh
-    filepath hashable hsini keys miniutter mtl prettyShow random stm
-    text transformers unorderedContainers vector vectorBinaryInstances
-    zlib
-  ];
-  pkgconfigDepends = [ gtk ];
-  meta = {
-    homepage = "http://github.com/LambdaHack/LambdaHack";
-    description = "A game engine library for roguelike dungeon crawlers";
-    license = self.stdenv.lib.licenses.bsd3;
-    platforms = self.ghc.meta.platforms;
-    maintainers = with self.stdenv.lib.maintainers; [ andres ];
-  };
-})
diff --git a/pkgs/games/hedgewars/default.nix b/pkgs/games/hedgewars/default.nix
index 3768375d6259..042d4f9fd4aa 100644
--- a/pkgs/games/hedgewars/default.nix
+++ b/pkgs/games/hedgewars/default.nix
@@ -1,8 +1,13 @@
-{ SDL_image, SDL_ttf, SDL_net, fpc, qt4 , ghc, ffmpeg, freeglut, network, vector
+{ SDL_image, SDL_ttf, SDL_net, fpc, qt4, ghcWithPackages, ffmpeg, freeglut
 , stdenv, makeWrapper, fetchurl, cmake, pkgconfig, lua5_1, SDL, SDL_mixer
-, utf8String, bytestringShow, hslogger, random, dataenc, zlib, libpng, mesa
+, zlib, libpng, mesa
 }:
 
+let
+  ghc = ghcWithPackages (pkgs: with pkgs; [
+          network vector utf8-string bytestring-show random hslogger dataenc
+        ]);
+in
 stdenv.mkDerivation rec {
   version = "0.9.20.5";
   name = "hedgewars-${version}";
@@ -12,9 +17,8 @@ stdenv.mkDerivation rec {
   };
 
   buildInputs = [
-    SDL_ttf SDL_net network vector utf8String bytestringShow hslogger random
-    cmake pkgconfig lua5_1 SDL SDL_mixer SDL_image fpc qt4 ghc ffmpeg freeglut
-    dataenc makeWrapper
+    SDL_ttf SDL_net cmake pkgconfig lua5_1 SDL SDL_mixer SDL_image fpc
+    qt4 ghc ffmpeg freeglut makeWrapper
   ];
 
   patches = [ ./fix-ghc-7.8-build-failure.diff ];
@@ -64,6 +68,6 @@ stdenv.mkDerivation rec {
        hedgehog or hedgehogs after a player's or CPU turn is shown only when
        all movement on the battlefield has ceased).'';
     maintainers = maintainers.kragniz;
-    platforms = platforms.all;
+    platforms = ghc.meta.platforms;
   };
 }
diff --git a/pkgs/games/uqm/3dovideo.nix b/pkgs/games/uqm/3dovideo.nix
index c52cc5ed879c..ca5a1197a327 100644
--- a/pkgs/games/uqm/3dovideo.nix
+++ b/pkgs/games/uqm/3dovideo.nix
@@ -15,7 +15,7 @@ let
     slides.intro = 3DOVID:addons/3dovideo/intro/intro.duk
   '' + concatMapStrings makeSpin (range 0 24));
 
-  helper = with haskellPackages; cabal.mkDerivation (self: {
+  helper = with haskellPackages; mkDerivation {
     pname = "uqm3donix";
     version = "0.1.0.0";
 
@@ -27,14 +27,11 @@ let
     isLibrary = false;
     isExecutable = true;
 
-    buildDepends = [ binary filepath tar ];
+    buildDepends = [ base binary bytestring filepath tar ];
 
-    meta = {
-      description = "Extract video files from a Star Control II 3DO image";
-      license = self.stdenv.lib.licenses.bsd3;
-      platforms = self.ghc.meta.platforms;
-    };
-  });
+    description = "Extract video files from a Star Control II 3DO image";
+    license = stdenv.lib.licenses.bsd3;
+  };
 
 in stdenv.mkDerivation {
   name = "uqm-3dovideo";
diff --git a/pkgs/games/xmoto/default.nix b/pkgs/games/xmoto/default.nix
index 5695bb5b4294..7d4f2e53a941 100644
--- a/pkgs/games/xmoto/default.nix
+++ b/pkgs/games/xmoto/default.nix
@@ -1,32 +1,26 @@
-a :  
-let 
-  s = import ./src-for-default.nix;
-  buildInputs = with a; [
+{ stdenv, fetchurl, chipmunk, sqlite, curl, zlib, bzip2, libjpeg
+, libpng, freeglut, mesa, SDL, SDL_mixer, SDL_image, SDL_net
+, SDL_ttf, lua5, ode, libxdg_basedir, libxml2 }:
+
+stdenv.mkDerivation rec {
+  name = "xmoto-${version}";
+  version = "0.5.11";
+
+  src = fetchurl {
+    url = "http://download.tuxfamily.org/xmoto/xmoto/${version}/xmoto-${version}-src.tar.gz";
+    sha256 = "1ci6r8zd0l7z28cy92ddf9dmqbdqwinz2y1cny34c61b57wsd155";
+  };
+
+  buildInputs = [
     chipmunk sqlite curl zlib bzip2 libjpeg libpng
     freeglut mesa SDL SDL_mixer SDL_image SDL_net SDL_ttf 
     lua5 ode libxdg_basedir libxml2
   ];
-in
-rec {
-  src = a.fetchUrlFromSrcInfo s;
-
-  inherit (s) name;
-  inherit buildInputs;
-  configureFlags = [];
-
-  /* doConfigure should be removed if not needed */
-  phaseNames = [ "patchIncludes" "doConfigure" "doMakeInstall"];
-  patchIncludes = a.fullDepEntry ''
-    sed -e '1i#include <sys/types.h>' -i src/helpers//System.cpp
-    sed -e '1i#include <unistd.h>' -i src/helpers//System.cpp
-  '' ["doUnpack" "minInit"];
 
-  meta = {
-    description = "X-Moto - obstacled race game";
-    maintainers = [
-      a.lib.maintainers.raskin
-      a.lib.maintainers.viric
-    ];
-    platforms = a.lib.platforms.linux;
+  meta = with stdenv.lib; {
+    description = "Obstacled race game";
+    homepage = http://xmoto.tuxfamily.org;
+    maintainers = with maintainers; [ raskin viric pSub ];
+    platforms = platforms.linux;
   };
 }
diff --git a/pkgs/games/xmoto/src-for-default.nix b/pkgs/games/xmoto/src-for-default.nix
deleted file mode 100644
index beb3f6af1645..000000000000
--- a/pkgs/games/xmoto/src-for-default.nix
+++ /dev/null
@@ -1,9 +0,0 @@
-rec {
-   version="0.5.11";
-   name="xmoto-0.5.11";
-   hash="1ci6r8zd0l7z28cy92ddf9dmqbdqwinz2y1cny34c61b57wsd155";
-   url="http://download.tuxfamily.org/xmoto/xmoto/${version}/xmoto-${version}-src.tar.gz";
-   advertisedUrl="http://download.tuxfamily.org/xmoto/xmoto/0.5.11/xmoto-0.5.11-src.tar.gz";
-  
-  
-}
diff --git a/pkgs/games/xmoto/src-info-for-default.nix b/pkgs/games/xmoto/src-info-for-default.nix
deleted file mode 100644
index 8d5d3f49822c..000000000000
--- a/pkgs/games/xmoto/src-info-for-default.nix
+++ /dev/null
@@ -1,7 +0,0 @@
-{
-  downloadPage = "http://xmoto.tuxfamily.org/";
-  baseName = "xmoto";
-  sourceRegexp = "xmoto-.*-src[.]tar[.].*";
-  versionExtractorSedScript = ''$dashDelimitedVersion'';
-  versionReferenceCreator=''$(replaceAllVersionOccurences)'';
-}