summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorJoel Taylor <me@joelt.io>2014-08-23 18:26:55 -0700
committerJoel Taylor <me@joelt.io>2014-09-09 13:54:57 -0700
commitfa9b1f9cda5e44795d02df54defc6e8b9a0b2132 (patch)
tree9a546d08fd70d7124f74223e9aaaca9fee999e49 /pkgs/development
parent6f949b2e872c8ef3d8c53c083506187c56afc85e (diff)
downloadnixlib-fa9b1f9cda5e44795d02df54defc6e8b9a0b2132.tar
nixlib-fa9b1f9cda5e44795d02df54defc6e8b9a0b2132.tar.gz
nixlib-fa9b1f9cda5e44795d02df54defc6e8b9a0b2132.tar.bz2
nixlib-fa9b1f9cda5e44795d02df54defc6e8b9a0b2132.tar.lz
nixlib-fa9b1f9cda5e44795d02df54defc6e8b9a0b2132.tar.xz
nixlib-fa9b1f9cda5e44795d02df54defc6e8b9a0b2132.tar.zst
nixlib-fa9b1f9cda5e44795d02df54defc6e8b9a0b2132.zip
build nix head successfully
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/llvm/3.3/clang.nix4
-rw-r--r--pkgs/development/compilers/llvm/3.4/clang.nix4
2 files changed, 4 insertions, 4 deletions
diff --git a/pkgs/development/compilers/llvm/3.3/clang.nix b/pkgs/development/compilers/llvm/3.3/clang.nix
index 72287560b245..262e0bff2483 100644
--- a/pkgs/development/compilers/llvm/3.3/clang.nix
+++ b/pkgs/development/compilers/llvm/3.3/clang.nix
@@ -1,9 +1,5 @@
 { stdenv, fetchurl, perl, groff, llvm, cmake, libxml2, python }:
 
-# be sure not to rebuild clang on darwin; some packages request it specifically
-# we need to fix those
-assert stdenv.isDarwin -> stdenv.gcc.nativeTools;
-
 let
   version = "3.3";
   gccReal = if (stdenv.gcc.gcc or null) == null then stdenv.gcc else stdenv.gcc.gcc;
diff --git a/pkgs/development/compilers/llvm/3.4/clang.nix b/pkgs/development/compilers/llvm/3.4/clang.nix
index 6ec3f7bf44a3..fc33a7809a6c 100644
--- a/pkgs/development/compilers/llvm/3.4/clang.nix
+++ b/pkgs/development/compilers/llvm/3.4/clang.nix
@@ -1,5 +1,9 @@
 { stdenv, fetch, cmake, libxml2, libedit, llvm, version, clang-tools-extra_src }:
 
+# be sure not to rebuild clang on darwin; some packages request it specifically
+# we need to fix those
+assert stdenv.isDarwin -> stdenv.gcc.nativeTools;
+
 stdenv.mkDerivation {
   name = "clang-${version}";