summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorMatthew Bauer <mjbauer95@gmail.com>2017-09-01 15:11:12 -0500
committerMatthew Bauer <mjbauer95@gmail.com>2017-09-01 15:11:12 -0500
commitf8f338463882f0f7a026de9f862eacfebd0e4e86 (patch)
tree7d882b6fa827339fec6e39bcb951215a47bd592d /pkgs/development
parent017561209e933f3de086e04211dc48cf37d1ee82 (diff)
downloadnixlib-f8f338463882f0f7a026de9f862eacfebd0e4e86.tar
nixlib-f8f338463882f0f7a026de9f862eacfebd0e4e86.tar.gz
nixlib-f8f338463882f0f7a026de9f862eacfebd0e4e86.tar.bz2
nixlib-f8f338463882f0f7a026de9f862eacfebd0e4e86.tar.lz
nixlib-f8f338463882f0f7a026de9f862eacfebd0e4e86.tar.xz
nixlib-f8f338463882f0f7a026de9f862eacfebd0e4e86.tar.zst
nixlib-f8f338463882f0f7a026de9f862eacfebd0e4e86.zip
xcbuild: fix sdk dir name issue
Previously, this error was coming up in xcbuild:

ld: malformed 32-bit x.y.z version number: 1068638

It’s an interesting error because it only happens with certain hashes for the
nixpkgs sdk. For instance, on latest nixpkgs unstable channel, the hash for the
xcbuild sdk is:

/nix/store/w6mwbdaz9calyii0fyxspl51f1068638-nix.nixpkgs.sdk

that is an issue we pass -isysroot ${sdk} to clang where it will interpret that
hanging "1068638". It would probably go away as soon as the hash changes but
this hacky fix will solve the problem.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/xcbuild/platform.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/pkgs/development/tools/xcbuild/platform.nix b/pkgs/development/tools/xcbuild/platform.nix
index 31692d9bee68..df1e38fb4deb 100644
--- a/pkgs/development/tools/xcbuild/platform.nix
+++ b/pkgs/development/tools/xcbuild/platform.nix
@@ -228,6 +228,6 @@ stdenv.mkDerivation {
 
     mkdir -p $out/Developer/SDKs/
     cd $out/Developer/SDKs/
-    ln -s ${sdk}
+    cp -r ${sdk} nix.nixpkgs.sdk
   '';
 }