summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorAustin Seipp <aseipp@pobox.com>2018-03-29 21:13:11 -0500
committerAustin Seipp <aseipp@pobox.com>2018-04-01 15:18:47 -0500
commitf71b066d60918be31164707613e6f4ad62c8af0f (patch)
tree34cd6ef9af8ba3c1a359224665ecba2d3b6e13f4 /pkgs/development
parent0d04d010211e02b25a30b9a60d983ea1002b6943 (diff)
downloadnixlib-f71b066d60918be31164707613e6f4ad62c8af0f.tar
nixlib-f71b066d60918be31164707613e6f4ad62c8af0f.tar.gz
nixlib-f71b066d60918be31164707613e6f4ad62c8af0f.tar.bz2
nixlib-f71b066d60918be31164707613e6f4ad62c8af0f.tar.lz
nixlib-f71b066d60918be31164707613e6f4ad62c8af0f.tar.xz
nixlib-f71b066d60918be31164707613e6f4ad62c8af0f.tar.zst
nixlib-f71b066d60918be31164707613e6f4ad62c8af0f.zip
nixpkgs: remove all Java 9 expressions
Java 9 is EOL, and we no longer need it with JDK 10 builds bootstrapped via JDK
10.

Signed-off-by: Austin Seipp <aseipp@pobox.com>
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/openjdk/9.nix262
-rw-r--r--pkgs/development/compilers/openjdk/fix-java-home-jdk9.patch14
-rw-r--r--pkgs/development/compilers/openjdk/read-truststore-from-env-jdk9.patch20
-rw-r--r--pkgs/development/compilers/openjdk/swing-use-gtk-jdk9.patch26
-rw-r--r--pkgs/development/compilers/oraclejdk/jdk9-linux.nix158
5 files changed, 0 insertions, 480 deletions
diff --git a/pkgs/development/compilers/openjdk/9.nix b/pkgs/development/compilers/openjdk/9.nix
deleted file mode 100644
index 7ac3931c93d7..000000000000
--- a/pkgs/development/compilers/openjdk/9.nix
+++ /dev/null
@@ -1,262 +0,0 @@
-{ stdenv, lib, fetchurl, bash, cpio, pkgconfig, file, which, unzip, zip, cups, freetype
-, alsaLib, bootjdk, cacert, perl, liberation_ttf, fontconfig, zlib, lndir
-, libX11, libICE, libXrender, libXext, libXt, libXtst, libXi, libXinerama, libXcursor
-, libjpeg, giflib
-, setJavaClassPath
-, minimal ? false
-#, enableInfinality ? true # font rendering patch
-, enableGnome2 ? true, gtk2, gnome_vfs, glib, GConf
-}:
-
-let
-
-  /**
-   * The JRE libraries are in directories that depend on the CPU.
-   */
-  architecture =
-    if stdenv.system == "i686-linux" then
-      "i386"
-    else if stdenv.system == "x86_64-linux" then
-      "amd64"
-    else
-      throw "openjdk requires i686-linux or x86_64 linux";
-
-  update = "9.0.4";
-  build = "12";
-  baseurl = "http://hg.openjdk.java.net/jdk-updates/jdk9u";
-  repover = "jdk-${update}+${build}";
-  paxflags = if stdenv.isi686 then "msp" else "m";
-  jdk9 = fetchurl {
-             url = "${baseurl}/archive/${repover}.tar.gz";
-             sha256 = "06hnrzkwxgrfq26il1mjyl6wgb7x3qym69pjbddhl9m29n2si3jh";
-          };
-  langtools = fetchurl {
-             url = "${baseurl}/langtools/archive/${repover}.tar.gz";
-             sha256 = "16xqnqn773p6ywcdjx801vbng2skjal7svydn0s7wf3ldqzx64mi";
-          };
-  hotspot = fetchurl {
-             url = "${baseurl}/hotspot/archive/${repover}.tar.gz";
-             sha256 = "0g5ddffl2qykrjf17ac9as60rd4sfyv7s2fpgjn86k4a69gkx93v";
-          };
-  corba = fetchurl {
-             url = "${baseurl}/corba/archive/${repover}.tar.gz";
-             sha256 = "14585dzs2mfzgzrnbvc062pigngs35hajwpr22m6fzbm7580vnqk";
-          };
-  jdk = fetchurl {
-             url = "${baseurl}/jdk/archive/${repover}.tar.gz";
-             sha256 = "16595jdg3y9zy70q8i615a7d6w0zzbydfxylvaq42wrsc7jw733h";
-          };
-  jaxws = fetchurl {
-             url = "${baseurl}/jaxws/archive/${repover}.tar.gz";
-             sha256 = "1m1aspc1hq74w0bkasrfvp8ygs6psbc1l61vfw9244j2vgfahjgn";
-          };
-  jaxp = fetchurl {
-             url = "${baseurl}/jaxp/archive/${repover}.tar.gz";
-             sha256 = "06ns2giw366vjivb6d46gqwfvfzkaddrgd1x6y8w37ywygp50lxm";
-          };
-  nashorn = fetchurl {
-             url = "${baseurl}/nashorn/archive/${repover}.tar.gz";
-             sha256 = "0z6mlzvz1hh1yzli69qjlrcwqdjnivbjbqqrqi4hhpls6z0a2ch7";
-          };
-  openjdk9 = stdenv.mkDerivation {
-    name = "openjdk-${update}-b${build}";
-
-    srcs = [ jdk9 langtools hotspot corba jdk jaxws jaxp nashorn ];
-    sourceRoot = ".";
-
-    outputs = [ "out" "jre" ];
-
-    nativeBuildInputs = [ pkgconfig ];
-    buildInputs = [
-      cpio file which unzip zip perl bootjdk zlib cups freetype alsaLib
-      libjpeg giflib libX11 libICE libXext libXrender libXtst libXt libXtst
-      libXi libXinerama libXcursor lndir fontconfig
-    ] ++ lib.optionals (!minimal && enableGnome2) [
-      gtk2 gnome_vfs GConf glib
-    ];
-
-    #move the seven other source dirs under the main jdk8u directory,
-    #with version suffixes removed, as the remainder of the build will expect
-    prePatch = ''
-      mainDir=$(find . -maxdepth 1 -name jdk9\*);
-      find . -maxdepth 1 -name \*jdk\* -not -name jdk9\* | awk -F- '{print $1}' | while read p; do
-        mv $p-* $mainDir/$p
-      done
-      cd $mainDir
-    '';
-
-    patches = [
-      ./fix-java-home-jdk9.patch
-      ./read-truststore-from-env-jdk9.patch
-      ./currency-date-range-jdk8.patch
-    #] ++ lib.optionals (!minimal && enableInfinality) [
-    #  ./004_add-fontconfig.patch
-    #  ./005_enable-infinality.patch
-    ] ++ lib.optionals (!minimal && enableGnome2) [
-      ./swing-use-gtk-jdk9.patch
-    ];
-
-    preConfigure = ''
-      chmod +x configure
-      substituteInPlace configure --replace /bin/bash "${bash}/bin/bash"
-
-      configureFlagsArray=(
-        "--with-boot-jdk=${bootjdk.home}"
-        "--with-update-version=${update}"
-        "--with-build-number=${build}"
-        "--with-milestone=fcs"
-        "--enable-unlimited-crypto"
-        "--disable-debug-symbols"
-        "--disable-freetype-bundling"
-        "--with-zlib=system"
-        "--with-giflib=system"
-        "--with-stdc++lib=dynamic"
-
-        # glibc 2.24 deprecated readdir_r so we need this
-        # See https://www.mail-archive.com/openembedded-devel@lists.openembedded.org/msg49006.html
-        "--with-extra-cflags=-Wno-error=deprecated-declarations -Wno-error=format-contains-nul -Wno-error=unused-result"
-    ''
-    + lib.optionalString minimal "\"--enable-headless-only\""
-    + ");"
-    # https://bugzilla.redhat.com/show_bug.cgi?id=1306558
-    # https://github.com/JetBrains/jdk8u/commit/eaa5e0711a43d64874111254d74893fa299d5716
-    + stdenv.lib.optionalString stdenv.cc.isGNU ''
-      NIX_CFLAGS_COMPILE+=" -fno-lifetime-dse -fno-delete-null-pointer-checks -std=gnu++98 -Wno-error"
-    '';
-
-    NIX_LDFLAGS= lib.optionals (!minimal) [
-      "-lfontconfig" "-lcups" "-lXinerama" "-lXrandr" "-lmagic"
-    ] ++ lib.optionals (!minimal && enableGnome2) [
-      "-lgtk-x11-2.0" "-lgio-2.0" "-lgnomevfs-2" "-lgconf-2"
-    ];
-
-    buildFlags = [ "all" ];
-
-    installPhase = ''
-      mkdir -p $out/lib/openjdk $out/share $jre/lib/openjdk
-
-      cp -av build/*/images/jdk/* $out/lib/openjdk
-
-      # Remove some broken manpages.
-      rm -rf $out/lib/openjdk/man/ja*
-
-      # Mirror some stuff in top-level.
-      mkdir $out/include $out/share/man
-      ln -s $out/lib/openjdk/include/* $out/include/
-      ln -s $out/lib/openjdk/man/* $out/share/man/
-
-      # jni.h expects jni_md.h to be in the header search path.
-      ln -s $out/include/linux/*_md.h $out/include/
-
-      # Copy the JRE to a separate output and setup fallback fonts
-      cp -av build/*/images/jre $jre/lib/openjdk/
-      mkdir $out/lib/openjdk/jre
-      ${lib.optionalString (!minimal) ''
-        mkdir -p $jre/lib/openjdk/jre/lib/fonts/fallback
-        lndir ${liberation_ttf}/share/fonts/truetype $jre/lib/openjdk/jre/lib/fonts/fallback
-      ''}
-
-      # Remove crap from the installation.
-      rm -rf $out/lib/openjdk/demo
-      ${lib.optionalString minimal ''
-        for d in $out/lib/openjdk/lib $jre/lib/openjdk/jre/lib; do
-          rm ''${d}/{libjsound,libjsoundalsa,libawt*,libfontmanager}.so
-        done
-      ''}
-
-      lndir $jre/lib/openjdk/jre $out/lib/openjdk/jre
-
-      # Make sure cmm/*.pf are not symlinks:
-      # https://youtrack.jetbrains.com/issue/IDEA-147272
-      # in 9, it seems no *.pf files end up in $out ... ?
-      # rm -rf $out/lib/openjdk/jre/lib/cmm
-      # ln -s {$jre,$out}/lib/openjdk/jre/lib/cmm
-
-      # Set PaX markings
-      exes=$(file $out/lib/openjdk/bin/* $jre/lib/openjdk/jre/bin/* 2> /dev/null | grep -E 'ELF.*(executable|shared object)' | sed -e 's/: .*$//')
-      echo "to mark: *$exes*"
-      for file in $exes; do
-        echo "marking *$file*"
-        paxmark ${paxflags} "$file"
-      done
-
-      # Remove duplicate binaries.
-      for i in $(cd $out/lib/openjdk/bin && echo *); do
-        if [ "$i" = java ]; then continue; fi
-        if cmp -s $out/lib/openjdk/bin/$i $jre/lib/openjdk/jre/bin/$i; then
-          ln -sfn $jre/lib/openjdk/jre/bin/$i $out/lib/openjdk/bin/$i
-        fi
-      done
-
-      # Generate certificates.
-      (
-        cd $jre/lib/openjdk/jre/lib/security
-        rm cacerts
-        perl ${./generate-cacerts.pl} $jre/lib/openjdk/jre/bin/keytool ${cacert}/etc/ssl/certs/ca-bundle.crt
-      )
-
-      ln -s $out/lib/openjdk/bin $out/bin
-      ln -s $jre/lib/openjdk/jre/bin $jre/bin
-      ln -s $jre/lib/openjdk/jre $out/jre
-    '';
-
-    # FIXME: this is unnecessary once the multiple-outputs branch is merged.
-    preFixup = ''
-      prefix=$jre stripDirs "$stripDebugList" "''${stripDebugFlags:--S}"
-      patchELF $jre
-      propagatedBuildInputs+=" $jre"
-
-      # Propagate the setJavaClassPath setup hook from the JRE so that
-      # any package that depends on the JRE has $CLASSPATH set up
-      # properly.
-      mkdir -p $jre/nix-support
-      #TODO or printWords?  cf https://github.com/NixOS/nixpkgs/pull/27427#issuecomment-317293040
-      echo -n "${setJavaClassPath}" > $jre/nix-support/propagated-build-inputs
-
-      # Set JAVA_HOME automatically.
-      mkdir -p $out/nix-support
-      cat <<EOF > $out/nix-support/setup-hook
-      if [ -z "\$JAVA_HOME" ]; then export JAVA_HOME=$out/lib/openjdk; fi
-      EOF
-    '';
-
-    postFixup = ''
-      # Build the set of output library directories to rpath against
-      LIBDIRS=""
-      for output in $outputs; do
-        LIBDIRS="$(find $(eval echo \$$output) -name \*.so\* -exec dirname {} \+ | sort | uniq | tr '\n' ':'):$LIBDIRS"
-      done
-
-      # Add the local library paths to remove dependencies on the bootstrap
-      for output in $outputs; do
-        OUTPUTDIR=$(eval echo \$$output)
-        BINLIBS=$(find $OUTPUTDIR/bin/ -type f; find $OUTPUTDIR -name \*.so\*)
-        echo "$BINLIBS" | while read i; do
-          patchelf --set-rpath "$LIBDIRS:$(patchelf --print-rpath "$i")" "$i" || true
-          patchelf --shrink-rpath "$i" || true
-        done
-      done
-
-      # Test to make sure that we don't depend on the bootstrap
-      for output in $outputs; do
-        if grep -q -r '${bootjdk}' $(eval echo \$$output); then
-          echo "Extraneous references to ${bootjdk} detected"
-          exit 1
-        fi
-      done
-    '';
-
-    meta = with stdenv.lib; {
-      homepage = http://openjdk.java.net/;
-      license = licenses.gpl2;
-      description = "The open-source Java Development Kit";
-      maintainers = with maintainers; [ edwtjo ];
-      platforms = platforms.linux;
-    };
-
-    passthru = {
-      inherit architecture;
-      home = "${openjdk9}/lib/openjdk";
-    };
-  };
-in openjdk9
diff --git a/pkgs/development/compilers/openjdk/fix-java-home-jdk9.patch b/pkgs/development/compilers/openjdk/fix-java-home-jdk9.patch
deleted file mode 100644
index f9755d58e48f..000000000000
--- a/pkgs/development/compilers/openjdk/fix-java-home-jdk9.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/hotspot/src/os/linux/vm/os_linux.cpp	2017-07-04 23:09:02.533972226 -0400
-+++ b/hotspot/src/os/linux/vm/os_linux.cpp	2017-07-04 23:07:52.118338845 -0400
-@@ -2318,10 +2318,7 @@
-   assert(ret, "cannot locate libjvm");
-   char *rp = NULL;
-   if (ret && dli_fname[0] != '\0') {
--    rp = realpath(dli_fname, buf);
--  }
--  if (rp == NULL) {
--    return;
-+    snprintf(buf, buflen, "%s", dli_fname);
-   }
- 
-   if (Arguments::sun_java_launcher_is_altjvm()) {
diff --git a/pkgs/development/compilers/openjdk/read-truststore-from-env-jdk9.patch b/pkgs/development/compilers/openjdk/read-truststore-from-env-jdk9.patch
deleted file mode 100644
index cb8d59ff8063..000000000000
--- a/pkgs/development/compilers/openjdk/read-truststore-from-env-jdk9.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/jdk/src/java.base/share/classes/sun/security/ssl/TrustStoreManager.java	2017-06-26 21:48:25.000000000 -0400
-+++ b/jdk/src/java.base/share/classes/sun/security/ssl/TrustStoreManager.java.new	2017-07-05 20:45:57.491295030 -0400
-@@ -71,6 +71,7 @@
-      *
-      * The preference of the default trusted KeyStore is:
-      *    javax.net.ssl.trustStore
-+     *    system environment variable JAVAX_NET_SSL_TRUSTSTORE
-      *    jssecacerts
-      *    cacerts
-      */
-@@ -144,6 +145,9 @@
-                     String temporaryName = "";
-                     File temporaryFile = null;
-                     long temporaryTime = 0L;
-+                    if (storePropName == null){
-+                        storePropName = System.getenv("JAVAX_NET_SSL_TRUSTSTORE");
-+                    }
-                     if (!"NONE".equals(storePropName)) {
-                         String[] fileNames =
-                                 new String[] {storePropName, defaultStore};
diff --git a/pkgs/development/compilers/openjdk/swing-use-gtk-jdk9.patch b/pkgs/development/compilers/openjdk/swing-use-gtk-jdk9.patch
deleted file mode 100644
index 07d95ba71b8a..000000000000
--- a/pkgs/development/compilers/openjdk/swing-use-gtk-jdk9.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff -ru3 a/jdk/src/share/classes/javax/swing/UIManager.java b/jdk/src/share/classes/javax/swing/UIManager.java
---- a/jdk/src/java.desktop/share/classes/javax/swing/UIManager.java	2016-07-26 00:41:37.000000000 +0300
-+++ b/jdk/src/java.desktop/share/classes/javax/swing/UIManager.java	2016-10-02 22:46:01.890071761 +0300
-@@ -607,11 +607,9 @@
-         if (osType == OSInfo.OSType.WINDOWS) {
-             return "com.sun.java.swing.plaf.windows.WindowsLookAndFeel";
-         } else {
--            String desktop = AccessController.doPrivileged(new GetPropertyAction("sun.desktop"));
-             Toolkit toolkit = Toolkit.getDefaultToolkit();
--            if ("gnome".equals(desktop) &&
--                    toolkit instanceof SunToolkit &&
--                    ((SunToolkit) toolkit).isNativeGTKAvailable()) {
-+            if (toolkit instanceof SunToolkit &&
-+                    ((SunToolkit) toolkit).isNativeGTKAvailable()) {
-                 // May be set on Linux and Solaris boxs.
-                 return "com.sun.java.swing.plaf.gtk.GTKLookAndFeel";
-             }
-@@ -1341,7 +1339,7 @@
-             lafName = (String) lafData.remove("defaultlaf");
-         }
-         if (lafName == null) {
--            lafName = getCrossPlatformLookAndFeelClassName();
-+            lafName = getSystemLookAndFeelClassName();
-         }
-         lafName = swingProps.getProperty(defaultLAFKey, lafName);
- 
diff --git a/pkgs/development/compilers/oraclejdk/jdk9-linux.nix b/pkgs/development/compilers/oraclejdk/jdk9-linux.nix
deleted file mode 100644
index 87f2e49b4431..000000000000
--- a/pkgs/development/compilers/oraclejdk/jdk9-linux.nix
+++ /dev/null
@@ -1,158 +0,0 @@
-{ swingSupport ? true
-, stdenv
-, requireFile
-, makeWrapper
-, unzip
-, file
-, xorg ? null
-, packageType ? "JDK" # JDK, JRE, or ServerJRE
-, pluginSupport ? true
-, glib
-, libxml2
-, ffmpeg_2
-, libxslt
-, libGL
-, freetype
-, fontconfig
-, gtk2
-, pango
-, cairo
-, alsaLib
-, atk
-, gdk_pixbuf
-, zlib
-, elfutils
-, setJavaClassPath
-}:
-
-assert stdenv.system == "x86_64-linux";
-assert swingSupport -> xorg != null;
-
-let
-  version = "9.0.4";
-
-  downloadUrlBase = http://www.oracle.com/technetwork/java/javase/downloads;
-
-  rSubPaths = [
-    "lib/jli"
-    "lib/server"
-    "lib"
-  ];
-
-in
-
-let result = stdenv.mkDerivation rec {
-  name = if packageType == "JDK"       then "oraclejdk-${version}"
-    else if packageType == "JRE"       then "oraclejre-${version}"
-    else if packageType == "ServerJRE" then "oracleserverjre-${version}"
-    else abort "unknown package Type ${packageType}";
-
-  src =
-    if packageType == "JDK" then
-      requireFile {
-        name = "jdk-${version}_linux-x64_bin.tar.gz";
-        url =  "${downloadUrlBase}/jdk9-downloads-3848520.html";
-        sha256 = "18nsjn64wkfmyb09wf2k7lvhazf83cs3dyichr038vl1gs3ymi4h";
-      }
-    else if packageType == "JRE" then
-      requireFile {
-        name = "jre-${version}_linux-x64_bin.tar.gz";
-        url = "${downloadUrlBase}/jre9-downloads-3848532.html";
-        sha256 = "01fp079mr04nniyf06w8vd47qxr6rly1lbh8dqkddb8fp9h6a79k";
-      }
-    else if packageType == "ServerJRE" then
-      requireFile {
-        name = "serverjre-${version}_linux-x64_bin.tar.gz";
-        url = "${downloadUrlBase}/server-jre9-downloads-3848530.html";
-        sha256 = "1jlpa4mn306hx0p9jcw3i6cpdvnng29dwjsymgcan56810q6p6yj";
-      }
-    else abort "unknown package Type ${packageType}";
-
-  nativeBuildInputs = [ file ];
-
-  buildInputs = [ makeWrapper ];
-
-  # See: https://github.com/NixOS/patchelf/issues/10
-  dontStrip = 1;
-
-  installPhase = ''
-    cd ..
-
-    # Set PaX markings
-    exes=$(file $sourceRoot/bin/* 2> /dev/null | grep -E 'ELF.*(executable|shared object)' | sed -e 's/: .*$//')
-    for file in $exes; do
-      paxmark m "$file"
-      # On x86 for heap sizes over 700MB disable SEGMEXEC and PAGEEXEC as well.
-      ${stdenv.lib.optionalString stdenv.isi686 ''paxmark msp "$file"''}
-    done
-
-    mv $sourceRoot $out
-
-    shopt -s extglob
-    for file in $out/*
-    do
-      if test -f $file ; then
-        rm $file
-      fi
-    done
-
-    if test -z "$pluginSupport"; then
-      rm -f $out/bin/javaws
-    fi
-
-    mkdir $out/lib/plugins
-    ln -s $out/lib/libnpjp2.so $out/lib/plugins
-
-    # for backward compatibility
-    ln -s $out $out/jre
-
-    mkdir -p $out/nix-support
-    printWords ${setJavaClassPath} > $out/nix-support/propagated-build-inputs
-
-    # Set JAVA_HOME automatically.
-    cat <<EOF >> $out/nix-support/setup-hook
-    if [ -z "\$JAVA_HOME" ]; then export JAVA_HOME=$out; fi
-    EOF
-  '';
-
-  postFixup = ''
-    rpath+="''${rpath:+:}${stdenv.lib.concatStringsSep ":" (map (a: "$out/${a}") rSubPaths)}"
-
-    # set all the dynamic linkers
-    find $out -type f -perm -0100 \
-        -exec patchelf --interpreter "$(cat $NIX_CC/nix-support/dynamic-linker)" \
-        --set-rpath "$rpath" {} \;
-
-    find $out -name "*.so" -exec patchelf --set-rpath "$rpath" {} \;
-
-    # Oracle Java Mission Control needs to know where libgtk-x11 and related is
-    if test -x $out/bin/jmc; then
-      wrapProgram "$out/bin/jmc" \
-          --suffix-each LD_LIBRARY_PATH ':' "$rpath"
-    fi
-  '';
-
-  /**
-   * libXt is only needed on amd64
-   */
-  libraries =
-    [stdenv.cc.libc glib libxml2 ffmpeg_2 libxslt libGL xorg.libXxf86vm alsaLib fontconfig freetype pango gtk2 cairo gdk_pixbuf atk zlib elfutils] ++
-    (if swingSupport then [xorg.libX11 xorg.libXext xorg.libXtst xorg.libXi xorg.libXp xorg.libXt xorg.libXrender stdenv.cc.cc] else []);
-
-  rpath = stdenv.lib.strings.makeLibraryPath libraries;
-
-  passthru.mozillaPlugin = "/lib/plugins";
-
-  passthru.jre = result; # FIXME: use multiple outputs or return actual JRE package
-
-  passthru.home = result;
-
-  # for backward compatibility
-  passthru.architecture = "";
-
-  meta = with stdenv.lib; {
-    license = licenses.unfree;
-    platforms = [ "x86_64-linux" ]; # some inherit jre.meta.platforms
-  };
-
-}; in result