summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorCarles Pagès <page@ruiec.cat>2017-05-22 23:32:07 +0200
committerGitHub <noreply@github.com>2017-05-22 23:32:07 +0200
commitf60767d55e461181dc713c1b734c922c224d2e1d (patch)
tree729c9a043afddb247005809f8263107c500df2d6 /pkgs/development
parent2549be898de0eb535d6b1cd04728791b2935f23e (diff)
parent8a978a7be3121cab6b388d6f05a855b2aaa8846d (diff)
downloadnixlib-f60767d55e461181dc713c1b734c922c224d2e1d.tar
nixlib-f60767d55e461181dc713c1b734c922c224d2e1d.tar.gz
nixlib-f60767d55e461181dc713c1b734c922c224d2e1d.tar.bz2
nixlib-f60767d55e461181dc713c1b734c922c224d2e1d.tar.lz
nixlib-f60767d55e461181dc713c1b734c922c224d2e1d.tar.xz
nixlib-f60767d55e461181dc713c1b734c922c224d2e1d.tar.zst
nixlib-f60767d55e461181dc713c1b734c922c224d2e1d.zip
Merge pull request #25366 from titanous/kodi-hdhomerun
kodi: add pvr-hdhomerun plugin
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/libhdhomerun/default.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/pkgs/development/libraries/libhdhomerun/default.nix b/pkgs/development/libraries/libhdhomerun/default.nix
new file mode 100644
index 000000000000..08563ed53dd5
--- /dev/null
+++ b/pkgs/development/libraries/libhdhomerun/default.nix
@@ -0,0 +1,34 @@
+{ stdenv, fetchgit }:
+
+stdenv.mkDerivation {
+  name = "libhdhomerun-1efbcb";
+
+  src = fetchgit {
+    url = "git://github.com/Silicondust/libhdhomerun.git";
+    rev = "1efbcb2b87b17a82f2b3d873d1c9cc1c6a3a9b77";
+    sha256 = "11iyrfs98xb50n9iqnwfphmmnn5w3mq2l9cjjpf8qp29cvs33cgy";
+  };
+
+  patchPhase = stdenv.lib.optionalString stdenv.isDarwin ''
+    substituteInPlace Makefile --replace "gcc" "cc"
+    substituteInPlace Makefile --replace "-arch i386" ""
+  '';
+
+  installPhase = let
+    libSuff = if stdenv.isDarwin then "dylib" else "so";
+  in ''
+    mkdir -p $out/{bin,lib,include/hdhomerun}
+    install -Dm444 libhdhomerun.${libSuff} $out/lib
+    install -Dm555 hdhomerun_config $out/bin
+    cp *.h $out/include/hdhomerun
+  '';
+
+  meta = with stdenv.lib; {
+    description = "Implements the libhdhomerun protocol for use with Silicondust HDHomeRun TV tuners";
+    homepage = "https://github.com/Silicondust/libhdhomerun";
+    repositories.git = "https://github.com/Silicondust/libhdhomerun.git";
+    license = stdenv.lib.licenses.lgpl2;
+    platforms = stdenv.lib.platforms.unix;
+    maintainers = [ maintainers.titanous ];
+  };
+}