summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2017-12-25 15:20:42 +0100
committerMatthieu Coudron <mattator@gmail.com>2018-04-23 16:35:44 +0900
commitf396f0937e69f843187e5c899e8e6a21123ec2ec (patch)
tree34c0af3bf31059298ad16eb2438d3e50fd25d5f4 /pkgs/development
parent6c064e6b1f34a8416f990db0cc617a7195f71588 (diff)
downloadnixlib-f396f0937e69f843187e5c899e8e6a21123ec2ec.tar
nixlib-f396f0937e69f843187e5c899e8e6a21123ec2ec.tar.gz
nixlib-f396f0937e69f843187e5c899e8e6a21123ec2ec.tar.bz2
nixlib-f396f0937e69f843187e5c899e8e6a21123ec2ec.tar.lz
nixlib-f396f0937e69f843187e5c899e8e6a21123ec2ec.tar.xz
nixlib-f396f0937e69f843187e5c899e8e6a21123ec2ec.tar.zst
nixlib-f396f0937e69f843187e5c899e8e6a21123ec2ec.zip
pythonPackages.milksnake: init at 0.1.5
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/milksnake/default.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/milksnake/default.nix b/pkgs/development/python-modules/milksnake/default.nix
new file mode 100644
index 000000000000..014bb223225d
--- /dev/null
+++ b/pkgs/development/python-modules/milksnake/default.nix
@@ -0,0 +1,26 @@
+{ lib, buildPythonPackage, fetchPypi, cffi }:
+
+buildPythonPackage rec {
+  pname = "milksnake";
+  version = "0.1.5";
+
+  src = fetchPypi {
+    inherit pname version;
+    extension = "zip";
+    sha256 = "120nprd8lqis7x7zy72536gk2j68f7gxm8gffmx8k4ygifvl7kfz";
+  };
+
+  propagatedBuildInputs = [
+   cffi
+  ];
+
+  # tests rely on pip/venv
+  doCheck = false;
+
+  meta = with lib; {
+    description = "A python library that extends setuptools for binary extensions";
+    homepage = https://github.com/getsentry/milksnake;
+    license = licenses.asl20;
+    maintainers = with maintainers; [ matthiasbeyer ];
+  };
+}