summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2018-06-07 14:27:44 -0400
committerJohn Ericson <John.Ericson@Obsidian.Systems>2018-06-07 14:27:44 -0400
commitf379be939c92a5775556e92564b435c077508a21 (patch)
tree6b766871281dc9f657f395cc4ee1e047f9ff6dc3 /pkgs/development
parentc923e938a3de8738ac881bd8762a18961aadc796 (diff)
downloadnixlib-f379be939c92a5775556e92564b435c077508a21.tar
nixlib-f379be939c92a5775556e92564b435c077508a21.tar.gz
nixlib-f379be939c92a5775556e92564b435c077508a21.tar.bz2
nixlib-f379be939c92a5775556e92564b435c077508a21.tar.lz
nixlib-f379be939c92a5775556e92564b435c077508a21.tar.xz
nixlib-f379be939c92a5775556e92564b435c077508a21.tar.zst
nixlib-f379be939c92a5775556e92564b435c077508a21.zip
haskell infra: Use `self.ghc` rather than closing over initial value
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/haskell-modules/make-package-set.nix5
1 files changed, 2 insertions, 3 deletions
diff --git a/pkgs/development/haskell-modules/make-package-set.nix b/pkgs/development/haskell-modules/make-package-set.nix
index 7fc921037a2a..a54967c4e45e 100644
--- a/pkgs/development/haskell-modules/make-package-set.nix
+++ b/pkgs/development/haskell-modules/make-package-set.nix
@@ -102,8 +102,7 @@ let
   callPackage = drv: args: callPackageWithScope defaultScope drv args;
 
   withPackages = packages: buildPackages.callPackage ./with-packages-wrapper.nix {
-    inherit (self) llvmPackages;
-    inherit ghc;
+    inherit (self) ghc llvmPackages;
     inherit packages;
   };
 
@@ -120,7 +119,7 @@ let
       installPhase = ''
         export HOME="$TMP"
         mkdir -p "$out"
-        cabal2nix --compiler=${ghc.haskellCompilerName} --system=${hostPlatform.system} ${sha256Arg} "${src}" ${extraCabal2nixOptions} > "$out/default.nix"
+        cabal2nix --compiler=${self.ghc.haskellCompilerName} --system=${hostPlatform.system} ${sha256Arg} "${src}" ${extraCabal2nixOptions} > "$out/default.nix"
       '';
   };