summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorWilliam A. Kennington III <william@wkennington.com>2014-09-14 15:53:05 -0700
committerWilliam A. Kennington III <william@wkennington.com>2014-09-21 15:18:16 -0700
commitf327e9c9221d39dac55e565819054122ead64218 (patch)
tree28a94703e366294537fe6f1a135651f9d684cdaa /pkgs/development
parent89cf0e4fea8f2839a7423452097fd7fdc662cb48 (diff)
downloadnixlib-f327e9c9221d39dac55e565819054122ead64218.tar
nixlib-f327e9c9221d39dac55e565819054122ead64218.tar.gz
nixlib-f327e9c9221d39dac55e565819054122ead64218.tar.bz2
nixlib-f327e9c9221d39dac55e565819054122ead64218.tar.lz
nixlib-f327e9c9221d39dac55e565819054122ead64218.tar.xz
nixlib-f327e9c9221d39dac55e565819054122ead64218.tar.zst
nixlib-f327e9c9221d39dac55e565819054122ead64218.zip
boostHeaders: regular boost package now only contains headers
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/boost/header-only-wrapper.nix30
1 files changed, 0 insertions, 30 deletions
diff --git a/pkgs/development/libraries/boost/header-only-wrapper.nix b/pkgs/development/libraries/boost/header-only-wrapper.nix
deleted file mode 100644
index 96c9216a371b..000000000000
--- a/pkgs/development/libraries/boost/header-only-wrapper.nix
+++ /dev/null
@@ -1,30 +0,0 @@
-{ stdenv, fetchurl, boost }:
-
-let
-  version = stdenv.lib.removePrefix "boost-" boost.name;
-  pkgid = stdenv.lib.replaceChars ["-" "."] ["_" "_"] boost.name;
-in
-
-stdenv.mkDerivation {
-  name = "boost-headers-${version}";
-
-  src = boost.src;
-
-  phases = [ "installPhase" ];
-
-  installPhase = ''
-    mkdir -p $out/include
-    tar xf $src -C $out/include --strip-components=1 ${pkgid}/boost
-  '';
-
-  preferLocalBuild = true;
-
-  meta = {
-    homepage = "http://boost.org/";
-    description = "Boost C++ Library Collection";
-    license = "boost-license";
-
-    platforms = stdenv.lib.platforms.unix;
-    maintainers = [ stdenv.lib.maintainers.viric stdenv.lib.maintainers.simons ];
-  };
-}