summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorJaakko Luttinen <jaakko.luttinen@iki.fi>2018-08-26 14:13:24 +0300
committerJaakko Luttinen <jaakko.luttinen@iki.fi>2018-09-12 08:44:19 +0300
commitf053daf36ceb956e19a78115e4abdf46058fec25 (patch)
treeacb5d5d736390d6d3aa5ee277b0bcc9255e63fc7 /pkgs/development
parent9f8e6148c5da6101bd534c3d68549ab00946b441 (diff)
downloadnixlib-f053daf36ceb956e19a78115e4abdf46058fec25.tar
nixlib-f053daf36ceb956e19a78115e4abdf46058fec25.tar.gz
nixlib-f053daf36ceb956e19a78115e4abdf46058fec25.tar.bz2
nixlib-f053daf36ceb956e19a78115e4abdf46058fec25.tar.lz
nixlib-f053daf36ceb956e19a78115e4abdf46058fec25.tar.xz
nixlib-f053daf36ceb956e19a78115e4abdf46058fec25.tar.zst
nixlib-f053daf36ceb956e19a78115e4abdf46058fec25.zip
pythonPackages.rlp: fix build
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/rlp/default.nix16
1 files changed, 13 insertions, 3 deletions
diff --git a/pkgs/development/python-modules/rlp/default.nix b/pkgs/development/python-modules/rlp/default.nix
index 77ada95b3019..150234a3dd29 100644
--- a/pkgs/development/python-modules/rlp/default.nix
+++ b/pkgs/development/python-modules/rlp/default.nix
@@ -1,4 +1,4 @@
-{ lib, fetchPypi, buildPythonPackage, pytest }:
+{ lib, fetchPypi, buildPythonPackage, pytest, hypothesis, eth-utils }:
 
 buildPythonPackage rec {
   pname = "rlp";
@@ -9,8 +9,18 @@ buildPythonPackage rec {
     sha256 = "040fb5172fa23d27953a886c40cac989fc031d0629db934b5a9edcd2fb28df1e";
   };
 
-  checkInputs = [ pytest ];
-  propagatedBuildInputs = [ ];
+  checkInputs = [ pytest hypothesis ];
+  propagatedBuildInputs = [ eth-utils ];
+
+  # setuptools-markdown uses pypandoc which is broken at the moment
+  preConfigure = ''
+    substituteInPlace setup.py --replace \'setuptools-markdown\' ""
+    substituteInPlace setup.py --replace "long_description_markdown_filename='README.md'," ""
+  '';
+
+  checkPhase = ''
+    pytest .
+  '';
 
   meta = {
     description = "A package for encoding and decoding data in and from Recursive Length Prefix notation";