summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorRahul Gopinath <rahul@gopinath.org>2016-06-12 18:29:56 -0700
committerRahul Gopinath <rahul@gopinath.org>2016-06-12 20:27:44 -0700
commitea8fb0aee53e121bb844201f6032c8d33b70dc16 (patch)
tree262c0a6b832e9206566d61e261dad02a17ff384f /pkgs/development
parent96066935f27330fef376202482d495f55e57f0f6 (diff)
downloadnixlib-ea8fb0aee53e121bb844201f6032c8d33b70dc16.tar
nixlib-ea8fb0aee53e121bb844201f6032c8d33b70dc16.tar.gz
nixlib-ea8fb0aee53e121bb844201f6032c8d33b70dc16.tar.bz2
nixlib-ea8fb0aee53e121bb844201f6032c8d33b70dc16.tar.lz
nixlib-ea8fb0aee53e121bb844201f6032c8d33b70dc16.tar.xz
nixlib-ea8fb0aee53e121bb844201f6032c8d33b70dc16.tar.zst
nixlib-ea8fb0aee53e121bb844201f6032c8d33b70dc16.zip
SDL_sixel: init at 1.2-nightly
SDL_sixel is a fork of SDL1.2 that supports sixel as a video driver (for
console graphics)
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/SDL_sixel/default.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/pkgs/development/libraries/SDL_sixel/default.nix b/pkgs/development/libraries/SDL_sixel/default.nix
new file mode 100644
index 000000000000..5b8e887c2eee
--- /dev/null
+++ b/pkgs/development/libraries/SDL_sixel/default.nix
@@ -0,0 +1,25 @@
+{ stdenv, fetchFromGitHub, pkgconfig, libsixel }:
+
+stdenv.mkDerivation rec {
+  name    = "SDL_sixel-${version}";
+  version = "1.2-nightly";
+
+  src = fetchFromGitHub {
+    owner = "saitoha";
+    repo = "SDL1.2-SIXEL";
+    rev = "ab3fccac6e34260a617be511bd8c2b2beae41952";
+    sha256 = "0gm2vngdac17lzw9azkhzazmfq3byjddms14gqjk18vnynfqp5wp";
+  };
+
+  configureFlags = [ "--enable-video-sixel" ];
+
+  buildInputs = [ pkgconfig libsixel ];
+
+  meta = with stdenv.lib; {
+    description = "A cross-platform multimedia library, that supports sixel graphics on consoles";
+    homepage    = https://github.com/saitoha/SDL1.2-SIXEL;
+    maintainers = with maintainers; [ vrthra ];
+    platforms   = platforms.linux;
+    license     = licenses.lgpl21;
+  };
+}