summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorVincent Laporte <Vincent.Laporte@gmail.com>2018-05-28 06:52:45 +0000
committerVincent Laporte <Vincent.Laporte@gmail.com>2018-06-06 07:14:23 +0000
commite7795ce53e6e7fff4c5b43b29ff4b682ea8d563d (patch)
treeed28dd6a54542cdf314e3c0c5a157b2fa0b82011 /pkgs/development
parent8e0100ba8516a4c0bd7bafa49ccd5673bcadfbfb (diff)
downloadnixlib-e7795ce53e6e7fff4c5b43b29ff4b682ea8d563d.tar
nixlib-e7795ce53e6e7fff4c5b43b29ff4b682ea8d563d.tar.gz
nixlib-e7795ce53e6e7fff4c5b43b29ff4b682ea8d563d.tar.bz2
nixlib-e7795ce53e6e7fff4c5b43b29ff4b682ea8d563d.tar.lz
nixlib-e7795ce53e6e7fff4c5b43b29ff4b682ea8d563d.tar.xz
nixlib-e7795ce53e6e7fff4c5b43b29ff4b682ea8d563d.tar.zst
nixlib-e7795ce53e6e7fff4c5b43b29ff4b682ea8d563d.zip
ocamlPackages.reactivedata: use opaline
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/ocaml-modules/reactivedata/default.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/pkgs/development/ocaml-modules/reactivedata/default.nix b/pkgs/development/ocaml-modules/reactivedata/default.nix
index 1f1781f5a65b..fa85f2174688 100644
--- a/pkgs/development/ocaml-modules/reactivedata/default.nix
+++ b/pkgs/development/ocaml-modules/reactivedata/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, ocaml, findlib, ocamlbuild, react, opam }:
+{ stdenv, fetchurl, ocaml, findlib, ocamlbuild, react, opaline }:
 
 assert stdenv.lib.versionAtLeast ocaml.version "3.11";
 
@@ -9,12 +9,12 @@ stdenv.mkDerivation {
     sha256 = "0wcs0z50nia1cpk8mh6i5qbc6sff9cc8x7s7q1q89d7m73bnv4vf";
   };
 
-  buildInputs = [ ocaml findlib ocamlbuild opam ];
+  buildInputs = [ ocaml findlib ocamlbuild opaline ];
   propagatedBuildInputs = [ react ];
 
   buildPhase = "ocaml pkg/build.ml native=true native-dynlink=true";
 
-  installPhase = "opam-installer -i --prefix=$out --libdir=$OCAMLFIND_DESTDIR";
+  installPhase = "opaline -prefix $out -libdir $OCAMLFIND_DESTDIR";
 
   meta = with stdenv.lib; {
     description = "An OCaml module for functional reactive programming (FRP) based on React";