summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorRobin Gloster <mail@glob.in>2016-08-27 08:00:20 +0000
committerRobin Gloster <mail@glob.in>2016-08-27 08:00:20 +0000
commite646d2c07cc9f643811993908f5db72d3bc57682 (patch)
tree6bd51f8bb856b4234caf2b4681407a83df46aeb6 /pkgs/development
parent8a84fc0217344990b646cbfbf01037b935407a40 (diff)
downloadnixlib-e646d2c07cc9f643811993908f5db72d3bc57682.tar
nixlib-e646d2c07cc9f643811993908f5db72d3bc57682.tar.gz
nixlib-e646d2c07cc9f643811993908f5db72d3bc57682.tar.bz2
nixlib-e646d2c07cc9f643811993908f5db72d3bc57682.tar.lz
nixlib-e646d2c07cc9f643811993908f5db72d3bc57682.tar.xz
nixlib-e646d2c07cc9f643811993908f5db72d3bc57682.tar.zst
nixlib-e646d2c07cc9f643811993908f5db72d3bc57682.zip
gnome3.gtk: fix build on darwin
The .la file does not exist on darwin.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/gtk+/3.x.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/pkgs/development/libraries/gtk+/3.x.nix b/pkgs/development/libraries/gtk+/3.x.nix
index b0409ee2808a..249f2651517f 100644
--- a/pkgs/development/libraries/gtk+/3.x.nix
+++ b/pkgs/development/libraries/gtk+/3.x.nix
@@ -41,7 +41,7 @@ stdenv.mkDerivation rec {
     ++ optional cupsSupport cups;
   #TODO: colord?
 
-  NIX_LDFLAGS = stdenv.lib.optionalString stdenv.isDarwin "-lintl";
+  NIX_LDFLAGS = optionalString stdenv.isDarwin "-lintl";
 
   # demos fail to install, no idea where's the problem
   preConfigure = "sed '/^SRC_SUBDIRS /s/demos//' -i Makefile.in";
@@ -60,7 +60,7 @@ stdenv.mkDerivation rec {
     "--enable-wayland-backend"
   ];
 
-  postInstall = ''
+  postInstall = optionalString (!stdenv.isDarwin) ''
     substituteInPlace "$out/lib/gtk-3.0/3.0.0/printbackends/libprintbackend-cups.la" \
       --replace '-L${gmp.dev}/lib' '-L${gmp.out}/lib'
   '';