summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorrnhmjoj <rnhmjoj@inventati.org>2018-09-11 23:51:50 +0200
committerrnhmjoj <rnhmjoj@inventati.org>2018-09-12 03:23:04 +0200
commite281f0e68631af7c1ff6e20f1b84683a117b016d (patch)
treef4f513ff860d8f5c395b7550e75a6ce6cf91a3a1 /pkgs/development
parent99dad9d7f01429f03054d45da8a6468fca0f8793 (diff)
downloadnixlib-e281f0e68631af7c1ff6e20f1b84683a117b016d.tar
nixlib-e281f0e68631af7c1ff6e20f1b84683a117b016d.tar.gz
nixlib-e281f0e68631af7c1ff6e20f1b84683a117b016d.tar.bz2
nixlib-e281f0e68631af7c1ff6e20f1b84683a117b016d.tar.lz
nixlib-e281f0e68631af7c1ff6e20f1b84683a117b016d.tar.xz
nixlib-e281f0e68631af7c1ff6e20f1b84683a117b016d.tar.zst
nixlib-e281f0e68631af7c1ff6e20f1b84683a117b016d.zip
python.pkgs.tldextract: init at 2.2.0
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/tldextract/default.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/tldextract/default.nix b/pkgs/development/python-modules/tldextract/default.nix
new file mode 100644
index 000000000000..4e494244d314
--- /dev/null
+++ b/pkgs/development/python-modules/tldextract/default.nix
@@ -0,0 +1,24 @@
+{ lib, fetchPypi, buildPythonPackage
+, requests, requests-file, idna, pytest
+, responses
+}:
+
+buildPythonPackage rec {
+  pname   = "tldextract";
+  version = "2.2.0";
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "1d5s8v6kpsgazyahflhji1cfdcf89rv7l7z55v774bhzvcjp2y99";
+  };
+
+  propagatedBuildInputs = [ requests requests-file idna ];
+  checkInputs = [ pytest responses ];
+
+  meta = {
+    homepage = https://github.com/john-kurkowski/tldextract;
+    description = "Accurately separate the TLD from the registered domain and subdomains of a URL, using the Public Suffix List.";
+    license = lib.licenses.bsd3;
+  };
+
+}