summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorWill Dietz <w@wdtz.org>2018-07-05 22:12:46 -0500
committerWill Dietz <w@wdtz.org>2018-07-05 22:12:46 -0500
commite264a93a8530ea46338eda04dcb2cf411765bedd (patch)
treeae1220b818432fe8f5fdf0c92e72bbfbfd3f19d0 /pkgs/development
parent151680b077947fb33ae5e36748fbc3ea9d5807a1 (diff)
downloadnixlib-e264a93a8530ea46338eda04dcb2cf411765bedd.tar
nixlib-e264a93a8530ea46338eda04dcb2cf411765bedd.tar.gz
nixlib-e264a93a8530ea46338eda04dcb2cf411765bedd.tar.bz2
nixlib-e264a93a8530ea46338eda04dcb2cf411765bedd.tar.lz
nixlib-e264a93a8530ea46338eda04dcb2cf411765bedd.tar.xz
nixlib-e264a93a8530ea46338eda04dcb2cf411765bedd.tar.zst
nixlib-e264a93a8530ea46338eda04dcb2cf411765bedd.zip
libndctl: fix build w/musl using patch from upstream
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/libndctl/default.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/pkgs/development/libraries/libndctl/default.nix b/pkgs/development/libraries/libndctl/default.nix
index 0c7c02f80d47..d9a77f4bb8ba 100644
--- a/pkgs/development/libraries/libndctl/default.nix
+++ b/pkgs/development/libraries/libndctl/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchFromGitHub, autoreconfHook, autoconf, automake, asciidoc, docbook_xsl, docbook_xml_dtd_45, libxslt, xmlto, pkgconfig, json_c, kmod, which, systemd, utillinux
+{ stdenv, fetchFromGitHub, fetchpatch, autoreconfHook, autoconf, automake, asciidoc, docbook_xsl, docbook_xml_dtd_45, libxslt, xmlto, pkgconfig, json_c, kmod, which, systemd, utillinux
 }:
 
 let
@@ -23,6 +23,14 @@ in stdenv.mkDerivation rec {
     json_c kmod systemd utillinux
   ];
 
+  patches = [
+    (fetchpatch {
+      name = "add-missing-include-for-ssize_t.patch";
+      url = "https://github.com/pmem/ndctl/commit/8f1798d14dda367c659b87362edb312739830ddf.patch";
+      sha256 = "1jr5kh087938msl22hgjngbf025n9iplz0czmybfp7lavl73m0pm";
+    })
+  ];
+
   preAutoreconf = ''
     substituteInPlace configure.ac --replace "which" "${which}/bin/which"
     substituteInPlace git-version --replace /bin/bash ${stdenv.shell}