summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2009-07-17 16:14:28 +0000
committerLudovic Courtès <ludo@gnu.org>2009-07-17 16:14:28 +0000
commitdeb63071d782351ffa3030e18dce67687e9f9988 (patch)
tree68d06c88ba72c7da7daf2b95795f1c9175563357 /pkgs/development
parent04cc6b721a32d783c7e878c9a8c5fa5e304d5334 (diff)
downloadnixlib-deb63071d782351ffa3030e18dce67687e9f9988.tar
nixlib-deb63071d782351ffa3030e18dce67687e9f9988.tar.gz
nixlib-deb63071d782351ffa3030e18dce67687e9f9988.tar.bz2
nixlib-deb63071d782351ffa3030e18dce67687e9f9988.tar.lz
nixlib-deb63071d782351ffa3030e18dce67687e9f9988.tar.xz
nixlib-deb63071d782351ffa3030e18dce67687e9f9988.tar.zst
nixlib-deb63071d782351ffa3030e18dce67687e9f9988.zip
GCC 4.4: Don't use the included Gettext.
svn path=/nixpkgs/trunk/; revision=16415
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/gcc-4.4/default.nix17
1 files changed, 11 insertions, 6 deletions
diff --git a/pkgs/development/compilers/gcc-4.4/default.nix b/pkgs/development/compilers/gcc-4.4/default.nix
index d009acb6879a..57571b97c166 100644
--- a/pkgs/development/compilers/gcc-4.4/default.nix
+++ b/pkgs/development/compilers/gcc-4.4/default.nix
@@ -4,7 +4,7 @@
 , profiledCompiler ? false
 , staticCompiler ? false
 , texinfo ? null
-, gmp, mpfr
+, gmp, mpfr, gettext
 , bison ? null, flex ? null
 , zlib ? null, boehmgc ? null
 , enableMultilib ? false
@@ -50,12 +50,11 @@ stdenv.mkDerivation ({
   patches =
     [./pass-cxxcpp.patch]
     ++ optional noSysDirs ./no-sys-dirs.patch
-    ++ optional (noSysDirs && langFortran) ./no-sys-dirs-fortran.patch
-    ++ optional langJava ./java-jvgenmain-link.patch;
-    
+    ++ optional (noSysDirs && langFortran) ./no-sys-dirs-fortran.patch;
+
   inherit noSysDirs profiledCompiler staticCompiler;
 
-  buildInputs = [texinfo gmp mpfr]
+  buildInputs = [ texinfo gmp mpfr gettext ]
     ++ (optionals langTreelang [bison flex])
     ++ (optional (zlib != null) zlib)
     ++ (optional (boehmgc != null) boehmgc)
@@ -64,6 +63,7 @@ stdenv.mkDerivation ({
   configureFlags = "
     ${if enableMultilib then "" else "--disable-multilib"}
     --disable-libstdcxx-pch
+    --without-included-gettext
     --with-system-zlib
     --enable-languages=${
       concatStrings (intersperse ","
@@ -87,7 +87,12 @@ stdenv.mkDerivation ({
   meta = {
     homepage = "http://gcc.gnu.org/";
     license = "GPL/LGPL";
-    description = "GNU Compiler Collection, 4.3.x";
+    description = "GNU Compiler Collection, version ${version}";
+
+    maintainers = [
+      # Add your name here!
+      stdenv.lib.maintainers.ludo
+    ];
   };
 } // (if langJava then {
   postConfigure = ''