summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2015-10-15 13:57:38 +0200
committerVladimír Čunát <vcunat@gmail.com>2015-10-28 10:09:34 +0100
commitdd915f82e7ca180ad9adfef024e408e666e12c9d (patch)
tree41f93c2c5422596a71aae6476bf90f38dfddf63a /pkgs/development
parentad02a45af0cd9043337a424b76fb98cdb9488ba4 (diff)
downloadnixlib-dd915f82e7ca180ad9adfef024e408e666e12c9d.tar
nixlib-dd915f82e7ca180ad9adfef024e408e666e12c9d.tar.gz
nixlib-dd915f82e7ca180ad9adfef024e408e666e12c9d.tar.bz2
nixlib-dd915f82e7ca180ad9adfef024e408e666e12c9d.tar.lz
nixlib-dd915f82e7ca180ad9adfef024e408e666e12c9d.tar.xz
nixlib-dd915f82e7ca180ad9adfef024e408e666e12c9d.tar.zst
nixlib-dd915f82e7ca180ad9adfef024e408e666e12c9d.zip
expat: split dev output
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/interpreters/lua-5/expat.nix2
-rw-r--r--pkgs/development/libraries/boost/generic.nix4
-rw-r--r--pkgs/development/libraries/expat/default.nix4
-rw-r--r--pkgs/development/libraries/gettext/expat.nix2
-rw-r--r--pkgs/development/ocaml-modules/expat/default.nix4
5 files changed, 10 insertions, 6 deletions
diff --git a/pkgs/development/interpreters/lua-5/expat.nix b/pkgs/development/interpreters/lua-5/expat.nix
index 0dbbaf8a1614..243abae331a6 100644
--- a/pkgs/development/interpreters/lua-5/expat.nix
+++ b/pkgs/development/interpreters/lua-5/expat.nix
@@ -15,7 +15,7 @@ stdenv.mkDerivation rec {
     makeFlagsArray=(
       LUA_LDIR="$out/share/lua/${lua5.luaversion}"
       LUA_INC="-I${lua5}/include" LUA_CDIR="$out/lib/lua/${lua5.luaversion}"
-      EXPAT_INC="-I${expat}/include");
+      EXPAT_INC="-I${expat.dev}/include");
   '';
 
   meta = {
diff --git a/pkgs/development/libraries/boost/generic.nix b/pkgs/development/libraries/boost/generic.nix
index 1fd78761cd3b..ebdd5e8ade9b 100644
--- a/pkgs/development/libraries/boost/generic.nix
+++ b/pkgs/development/libraries/boost/generic.nix
@@ -64,8 +64,8 @@ let
   ] ++ optional (variant == "release") "debug-symbols=off";
 
   nativeB2Flags = [
-    "-sEXPAT_INCLUDE=${expat}/include"
-    "-sEXPAT_LIBPATH=${expat}/lib"
+    "-sEXPAT_INCLUDE=${expat.dev}/include"
+    "-sEXPAT_LIBPATH=${expat.out}/lib"
   ] ++ optional (toolset != null) "toolset=${toolset}"
     ++ optional (mpi != null) "--user-config=user-config.jam";
   nativeB2Args = concatStringsSep " " (genericB2Flags ++ nativeB2Flags);
diff --git a/pkgs/development/libraries/expat/default.nix b/pkgs/development/libraries/expat/default.nix
index 05cfeaee4232..082f651a3fc6 100644
--- a/pkgs/development/libraries/expat/default.nix
+++ b/pkgs/development/libraries/expat/default.nix
@@ -10,6 +10,10 @@ stdenv.mkDerivation rec {
 
   patches = [ ./CVE-2015-1283.patch ];
 
+  outputs = [ "dev" "out" ]; # TODO: fix referrers
+  outputBin = "dev";
+  outputMan = "dev"; # tiny page for a dev tool
+
   meta = with stdenv.lib; {
     homepage = http://www.libexpat.org/;
     description = "A stream-oriented XML parser library written in C";
diff --git a/pkgs/development/libraries/gettext/expat.nix b/pkgs/development/libraries/gettext/expat.nix
index fc6116b39160..35d2e1a0950f 100644
--- a/pkgs/development/libraries/gettext/expat.nix
+++ b/pkgs/development/libraries/gettext/expat.nix
@@ -5,6 +5,6 @@ runCommand "gettext-expat-${gettext.name}" { buildInputs = [ makeWrapper ]; } ''
   cp -rf ${gettext}/* $out/
   chmod a+w $out/bin
   for p in $out/bin/*; do
-    wrapProgram $p --prefix LD_LIBRARY_PATH : ${expat}/lib
+    wrapProgram $p --prefix LD_LIBRARY_PATH : ${expat.out}/lib
   done
 ''
diff --git a/pkgs/development/ocaml-modules/expat/default.nix b/pkgs/development/ocaml-modules/expat/default.nix
index f4837bd047f5..b6ee0d192e33 100644
--- a/pkgs/development/ocaml-modules/expat/default.nix
+++ b/pkgs/development/ocaml-modules/expat/default.nix
@@ -28,8 +28,8 @@ stdenv.mkDerivation {
   postPatch = ''
     substituteInPlace "unittest.ml" \
       --replace "/home/maas/xml-samples/REC-xml-19980210.xml.txt" "${testcase}"
-    substituteInPlace Makefile --replace "EXPAT_LIBDIR=/usr/local/lib" "EXPAT_LIBDIR=${expat}/lib" \
-    substituteInPlace Makefile --replace "EXPAT_INCDIR=/usr/local/include" "EXPAT_INCDIR=${expat}/include" \
+    substituteInPlace Makefile --replace "EXPAT_LIBDIR=/usr/local/lib" "EXPAT_LIBDIR=${expat.out}/lib" \
+    substituteInPlace Makefile --replace "EXPAT_INCDIR=/usr/local/include" "EXPAT_INCDIR=${expat.dev}/include" \
   '';
 
   configurePhase = "true";  	# Skip configure