summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorChris Ostrouchov <chris.ostrouchov@gmail.com>2018-10-16 16:37:02 -0400
committerFrederik Rietdijk <freddyrietdijk@fridh.nl>2018-10-18 11:02:23 +0200
commitdc56c8faf903126a0566506379bc867e71124ffb (patch)
treeaa0747c9a63bd4cb2c276a9414568c9f43ad5811 /pkgs/development
parentc26dd4138b86071816e6f5fa14400f231549428c (diff)
downloadnixlib-dc56c8faf903126a0566506379bc867e71124ffb.tar
nixlib-dc56c8faf903126a0566506379bc867e71124ffb.tar.gz
nixlib-dc56c8faf903126a0566506379bc867e71124ffb.tar.bz2
nixlib-dc56c8faf903126a0566506379bc867e71124ffb.tar.lz
nixlib-dc56c8faf903126a0566506379bc867e71124ffb.tar.xz
nixlib-dc56c8faf903126a0566506379bc867e71124ffb.tar.zst
nixlib-dc56c8faf903126a0566506379bc867e71124ffb.zip
pythonPackages.github3_py: refactor move to python-modules
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/github3_py/default.nix45
1 files changed, 45 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/github3_py/default.nix b/pkgs/development/python-modules/github3_py/default.nix
new file mode 100644
index 000000000000..8968585d9cdd
--- /dev/null
+++ b/pkgs/development/python-modules/github3_py/default.nix
@@ -0,0 +1,45 @@
+{ stdenv
+, buildPythonPackage
+, fetchPypi
+, unittest2
+, pytest
+, mock
+, betamax
+, betamax-matchers
+, dateutil
+, requests
+, pyopenssl
+, uritemplate_py
+, ndg-httpsclient
+, requests_toolbelt
+, pyasn1
+}:
+
+buildPythonPackage rec {
+  pname = "github3.py";
+  version = "1.1.0";
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "1cxaqdqmz9w2afc0cw2jyv783fp0grydbik0frzj79azzkhyg4gf";
+  };
+
+  buildInputs = [ unittest2 pytest mock betamax betamax-matchers dateutil ];
+  propagatedBuildInputs = [ requests pyopenssl uritemplate_py ndg-httpsclient requests_toolbelt pyasn1 ];
+
+  postPatch = ''
+    sed -i -e 's/mock ==1.0.1/mock>=1.0.1/' setup.py
+    sed -i -e 's/unittest2 ==0.5.1/unittest2>=0.5.1/' setup.py
+  '';
+
+  # TODO: only disable the tests that require network
+  doCheck = false;
+
+  meta = with stdenv.lib; {
+    homepage = http://github3py.readthedocs.org/en/master/;
+    description = "A wrapper for the GitHub API written in python";
+    license = licenses.bsd3;
+    maintainers = with maintainers; [ pSub ];
+  };
+
+}