summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
author(cdep)illabout <cdep.illabout@gmail.com>2018-08-28 09:55:59 +0900
committerPeter Simons <simons@cryp.to>2018-09-12 10:31:09 +0200
commitda86e4255b03510464fd32adca3ccb5fd7e77ede (patch)
tree8cb7c191ae4ebab7f7b96cfeb1ff180970c64aa5 /pkgs/development
parent1c5d7ad52efb2002bdf5a04b3a699d0d021cc224 (diff)
downloadnixlib-da86e4255b03510464fd32adca3ccb5fd7e77ede.tar
nixlib-da86e4255b03510464fd32adca3ccb5fd7e77ede.tar.gz
nixlib-da86e4255b03510464fd32adca3ccb5fd7e77ede.tar.bz2
nixlib-da86e4255b03510464fd32adca3ccb5fd7e77ede.tar.lz
nixlib-da86e4255b03510464fd32adca3ccb5fd7e77ede.tar.xz
nixlib-da86e4255b03510464fd32adca3ccb5fd7e77ede.tar.zst
nixlib-da86e4255b03510464fd32adca3ccb5fd7e77ede.zip
haskellPackages.termonad: Add dontCheck and remove from dont-distribute-packages.
The doctests for termonad fail to build only with nix.  When building
without nix, the doctests run correctly:

https://github.com/cdepillabout/termonad/issues/15

This PR disables the tests for termonad, as well as removing it from
dont-distribute-packages.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/haskell-modules/configuration-hackage2nix.yaml1
-rw-r--r--pkgs/development/haskell-modules/configuration-nix.nix4
2 files changed, 4 insertions, 1 deletions
diff --git a/pkgs/development/haskell-modules/configuration-hackage2nix.yaml b/pkgs/development/haskell-modules/configuration-hackage2nix.yaml
index 7b827664cdab..71dd526c1a3a 100644
--- a/pkgs/development/haskell-modules/configuration-hackage2nix.yaml
+++ b/pkgs/development/haskell-modules/configuration-hackage2nix.yaml
@@ -9060,7 +9060,6 @@ dont-distribute-packages:
   termcolor:                                      [ i686-linux, x86_64-linux, x86_64-darwin ]
   terminal-text:                                  [ i686-linux, x86_64-linux, x86_64-darwin ]
   termination-combinators:                        [ i686-linux, x86_64-linux, x86_64-darwin ]
-  termonad:                                       [ i686-linux, x86_64-linux, x86_64-darwin ]
   termplot:                                       [ i686-linux, x86_64-linux, x86_64-darwin ]
   terntup:                                        [ i686-linux, x86_64-linux, x86_64-darwin ]
   terrahs:                                        [ i686-linux, x86_64-linux, x86_64-darwin ]
diff --git a/pkgs/development/haskell-modules/configuration-nix.nix b/pkgs/development/haskell-modules/configuration-nix.nix
index dd599f67bc06..d016bd6ce8d6 100644
--- a/pkgs/development/haskell-modules/configuration-nix.nix
+++ b/pkgs/development/haskell-modules/configuration-nix.nix
@@ -507,4 +507,8 @@ self: super: builtins.intersectAttrs super {
   LDAP = dontCheck (overrideCabal super.LDAP (drv: {
     librarySystemDepends = drv.librarySystemDepends or [] ++ [ pkgs.cyrus_sasl.dev ];
   }));
+
+  # Doctests hang only when compiling with nix.
+  # https://github.com/cdepillabout/termonad/issues/15
+  termonad = dontCheck super.termonad;
 }