summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorVincent Laporte <Vincent.Laporte@gmail.com>2018-05-03 18:37:47 +0000
committerVincent Laporte <Vincent.Laporte@gmail.com>2018-05-04 07:04:17 +0000
commitd8ebe4f2cfce622066f174bc33a35910ea52093e (patch)
tree246486cc49186f32ffa31f3e1542830cc0ac14f8 /pkgs/development
parent301f14e993e54d1fa79b47c2efa699ea2c774b4b (diff)
downloadnixlib-d8ebe4f2cfce622066f174bc33a35910ea52093e.tar
nixlib-d8ebe4f2cfce622066f174bc33a35910ea52093e.tar.gz
nixlib-d8ebe4f2cfce622066f174bc33a35910ea52093e.tar.bz2
nixlib-d8ebe4f2cfce622066f174bc33a35910ea52093e.tar.lz
nixlib-d8ebe4f2cfce622066f174bc33a35910ea52093e.tar.xz
nixlib-d8ebe4f2cfce622066f174bc33a35910ea52093e.tar.zst
nixlib-d8ebe4f2cfce622066f174bc33a35910ea52093e.zip
ocamlPackages.git: 1.11.4 -> 1.11.5
Also enable tests
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/ocaml-modules/git-http/default.nix9
-rw-r--r--pkgs/development/ocaml-modules/git/default.nix10
2 files changed, 14 insertions, 5 deletions
diff --git a/pkgs/development/ocaml-modules/git-http/default.nix b/pkgs/development/ocaml-modules/git-http/default.nix
index 5b93b9607658..5e757b5b6727 100644
--- a/pkgs/development/ocaml-modules/git-http/default.nix
+++ b/pkgs/development/ocaml-modules/git-http/default.nix
@@ -1,10 +1,12 @@
-{ stdenv, ocaml, findlib, jbuilder, git, cohttp-lwt }:
+{ stdenv, ocaml, findlib, jbuilder, git, cohttp-lwt
+, alcotest, mtime, nocrypto
+}:
 
 stdenv.mkDerivation rec {
 	name = "ocaml${ocaml.version}-git-http-${version}";
 	inherit (git) version src;
 
-	buildInputs = [ ocaml findlib jbuilder ];
+	buildInputs = [ ocaml findlib jbuilder alcotest mtime nocrypto ];
 
 	propagatedBuildInputs = [ git cohttp-lwt ];
 
@@ -12,6 +14,9 @@ stdenv.mkDerivation rec {
 
 	inherit (jbuilder) installPhase;
 
+	doCheck = true;
+	checkPhase = "jbuilder runtest -p git-http";
+
 	meta = {
 		description = "Client implementation of the “Smart” HTTP Git protocol in pure OCaml";
 		inherit (git.meta) homepage license maintainers platforms;
diff --git a/pkgs/development/ocaml-modules/git/default.nix b/pkgs/development/ocaml-modules/git/default.nix
index 9347c6ad00cd..6f0f0d0b120b 100644
--- a/pkgs/development/ocaml-modules/git/default.nix
+++ b/pkgs/development/ocaml-modules/git/default.nix
@@ -1,19 +1,20 @@
 { stdenv, fetchFromGitHub, ocaml, findlib, jbuilder, opam
 , astring, decompress, fmt, hex, logs, mstruct, ocaml_lwt, ocamlgraph, uri
+, alcotest, mtime, nocrypto
 }:
 
 stdenv.mkDerivation rec {
-	version = "1.11.4";
+	version = "1.11.5";
 	name = "ocaml${ocaml.version}-git-${version}";
 
 	src = fetchFromGitHub {
 		owner = "mirage";
 		repo = "ocaml-git";
 		rev = version;
-		sha256 = "182b6shcfcq50r5snm01hwalnmck43x1xgdd4fvjb6q78pbwag2x";
+		sha256 = "0r1bxpxjjnl9hh8xbabsxl7svzvd19hfy73a2y1m4kljmw64dpfh";
 	};
 
-	buildInputs = [ ocaml findlib jbuilder ];
+	buildInputs = [ ocaml findlib jbuilder alcotest mtime nocrypto ];
 
 	propagatedBuildInputs = [ astring decompress fmt hex logs mstruct ocaml_lwt ocamlgraph uri ];
 
@@ -21,6 +22,9 @@ stdenv.mkDerivation rec {
 
 	inherit (jbuilder) installPhase;
 
+	doCheck = true;
+	checkPhase = "jbuilder runtest -p git";
+
 	meta = {
 		description = "Git format and protocol in pure OCaml";
 		license = stdenv.lib.licenses.isc;