summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorLluís Batlle i Rossell <viric@vicerveza.homeunix.net>2009-07-26 22:47:33 +0000
committerLluís Batlle i Rossell <viric@vicerveza.homeunix.net>2009-07-26 22:47:33 +0000
commitd4aedd92cc37de2cd8d5c5bc7520bfc433383fc2 (patch)
tree298ff00968cbd6706cfcb2ee7f39479780fb10dd /pkgs/development
parent4f5e00f6860d2cd63fd6254801479bfe743274aa (diff)
downloadnixlib-d4aedd92cc37de2cd8d5c5bc7520bfc433383fc2.tar
nixlib-d4aedd92cc37de2cd8d5c5bc7520bfc433383fc2.tar.gz
nixlib-d4aedd92cc37de2cd8d5c5bc7520bfc433383fc2.tar.bz2
nixlib-d4aedd92cc37de2cd8d5c5bc7520bfc433383fc2.tar.lz
nixlib-d4aedd92cc37de2cd8d5c5bc7520bfc433383fc2.tar.xz
nixlib-d4aedd92cc37de2cd8d5c5bc7520bfc433383fc2.tar.zst
nixlib-d4aedd92cc37de2cd8d5c5bc7520bfc433383fc2.zip
I revert my changes to get nixpkgs working on armv5tel-linux.
I thought I didn't change stdenv, but I did. This will go soon into the stdenv
branch then.
Reverse-merging r16467 through r16465.


svn path=/nixpkgs/trunk/; revision=16468
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/interpreters/perl-5.10/default.nix15
1 files changed, 5 insertions, 10 deletions
diff --git a/pkgs/development/interpreters/perl-5.10/default.nix b/pkgs/development/interpreters/perl-5.10/default.nix
index e7b6af563d6f..a8b8dd536a75 100644
--- a/pkgs/development/interpreters/perl-5.10/default.nix
+++ b/pkgs/development/interpreters/perl-5.10/default.nix
@@ -1,12 +1,5 @@
 {stdenv, fetchurl}:
 
-let
-  preBuildNoNative = ''
-      # Make Cwd work on NixOS (where we don't have a /bin/pwd).
-      substituteInPlace lib/Cwd.pm --replace "'/bin/pwd'" "'$(type -tP pwd)'"
-    '';
-  preBuildNative = "";
-in
 stdenv.mkDerivation {
   name = "perl-5.10.0";
 
@@ -29,10 +22,8 @@ stdenv.mkDerivation {
   # "installstyle" option to ensure that modules are put under
   # $out/lib/perl5 - this is the general default, but because $out
   # contains the string "perl", Configure would select $out/lib.
-  # Miniperl needs -lm. perl needs -lrt.
   configureFlags = ''
     -de -Dcc=gcc -Uinstallusrbinperl -Dinstallstyle=lib/perl5 -Duseshrplib
-    -Dldflags='-lm -lrt'
     ${if stdenv ? glibc then "-Dusethreads" else ""}
   '';
 
@@ -50,7 +41,11 @@ stdenv.mkDerivation {
       fi
     '';
 
-  preBuild = if (stdenv.gcc.nativeTools) then preBuildNative else preBuildNoNative;
+  preBuild =
+    ''
+      # Make Cwd work on NixOS (where we don't have a /bin/pwd).
+      substituteInPlace lib/Cwd.pm --replace "'/bin/pwd'" "'$(type -tP pwd)'"
+    '';
 
   setupHook = ./setup-hook.sh;
 }