summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorVincent Laporte <Vincent.Laporte@gmail.com>2015-06-11 23:59:55 +0200
committerVincent Laporte <Vincent.Laporte@gmail.com>2015-06-25 08:55:28 +0200
commitd440059e7d828518735134aed8826da5214e6efa (patch)
tree0cefa2d9fd9410e7f653a220561c12a5805556c8 /pkgs/development
parentaf3f91085a0c7b8f8b9a7c0cdd780463d4fc473d (diff)
downloadnixlib-d440059e7d828518735134aed8826da5214e6efa.tar
nixlib-d440059e7d828518735134aed8826da5214e6efa.tar.gz
nixlib-d440059e7d828518735134aed8826da5214e6efa.tar.bz2
nixlib-d440059e7d828518735134aed8826da5214e6efa.tar.lz
nixlib-d440059e7d828518735134aed8826da5214e6efa.tar.xz
nixlib-d440059e7d828518735134aed8826da5214e6efa.tar.zst
nixlib-d440059e7d828518735134aed8826da5214e6efa.zip
OCaml-4.02: fix ocamlbuild
This addresses the issue described at http://caml.inria.fr/mantis/view.php?id=6605
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/ocaml/4.02.1.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/pkgs/development/compilers/ocaml/4.02.1.nix b/pkgs/development/compilers/ocaml/4.02.1.nix
index 6f4cce522e46..d70fe3384e03 100644
--- a/pkgs/development/compilers/ocaml/4.02.1.nix
+++ b/pkgs/development/compilers/ocaml/4.02.1.nix
@@ -9,6 +9,10 @@ assert useX11 -> !stdenv.isArm && !stdenv.isMips;
 let
    useNativeCompilers = !stdenv.isMips;
    inherit (stdenv.lib) optionals optionalString;
+   patchOcamlBuild = fetchurl {
+     url = https://github.com/ocaml/ocaml/pull/117.patch;
+     sha256 = "0x2cdn2sgzq29qzqg5y2ial0jqy8gjg5a7jf8qqch55dc4vkyjw0";
+   };
 in
 
 stdenv.mkDerivation rec {
@@ -24,6 +28,8 @@ stdenv.mkDerivation rec {
     sha256 = "1p7lqvh64xpykh99014mz21q8fs3qyjym2qazhhbq8scwldv1i38";
   };
 
+  patches = [ patchOcamlBuild ];
+
   prefixKey = "-prefix ";
   configureFlags = optionals useX11 [ "-x11lib" x11lib
                                       "-x11include" x11inc ];