summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2014-09-28 15:24:38 -0400
committerShea Levy <shea@shealevy.com>2014-09-28 15:24:38 -0400
commitd34cd13a317dd0df5af9f3a67ad22e9ea8f9e505 (patch)
tree0994770bcdeb0803cccae4a6bfc2f2146b2db715 /pkgs/development
parent58d838024b886af0944731401b14be683618e2ff (diff)
downloadnixlib-d34cd13a317dd0df5af9f3a67ad22e9ea8f9e505.tar
nixlib-d34cd13a317dd0df5af9f3a67ad22e9ea8f9e505.tar.gz
nixlib-d34cd13a317dd0df5af9f3a67ad22e9ea8f9e505.tar.bz2
nixlib-d34cd13a317dd0df5af9f3a67ad22e9ea8f9e505.tar.lz
nixlib-d34cd13a317dd0df5af9f3a67ad22e9ea8f9e505.tar.xz
nixlib-d34cd13a317dd0df5af9f3a67ad22e9ea8f9e505.tar.zst
nixlib-d34cd13a317dd0df5af9f3a67ad22e9ea8f9e505.zip
Add nix-exec package
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/interpreters/nix-exec/default.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/pkgs/development/interpreters/nix-exec/default.nix b/pkgs/development/interpreters/nix-exec/default.nix
new file mode 100644
index 000000000000..999d4d8a0d21
--- /dev/null
+++ b/pkgs/development/interpreters/nix-exec/default.nix
@@ -0,0 +1,23 @@
+{ stdenv, fetchurl, pkgconfig, nix }: let
+  version = "1.0.0";
+in stdenv.mkDerivation {
+  name = "nix-exec-${version}";
+
+  src = fetchurl {
+    url = "https://github.com/shlevy/nix-exec/releases/download/v${version}/nix-exec-${version}.tar.xz";
+
+    sha256 = "0w89ma69iil1ki68zvs1l0ii0d87in64791l3a4yzyv9d3ncl3w6";
+  };
+
+  buildInputs = [ pkgconfig nix ];
+
+  meta = {
+    description = "Run programs defined in nix expressions";
+
+    homepage = https://github.com/shlevy/nix-exec;
+
+    license = stdenv.lib.licenses.mit;
+
+    maintainers = [ stdenv.lib.maintainers.shlevy ];
+  };
+}