summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorhsloan <ishaqsloan@gmail.com>2017-06-28 16:24:16 -0400
committerJohn Ericson <John.Ericson@Obsidian.Systems>2017-06-28 19:41:29 -0400
commitd28eb3b7a04dc7b057e3f0ee77cc7e07cfc7cf61 (patch)
tree83d0a53cac0324afbf760caad326144c9422d82a /pkgs/development
parent51856df2a1b465eb93d5966f2013f64a916d5a65 (diff)
downloadnixlib-d28eb3b7a04dc7b057e3f0ee77cc7e07cfc7cf61.tar
nixlib-d28eb3b7a04dc7b057e3f0ee77cc7e07cfc7cf61.tar.gz
nixlib-d28eb3b7a04dc7b057e3f0ee77cc7e07cfc7cf61.tar.bz2
nixlib-d28eb3b7a04dc7b057e3f0ee77cc7e07cfc7cf61.tar.lz
nixlib-d28eb3b7a04dc7b057e3f0ee77cc7e07cfc7cf61.tar.xz
nixlib-d28eb3b7a04dc7b057e3f0ee77cc7e07cfc7cf61.tar.zst
nixlib-d28eb3b7a04dc7b057e3f0ee77cc7e07cfc7cf61.zip
poppler: Don't use stdenv.cross
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/poppler/default.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/pkgs/development/libraries/poppler/default.nix b/pkgs/development/libraries/poppler/default.nix
index 20e35fa3e089..856c7bac8ce1 100644
--- a/pkgs/development/libraries/poppler/default.nix
+++ b/pkgs/development/libraries/poppler/default.nix
@@ -6,6 +6,7 @@
 , introspectionSupport ? false, gobjectIntrospection ? null
 , utils ? false
 , minimal ? false, suffix ? "glib"
+, hostPlatform
 }:
 
 let # beware: updates often break cups-filters build
@@ -56,7 +57,7 @@ stdenv.mkDerivation rec {
 
   crossAttrs.postPatch =
     # there are tests using `strXXX_s` functions that are missing apparently
-    stdenv.lib.optionalString (stdenv.cross.libc or null == "msvcrt")
+    stdenv.lib.optionalString (hostPlatform.libc or null == "msvcrt")
       "sed '/^SUBDIRS =/s/ test / /' -i Makefile.in";
 
   meta = with lib; {