summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authoradisbladis <adis@blad.is>2018-02-09 16:41:49 +0800
committeradisbladis <adis@blad.is>2018-02-09 16:46:21 +0800
commitd1c5b483d2cade5c48f295cf168a8c3d814e4f37 (patch)
treeba0b71619344145632c1c71b8c47c0b7e368e045 /pkgs/development
parent7ca084292a2ca21f66ee3b73b44617066ca1e129 (diff)
downloadnixlib-d1c5b483d2cade5c48f295cf168a8c3d814e4f37.tar
nixlib-d1c5b483d2cade5c48f295cf168a8c3d814e4f37.tar.gz
nixlib-d1c5b483d2cade5c48f295cf168a8c3d814e4f37.tar.bz2
nixlib-d1c5b483d2cade5c48f295cf168a8c3d814e4f37.tar.lz
nixlib-d1c5b483d2cade5c48f295cf168a8c3d814e4f37.tar.xz
nixlib-d1c5b483d2cade5c48f295cf168a8c3d814e4f37.tar.zst
nixlib-d1c5b483d2cade5c48f295cf168a8c3d814e4f37.zip
yaml2json: init at unstable-2017-05-03
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/yaml2json/default.nix24
-rw-r--r--pkgs/development/tools/yaml2json/deps.nix11
2 files changed, 35 insertions, 0 deletions
diff --git a/pkgs/development/tools/yaml2json/default.nix b/pkgs/development/tools/yaml2json/default.nix
new file mode 100644
index 000000000000..1a8d7f13aff5
--- /dev/null
+++ b/pkgs/development/tools/yaml2json/default.nix
@@ -0,0 +1,24 @@
+{ stdenv, buildGoPackage, fetchFromGitHub }:
+
+
+buildGoPackage rec {
+  name = "yaml2json-${version}";
+  version = "unstable-2017-05-03";
+  goPackagePath = "github.com/bronze1man/yaml2json";
+
+  goDeps = ./deps.nix;
+
+  src = fetchFromGitHub {
+    rev = "ee8196e587313e98831c040c26262693d48c1a0c";
+    owner = "bronze1man";
+    repo = "yaml2json";
+    sha256 = "16a2sqzbam5adbhfvilnpdabzwncs7kgpr0cn4gp09h2imzsprzw";
+  };
+
+  meta = with stdenv.lib; {
+    homepage = https://github.com/bronze1man/yaml2json;
+    description = "Convert yaml to json";
+    license = with licenses; [ mit ];
+    maintainers = [ maintainers.adisbladis ];
+  };
+}
diff --git a/pkgs/development/tools/yaml2json/deps.nix b/pkgs/development/tools/yaml2json/deps.nix
new file mode 100644
index 000000000000..f907520cc872
--- /dev/null
+++ b/pkgs/development/tools/yaml2json/deps.nix
@@ -0,0 +1,11 @@
+[
+  {
+    goPackagePath = "gopkg.in/yaml.v2";
+    fetch = {
+      type = "git";
+      url = "https://gopkg.in/yaml.v2";
+      rev = "d670f9405373e636a5a2765eea47fac0c9bc91a4";
+      sha256 = "1w1xid51n8v1mydn2m3vgggw8qgpd5a5sr62snsc77d99fpjsrs0";
+    };
+  }
+]