summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorxeji <36407913+xeji@users.noreply.github.com>2018-09-23 23:29:10 +0200
committerGitHub <noreply@github.com>2018-09-23 23:29:10 +0200
commitccd2862130a4c2a5bad2b928fdb348de1e471d34 (patch)
tree667365079e33fc29e3093674a85dbe17b906e89c /pkgs/development
parent9b67908e6799aeb1665f6424f2c3df5352d22aa0 (diff)
parentdbd57837913b6322a314c52a071a8b343318b543 (diff)
downloadnixlib-ccd2862130a4c2a5bad2b928fdb348de1e471d34.tar
nixlib-ccd2862130a4c2a5bad2b928fdb348de1e471d34.tar.gz
nixlib-ccd2862130a4c2a5bad2b928fdb348de1e471d34.tar.bz2
nixlib-ccd2862130a4c2a5bad2b928fdb348de1e471d34.tar.lz
nixlib-ccd2862130a4c2a5bad2b928fdb348de1e471d34.tar.xz
nixlib-ccd2862130a4c2a5bad2b928fdb348de1e471d34.tar.zst
nixlib-ccd2862130a4c2a5bad2b928fdb348de1e471d34.zip
Merge pull request #47141 from vbgl/jackline-20180511
jackline: 2017-12-24 -> 2018-05-11
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/ocaml-modules/erm_xml/default.nix12
-rw-r--r--pkgs/development/ocaml-modules/erm_xmpp/0.3.nix29
-rw-r--r--pkgs/development/ocaml-modules/erm_xmpp/default.nix41
3 files changed, 26 insertions, 56 deletions
diff --git a/pkgs/development/ocaml-modules/erm_xml/default.nix b/pkgs/development/ocaml-modules/erm_xml/default.nix
index c944752ff6b6..35b5c73b578b 100644
--- a/pkgs/development/ocaml-modules/erm_xml/default.nix
+++ b/pkgs/development/ocaml-modules/erm_xml/default.nix
@@ -1,17 +1,17 @@
 { stdenv, fetchzip, ocaml, findlib, ocamlbuild }:
 
-if stdenv.lib.versionAtLeast ocaml.version "4.06"
+if !stdenv.lib.versionAtLeast ocaml.version "4.02"
 then throw "erm_xml is not available for OCaml ${ocaml.version}"
 else
 
-let version = "0.3"; in
+let version = "0.3+20180112"; in
 
 stdenv.mkDerivation {
-  name = "ocaml-erm_xml-${version}";
+  name = "ocaml${ocaml.version}-erm_xml-${version}";
 
   src = fetchzip {
-    url = "https://github.com/ermine/xml/archive/v${version}.tar.gz";
-    sha256 = "19znk5w0qiw3wij4n6w3h5bcr221yy57jf815fr8k9m8kin710g3";
+    url = "https://github.com/hannesm/xml/archive/bbabdade807d8281fc48806da054b70dfe482479.tar.gz";
+    sha256 = "1gawpmg8plip0wia0xq60m024dn7l3ykwbjpbqx9f9bdmx74n1rr";
   };
 
   buildInputs = [ ocaml findlib ocamlbuild ];
@@ -19,7 +19,7 @@ stdenv.mkDerivation {
   createFindlibDestdir = true;
 
   meta = {
-    homepage = https://github.com/ermine/xml;
+    homepage = https://github.com/hannesm/xml;
     description = "XML Parser for discrete data";
     platforms = ocaml.meta.platforms or [];
     license = stdenv.lib.licenses.bsd3;
diff --git a/pkgs/development/ocaml-modules/erm_xmpp/0.3.nix b/pkgs/development/ocaml-modules/erm_xmpp/0.3.nix
deleted file mode 100644
index 1a8f854185a2..000000000000
--- a/pkgs/development/ocaml-modules/erm_xmpp/0.3.nix
+++ /dev/null
@@ -1,29 +0,0 @@
-{ stdenv, buildOcaml, fetchFromGitHub, ocaml, findlib, erm_xml, nocrypto }:
-
-buildOcaml rec {
-  version = "0.3";
-  name = "erm_xmpp";
-
-  src = fetchFromGitHub {
-    owner  = "hannesm";
-    repo   = "xmpp";
-    rev    = "eee18bd3dd343550169969c0b45548eafd51cfe1";
-    sha256 = "0hzs528lrx1ayalv6fh555pjn0b4l8xch1f72hd3b07g1xahdas5";
-  };
-
-  buildInputs = [ ocaml findlib ];
-  propagatedBuildInputs = [ erm_xml nocrypto ];
-
-  configurePhase = "ocaml setup.ml -configure --prefix $out";
-  buildPhase = "ocaml setup.ml -build";
-  installPhase = "ocaml setup.ml -install";
-
-  createFindlibDestdir = true;
-
-  meta = {
-    homepage = https://github.com/hannesm/xmpp;
-    description = "OCaml based XMPP implementation (fork)";
-    license = stdenv.lib.licenses.bsd3;
-    maintainers = with stdenv.lib.maintainers; [ sternenseemann ];
-  };
-}
diff --git a/pkgs/development/ocaml-modules/erm_xmpp/default.nix b/pkgs/development/ocaml-modules/erm_xmpp/default.nix
index c6027ce11ce5..a6bb75e61c24 100644
--- a/pkgs/development/ocaml-modules/erm_xmpp/default.nix
+++ b/pkgs/development/ocaml-modules/erm_xmpp/default.nix
@@ -1,33 +1,32 @@
-{ stdenv, fetchurl, fetchzip, ocaml, findlib, ocamlbuild, erm_xml, cryptokit, camlp4 }:
+{ stdenv, fetchFromGitHub, ocaml, findlib, camlp4, ocamlbuild
+, erm_xml, nocrypto
+}:
 
-let
-  version = "0.2";
-  disable-tests = fetchurl {
-    url = https://raw.githubusercontent.com/ocaml/opam-repository/master/packages/erm_xmpp/erm_xmpp.0.2/files/disable_tests.patch;
-    sha256 = "09d8630nmx2x8kb8ap1zmsb93zs14cqg7ga1gmdl92jvsjxbhgc1";
-  };
-in
-
-stdenv.mkDerivation {
-  name = "ocaml-erm_xmpp-${version}";
+stdenv.mkDerivation rec {
+  version = "0.3+20180112";
+  name = "ocaml${ocaml.version}-erm_xmpp-${version}";
 
-  src = fetchzip {
-    url = "https://github.com/ermine/xmpp/archive/v${version}.tar.gz";
-    sha256 = "0saw2dmrzv2aadrznvyvchnhivvcwm78x9nwf6flq5v0pqddapk2";
+  src = fetchFromGitHub {
+    owner  = "hannesm";
+    repo   = "xmpp";
+    rev    = "184dc70fab7d46d09b9148ca4448f07f1e0a2df2";
+    sha256 = "1dsqsfacvd9xqsqjzh6xwbnf2mv1dvhy210riyvjd260q085ch6n";
   };
 
-  patches = [ disable-tests ];
-
   buildInputs = [ ocaml findlib ocamlbuild camlp4 ];
-  propagatedBuildInputs = [ erm_xml cryptokit ];
+  propagatedBuildInputs = [ erm_xml nocrypto ];
+
+  configurePhase = "ocaml setup.ml -configure --prefix $out";
+  buildPhase = "ocaml setup.ml -build";
+  installPhase = "ocaml setup.ml -install";
 
   createFindlibDestdir = true;
 
   meta = {
-    homepage = https://github.com/ermine/xmpp;
-    description = "OCaml based XMPP implementation";
-    platforms = ocaml.meta.platforms or [];
+    homepage = https://github.com/hannesm/xmpp;
+    description = "OCaml based XMPP implementation (fork)";
     license = stdenv.lib.licenses.bsd3;
-    maintainers = with stdenv.lib.maintainers; [ vbgl ];
+    maintainers = with stdenv.lib.maintainers; [ sternenseemann ];
+    inherit (ocaml.meta) platforms;
   };
 }