summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorTravis B. Hartwell <nafai@travishartwell.net>2015-06-19 15:17:00 -0600
committerTravis B. Hartwell <nafai@travishartwell.net>2015-06-19 15:32:12 -0600
commitcaa216b640a78e04615f529adecd1374344205e6 (patch)
treeddc62ad1df9882d668b309492ae41433969495e8 /pkgs/development
parent7720c7d75fac24827c365a1565a1c950c6576984 (diff)
downloadnixlib-caa216b640a78e04615f529adecd1374344205e6.tar
nixlib-caa216b640a78e04615f529adecd1374344205e6.tar.gz
nixlib-caa216b640a78e04615f529adecd1374344205e6.tar.bz2
nixlib-caa216b640a78e04615f529adecd1374344205e6.tar.lz
nixlib-caa216b640a78e04615f529adecd1374344205e6.tar.xz
nixlib-caa216b640a78e04615f529adecd1374344205e6.tar.zst
nixlib-caa216b640a78e04615f529adecd1374344205e6.zip
atom-shell: renamed to electron and updated 0.19.1 -> 0.28.2
Added systemd to buildEnv path because of new libudev dependency.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/electron/default.nix (renamed from pkgs/development/tools/atom-shell/default.nix)18
1 files changed, 9 insertions, 9 deletions
diff --git a/pkgs/development/tools/atom-shell/default.nix b/pkgs/development/tools/electron/default.nix
index 4e5413b50122..4589b07343b4 100644
--- a/pkgs/development/tools/atom-shell/default.nix
+++ b/pkgs/development/tools/electron/default.nix
@@ -1,6 +1,7 @@
 { stdenv, fetchurl, buildEnv, makeDesktopItem, makeWrapper, zlib, glib, alsaLib
 , dbus, gtk, atk, pango, freetype, fontconfig, libgnome_keyring3, gdk_pixbuf
 , cairo, cups, expat, libgpgerror, nspr, gconf, nss, xlibs, libcap, unzip
+, systemd
 }:
 let
   atomEnv = buildEnv {
@@ -10,16 +11,16 @@ let
       fontconfig gdk_pixbuf cairo cups expat libgpgerror alsaLib nspr gconf nss
       xlibs.libXrender xlibs.libX11 xlibs.libXext xlibs.libXdamage xlibs.libXtst
       xlibs.libXcomposite xlibs.libXi xlibs.libXfixes xlibs.libXrandr
-      xlibs.libXcursor libcap
+      xlibs.libXcursor libcap systemd
     ];
   };
 in stdenv.mkDerivation rec {
-  name = "atom-shell-${version}";
-  version = "0.19.1";
+  name = "electron-${version}";
+  version = "0.28.2";
 
   src = fetchurl {
-    url = "https://github.com/atom/atom-shell/releases/download/v0.19.1/atom-shell-v0.19.1-linux-x64.zip";
-    sha256 = "10q1slwv2lkiqqxpv0m5a1k0gj2yp8bi9a7ilb05zz1wg7j3yw4y";
+    url = "https://github.com/atom/electron/releases/download/v${version}/electron-v${version}-linux-x64.zip";
+    sha256 = "55b0880e2f78a60d95a58e83cd75006c34cb6ed90836e1f34e3359c3e5d0b8f0";
     name = "${name}.zip";
   };
 
@@ -33,15 +34,14 @@ in stdenv.mkDerivation rec {
     mkdir -p $out/bin
     unzip -d $out/bin $src
     patchelf --set-interpreter "$(cat $NIX_CC/nix-support/dynamic-linker)" \
-    $out/bin/atom
-    mv $out/bin/atom $out/bin/atom-shell
-    wrapProgram $out/bin/atom-shell \
+    $out/bin/electron
+    wrapProgram $out/bin/electron \
     --prefix "LD_LIBRARY_PATH" : "${atomEnv}/lib:${atomEnv}/lib64"
   '';
 
   meta = with stdenv.lib; {
     description = "Cross platform desktop application shell";
-    homepage = https://github.com/atom/atom-shell;
+    homepage = https://github.com/atom/electron;
     license = licenses.mit;
     maintainers = [ maintainers.fluffynukeit ];
     platforms = [ "x86_64-linux" ];