summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorDaniel Austin <dan@fluffynukeit.com>2014-09-20 18:20:29 +0200
committerMateusz Kowalczyk <fuuzetsu@fuuzetsu.co.uk>2014-09-21 20:15:18 +0100
commitc8ba9e285aee618663294e44b76cb868af6711dd (patch)
tree37d6d9ac42d7ffc98d5289eec3669ace6b30772b /pkgs/development
parentdb23eace0dcc2ae65c3277de9138b03c20aff9c9 (diff)
downloadnixlib-c8ba9e285aee618663294e44b76cb868af6711dd.tar
nixlib-c8ba9e285aee618663294e44b76cb868af6711dd.tar.gz
nixlib-c8ba9e285aee618663294e44b76cb868af6711dd.tar.bz2
nixlib-c8ba9e285aee618663294e44b76cb868af6711dd.tar.lz
nixlib-c8ba9e285aee618663294e44b76cb868af6711dd.tar.xz
nixlib-c8ba9e285aee618663294e44b76cb868af6711dd.tar.zst
nixlib-c8ba9e285aee618663294e44b76cb868af6711dd.zip
haskell-jwt: add 0.4.0
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/haskell/jwt/default.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/pkgs/development/libraries/haskell/jwt/default.nix b/pkgs/development/libraries/haskell/jwt/default.nix
new file mode 100644
index 000000000000..e67b9e5b8df2
--- /dev/null
+++ b/pkgs/development/libraries/haskell/jwt/default.nix
@@ -0,0 +1,26 @@
+{ cabal, aeson, base64Bytestring, cryptohash, dataDefault
+, httpTypes, HUnit, network, QuickCheck, scientific, tasty
+, tastyHunit, tastyQuickcheck, tastyTh, text, time
+, unorderedContainers
+}:
+
+cabal.mkDerivation (self: {
+  pname = "jwt";
+  version = "0.4.0";
+  sha256 = "0kfdrl795h7nyai1gk056kjbw2c5n3bc30aq9466pky5jv6ywlbz";
+  buildDepends = [
+    aeson base64Bytestring cryptohash dataDefault httpTypes network
+    scientific text time unorderedContainers
+  ];
+  testDepends = [
+    aeson base64Bytestring cryptohash dataDefault httpTypes HUnit
+    network QuickCheck scientific tasty tastyHunit tastyQuickcheck
+    tastyTh text time unorderedContainers
+  ];
+  meta = {
+    homepage = "https://bitbucket.org/ssaasen/haskell-jwt";
+    description = "JSON Web Token (JWT) decoding and encoding";
+    license = self.stdenv.lib.licenses.mit;
+    platforms = self.ghc.meta.platforms;
+  };
+})