summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorNikolay Amiantov <ab@fmap.me>2017-11-10 20:06:10 +0300
committerNikolay Amiantov <ab@fmap.me>2017-11-10 22:34:42 +0300
commitc69d90b88867b0d8ebcf526ce02f9b33763b1c84 (patch)
tree72958a73677ddab8663c4aa223a59408673b7b84 /pkgs/development
parent6bdee9c7300fe415bb74ce93e45fd880445b18c7 (diff)
downloadnixlib-c69d90b88867b0d8ebcf526ce02f9b33763b1c84.tar
nixlib-c69d90b88867b0d8ebcf526ce02f9b33763b1c84.tar.gz
nixlib-c69d90b88867b0d8ebcf526ce02f9b33763b1c84.tar.bz2
nixlib-c69d90b88867b0d8ebcf526ce02f9b33763b1c84.tar.lz
nixlib-c69d90b88867b0d8ebcf526ce02f9b33763b1c84.tar.xz
nixlib-c69d90b88867b0d8ebcf526ce02f9b33763b1c84.tar.zst
nixlib-c69d90b88867b0d8ebcf526ce02f9b33763b1c84.zip
bazel: fix lost dependencies
Fixes #31249
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/build-managers/bazel/default.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/pkgs/development/tools/build-managers/bazel/default.nix b/pkgs/development/tools/build-managers/bazel/default.nix
index 724ae2c80ea5..a1452d330be0 100644
--- a/pkgs/development/tools/build-managers/bazel/default.nix
+++ b/pkgs/development/tools/build-managers/bazel/default.nix
@@ -89,6 +89,12 @@ stdenv.mkDerivation rec {
     cp scripts/zsh_completion/_bazel $out/share/zsh/site-functions/
   '';
 
+  # Save paths to hardcoded dependencies so Nix can detect them.
+  postFixup = ''
+    mkdir -p $out/nix-support
+    echo "${customBash} ${coreutils}" > $out/nix-support/depends
+  '';
+
   dontStrip = true;
   dontPatchELF = true;
 }