summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorMarc Weber <marco-oweber@gmx.de>2010-01-04 07:44:32 +0000
committerMarc Weber <marco-oweber@gmx.de>2010-01-04 07:44:32 +0000
commitc62430f6a6a9097546739fc8791f20797680d2af (patch)
tree38a1006689077d5adc13d53408de6176fd9c5fab /pkgs/development
parent78dbd14786a49e7419cf02a0f31c3ccde0a80f29 (diff)
downloadnixlib-c62430f6a6a9097546739fc8791f20797680d2af.tar
nixlib-c62430f6a6a9097546739fc8791f20797680d2af.tar.gz
nixlib-c62430f6a6a9097546739fc8791f20797680d2af.tar.bz2
nixlib-c62430f6a6a9097546739fc8791f20797680d2af.tar.lz
nixlib-c62430f6a6a9097546739fc8791f20797680d2af.tar.xz
nixlib-c62430f6a6a9097546739fc8791f20797680d2af.tar.zst
nixlib-c62430f6a6a9097546739fc8791f20797680d2af.zip
ghc version bump to latest stable release 6.12.1
make cabal expression add etxra library paths only if they exist.
Adding myself as maintainer so that the buildfarm builds ghc.

svn path=/nixpkgs/trunk/; revision=19198
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/ghc/6.12.1.nix8
-rw-r--r--pkgs/development/libraries/haskell/cabal/cabal.nix13
2 files changed, 16 insertions, 5 deletions
diff --git a/pkgs/development/compilers/ghc/6.12.1.nix b/pkgs/development/compilers/ghc/6.12.1.nix
index 9b108fbad8a0..0360db249541 100644
--- a/pkgs/development/compilers/ghc/6.12.1.nix
+++ b/pkgs/development/compilers/ghc/6.12.1.nix
@@ -1,15 +1,15 @@
 {stdenv, fetchurl, ghc, perl, gmp, ncurses}:
 
 stdenv.mkDerivation rec {
-  version = "6.12.0.20091010";
+  version = "6.12.1";
   
   name = "ghc-${version}";
   
   homepage = "http://haskell.org/ghc";
 
   src = fetchurl {
-    url = "http://darcs.haskell.org/~ghc/dist/6.12.1rc1/${name}-src.tar.bz2";
-    sha256 = "903552917778329fc79cc273ece81030324006f47157ddd4278cb08c1c637fd3";
+    url = http://haskell.org/ghc/dist/6.12.1/ghc-6.12.1-src.tar.bz2;
+    sha256 = "0ajm4sypk4zgjp0m6i03fadyv5dm9vlqfnvsx1g94yk7vnd9zyfd";
   };
 
   buildInputs = [ghc perl gmp ncurses];
@@ -34,6 +34,8 @@ stdenv.mkDerivation rec {
   meta = {
     inherit homepage;
     description = "The Glasgow Haskell Compiler";
+    maintainers = [stdenv.lib.maintainers.marcweber];
+    platforms = stdenv.platforms.linux;
   };
 
 
diff --git a/pkgs/development/libraries/haskell/cabal/cabal.nix b/pkgs/development/libraries/haskell/cabal/cabal.nix
index c4ea86a4ac72..5c83e90dc447 100644
--- a/pkgs/development/libraries/haskell/cabal/cabal.nix
+++ b/pkgs/development/libraries/haskell/cabal/cabal.nix
@@ -37,7 +37,7 @@ attrs :
             propagatedBuildInputs = [];
 
             # library directories that have to be added to the Cabal files
-            extraLibDirs = attrs.lib.lists.concatMap (x : [ (x + "/lib64") (x + "/lib") ]) self.propagatedBuildInputs;
+            extraLibDirs = [];
 
             # compiles Setup and configures
             configurePhase = ''
@@ -46,7 +46,16 @@ attrs :
               for i in Setup.hs Setup.lhs; do
                 test -f $i && ghc --make $i
               done
-              ./Setup configure --verbose --prefix="$out" ${toString (map (x : "--extra-lib-dir=" + x) self.extraLibDirs)} $configureFlags
+
+              for p in $propagatedBuildInputs; do
+                for d in lib{,64}; do
+                  if [ -e "$p/$d" ]; then
+                    extraLibDirs="$extraLibDirs --extra-lib-dir=$p/$d"
+                  fi
+                done
+              done
+
+              ./Setup configure --verbose --prefix="$out" $extraLibDirs $configureFlags
 
               eval "$postConfigure"
             '';