summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2017-09-06 17:28:21 +0200
committerFrederik Rietdijk <fridh@fridh.nl>2017-09-07 09:28:03 +0200
commitc4ec44e4d72d7a5a4c6670a4feb59de4df8516d7 (patch)
tree0e71e63f061a476ac8fb713659e999fe4720de0e /pkgs/development
parent6bbc2e09da03f7b49794b3381c2baeb62ac62f24 (diff)
downloadnixlib-c4ec44e4d72d7a5a4c6670a4feb59de4df8516d7.tar
nixlib-c4ec44e4d72d7a5a4c6670a4feb59de4df8516d7.tar.gz
nixlib-c4ec44e4d72d7a5a4c6670a4feb59de4df8516d7.tar.bz2
nixlib-c4ec44e4d72d7a5a4c6670a4feb59de4df8516d7.tar.lz
nixlib-c4ec44e4d72d7a5a4c6670a4feb59de4df8516d7.tar.xz
nixlib-c4ec44e4d72d7a5a4c6670a4feb59de4df8516d7.tar.zst
nixlib-c4ec44e4d72d7a5a4c6670a4feb59de4df8516d7.zip
python.pkgs.pylint: use fetchPypi
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/pylint/default.nix80
1 files changed, 40 insertions, 40 deletions
diff --git a/pkgs/development/python-modules/pylint/default.nix b/pkgs/development/python-modules/pylint/default.nix
index 8c82cb52910a..8c0fd1b7a8fe 100644
--- a/pkgs/development/python-modules/pylint/default.nix
+++ b/pkgs/development/python-modules/pylint/default.nix
@@ -1,42 +1,42 @@
-{ stdenv, fetchurl, buildPythonPackage, python, astroid, isort,
+{ stdenv, buildPythonPackage, fetchPypi, python, astroid, isort,
   pytest, pytestrunner,  mccabe, configparser, backports_functools_lru_cache }:
 
-  buildPythonPackage rec {
-    name = "${pname}-${version}";
-    pname = "pylint";
-    version = "1.7.2";
-
-    src = fetchurl {
-      url = "mirror://pypi/p/${pname}/${name}.tar.gz";
-      sha256 = "ea6afb93a9ed810cf52ff3838eb3a15e2bf6a81b80de0eaede1ce442caa5ca69";
-    };
-
-    buildInputs = [ pytest pytestrunner mccabe configparser backports_functools_lru_cache ];
-
-    propagatedBuildInputs = [ astroid configparser isort ];
-
-    postPatch = ''
-      # Remove broken darwin tests
-      sed -i -e '/test_parallel_execution/,+2d' pylint/test/test_self.py
-      sed -i -e '/test_py3k_jobs_option/,+4d' pylint/test/test_self.py
-      rm -vf pylint/test/test_functional.py
-    '';
-
-    checkPhase = ''
-      cd pylint/test
-      ${python.interpreter} -m unittest discover -p "*test*"
-    '';
-
-    postInstall = ''
-      mkdir -p $out/share/emacs/site-lisp
-      cp "elisp/"*.el $out/share/emacs/site-lisp/
-    '';
-
-    meta = with stdenv.lib; {
-      homepage = http://www.logilab.org/project/pylint;
-      description = "A bug and style checker for Python";
-      platforms = platforms.all;
-      license = licenses.gpl1Plus;
-      maintainers = with maintainers; [ nand0p ];
-    };
-  }
+buildPythonPackage rec {
+  name = "${pname}-${version}";
+  pname = "pylint";
+  version = "1.7.2";
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "ea6afb93a9ed810cf52ff3838eb3a15e2bf6a81b80de0eaede1ce442caa5ca69";
+  };
+
+  buildInputs = [ pytest pytestrunner mccabe configparser backports_functools_lru_cache ];
+
+  propagatedBuildInputs = [ astroid configparser isort ];
+
+  postPatch = ''
+    # Remove broken darwin tests
+    sed -i -e '/test_parallel_execution/,+2d' pylint/test/test_self.py
+    sed -i -e '/test_py3k_jobs_option/,+4d' pylint/test/test_self.py
+    rm -vf pylint/test/test_functional.py
+  '';
+
+  checkPhase = ''
+    cd pylint/test
+    ${python.interpreter} -m unittest discover -p "*test*"
+  '';
+
+  postInstall = ''
+    mkdir -p $out/share/emacs/site-lisp
+    cp "elisp/"*.el $out/share/emacs/site-lisp/
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = http://www.logilab.org/project/pylint;
+    description = "A bug and style checker for Python";
+    platforms = platforms.all;
+    license = licenses.gpl1Plus;
+    maintainers = with maintainers; [ nand0p ];
+  };
+}