summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorSarah Brofeldt <sbrofeldt@gmail.com>2018-05-24 23:52:49 +0200
committerGitHub <noreply@github.com>2018-05-24 23:52:49 +0200
commitc04d3ae0b2e074bffe952270bd6b6f99348d461b (patch)
tree53f07cf376ad676d9a7a0cb5db7c8a14d15a4a33 /pkgs/development
parent8d1eddea16a4f3d22b6f3c07c78a0960defa244d (diff)
parentc2361d632dffc7dc33bf25ff9e3d9615db27b338 (diff)
downloadnixlib-c04d3ae0b2e074bffe952270bd6b6f99348d461b.tar
nixlib-c04d3ae0b2e074bffe952270bd6b6f99348d461b.tar.gz
nixlib-c04d3ae0b2e074bffe952270bd6b6f99348d461b.tar.bz2
nixlib-c04d3ae0b2e074bffe952270bd6b6f99348d461b.tar.lz
nixlib-c04d3ae0b2e074bffe952270bd6b6f99348d461b.tar.xz
nixlib-c04d3ae0b2e074bffe952270bd6b6f99348d461b.tar.zst
nixlib-c04d3ae0b2e074bffe952270bd6b6f99348d461b.zip
Merge pull request #40922 from jtojnar/rust-cbindgen
rust-cbindgen: init at 0.6.0
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/rust/cbindgen/default.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/pkgs/development/tools/rust/cbindgen/default.nix b/pkgs/development/tools/rust/cbindgen/default.nix
new file mode 100644
index 000000000000..ef74842da1c0
--- /dev/null
+++ b/pkgs/development/tools/rust/cbindgen/default.nix
@@ -0,0 +1,22 @@
+{ stdenv, fetchFromGitHub, rustPlatform }:
+
+rustPlatform.buildRustPackage rec {
+  name = "rust-cbindgen-${version}";
+  version = "0.6.0";
+
+  src = fetchFromGitHub {
+    owner = "eqrion";
+    repo = "cbindgen";
+    rev = "v${version}";
+    sha256 = "0yzjbmdhhwbg551bm06xwwdjdm5kdqw37pgd7hals8qxb0dzmmh8";
+  };
+
+  cargoSha256 = "1ml4a7xp40l3bhfhpwdrwj3k99zhan9dzpkw71fa689xmv6pdj62";
+
+  meta = with stdenv.lib; {
+    description = "A project for generating C bindings from Rust code";
+    homepage = https://github.com/eqrion/cbindgen;
+    license = licenses.mpl20;
+    maintainers = with maintainers; [ jtojnar ];
+  };
+}