summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorTuomas Tynkkynen <tuomas@tuxera.com>2017-05-14 14:24:20 +0300
committerTuomas Tynkkynen <tuomas@tuxera.com>2017-05-14 14:24:20 +0300
commitbeb43a651cbdd4ab0e153567b72bfaeacb0f28f6 (patch)
tree8ab2721b9b05a787f9436a1f49f74d64f1c35dd6 /pkgs/development
parent51e0f8f759250b77a7ab7529f5c7da5053465ff4 (diff)
parentd22b1d0ba14329853af18869447a78419f1e5a6d (diff)
downloadnixlib-beb43a651cbdd4ab0e153567b72bfaeacb0f28f6.tar
nixlib-beb43a651cbdd4ab0e153567b72bfaeacb0f28f6.tar.gz
nixlib-beb43a651cbdd4ab0e153567b72bfaeacb0f28f6.tar.bz2
nixlib-beb43a651cbdd4ab0e153567b72bfaeacb0f28f6.tar.lz
nixlib-beb43a651cbdd4ab0e153567b72bfaeacb0f28f6.tar.xz
nixlib-beb43a651cbdd4ab0e153567b72bfaeacb0f28f6.tar.zst
nixlib-beb43a651cbdd4ab0e153567b72bfaeacb0f28f6.zip
Merge remote-tracking branch 'upstream/master' into staging
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/souper/default.nix9
-rw-r--r--pkgs/development/haskell-modules/configuration-common.nix34
-rw-r--r--pkgs/development/haskell-modules/configuration-hackage2nix.yaml7
-rw-r--r--pkgs/development/haskell-modules/hackage-packages.nix8
-rw-r--r--pkgs/development/libraries/vcg/default.nix14
-rw-r--r--pkgs/development/python-modules/whoosh/default.nix30
-rw-r--r--pkgs/development/tools/build-managers/buildbot/default.nix18
-rw-r--r--pkgs/development/tools/build-managers/buildbot/plugins.nix16
-rw-r--r--pkgs/development/tools/build-managers/buildbot/worker.nix4
-rw-r--r--pkgs/development/tools/misc/checkbashisms/default.nix19
10 files changed, 70 insertions, 89 deletions
diff --git a/pkgs/development/compilers/souper/default.nix b/pkgs/development/compilers/souper/default.nix
index 6ea135ea9906..327139ce0455 100644
--- a/pkgs/development/compilers/souper/default.nix
+++ b/pkgs/development/compilers/souper/default.nix
@@ -9,14 +9,15 @@ let
     rev   = "57cd3d43056b029d9da3c6b3c666c4153554c04f";
     sha256 = "197wb7nbirlfpx2jr3afpjjhcj7slc4dxxi02j3kmazz9kcqaygz";
   };
-in stdenv.mkDerivation {
-  name = "souper-unstable-2017-03-07";
+in stdenv.mkDerivation rec {
+  name = "souper-unstable-${version}";
+  version = "2017-03-23";
 
   src = fetchFromGitHub {
     owner  = "google";
     repo   = "souper";
-    rev    = "5faed54ddc4a0e0e12647a0eac1da455a1067a47";
-    sha256 = "1v8ml94ryw5wdls9syvicx4sc9l34yaq8r7cf7is6x7y1q677rps";
+    rev    = "cf2911d2eb1e7c8ab465df5a722fa5cdac06e6fc";
+    sha256 = "1kg08a1af4di729pn1pip2lzqzlvjign6av95214f5rr3cq2q0cl";
   };
 
   nativeBuildInputs = [
diff --git a/pkgs/development/haskell-modules/configuration-common.nix b/pkgs/development/haskell-modules/configuration-common.nix
index b54a5b72235d..67fe44157877 100644
--- a/pkgs/development/haskell-modules/configuration-common.nix
+++ b/pkgs/development/haskell-modules/configuration-common.nix
@@ -66,7 +66,7 @@ self: super: {
     src = pkgs.fetchgit {
       url = "git://git-annex.branchable.com/";
       rev = "refs/tags/" + drv.version;
-      sha256 = "0irvzwpwxxdy6qs7jj81r6qk7i1gkkqyaza4wcm0phyyn07yh2sz";
+      sha256 = "0i08zxk68kbg6k0d9af97r9nr5vidsy63hx22fdp7c5jp64f967q";
     };
   }))).override {
     dbus = if pkgs.stdenv.isLinux then self.dbus else null;
@@ -860,34 +860,4 @@ self: super: {
 
   # https://github.com/danidiaz/tailfile-hinotify/issues/2
   tailfile-hinotify = dontCheck super.tailfile-hinotify;
-} // (let scope' = self: super: {
-            haskell-tools-ast = super.haskell-tools-ast_0_6_0_0;
-            haskell-tools-backend-ghc = super.haskell-tools-backend-ghc_0_6_0_0;
-            haskell-tools-cli = super.haskell-tools-cli_0_6_0_0;
-            haskell-tools-daemon = super.haskell-tools-daemon_0_6_0_0;
-            haskell-tools-debug = super.haskell-tools-debug_0_6_0_0;
-            haskell-tools-demo = super.haskell-tools-demo_0_6_0_0;
-            haskell-tools-prettyprint = super.haskell-tools-prettyprint_0_6_0_0;
-            haskell-tools-refactor = super.haskell-tools-refactor_0_6_0_0;
-            haskell-tools-rewrite = super.haskell-tools-rewrite_0_6_0_0;
-          };
-      in {
-        haskell-tools-ast_0_6_0_0 =
-          super.haskell-tools-ast_0_6_0_0.overrideScope scope';
-        haskell-tools-backend-ghc_0_6_0_0 =
-          super.haskell-tools-backend-ghc_0_6_0_0.overrideScope scope';
-        haskell-tools-cli_0_6_0_0 =
-          dontCheck (super.haskell-tools-cli_0_6_0_0.overrideScope scope');
-        haskell-tools-daemon_0_6_0_0 =
-          dontCheck (super.haskell-tools-daemon_0_6_0_0.overrideScope scope');
-        haskell-tools-debug_0_6_0_0 =
-          super.haskell-tools-debug_0_6_0_0.overrideScope scope';
-        haskell-tools-demo_0_6_0_0 =
-          super.haskell-tools-demo_0_6_0_0.overrideScope scope';
-        haskell-tools-prettyprint_0_6_0_0 =
-          super.haskell-tools-prettyprint_0_6_0_0.overrideScope scope';
-        haskell-tools-refactor_0_6_0_0 =
-          super.haskell-tools-refactor_0_6_0_0.overrideScope scope';
-        haskell-tools-rewrite_0_6_0_0 =
-          super.haskell-tools-rewrite_0_6_0_0.overrideScope scope';
-     })
+}
diff --git a/pkgs/development/haskell-modules/configuration-hackage2nix.yaml b/pkgs/development/haskell-modules/configuration-hackage2nix.yaml
index 15f57b08fe63..1ace80a48a50 100644
--- a/pkgs/development/haskell-modules/configuration-hackage2nix.yaml
+++ b/pkgs/development/haskell-modules/configuration-hackage2nix.yaml
@@ -2458,13 +2458,6 @@ extra-packages:
   - transformers == 0.4.3.*             # the latest version isn't supported by mtl yet
   - vector < 0.10.10                    # newer versions don't work with GHC 6.12.3
   - zlib < 0.6                          # newer versions break cabal-install
-  - aeson == 0.11.3.0                   # purescript 0.10.7
-  - bower-json == 1.0.0.1               # purescript 0.10.7
-  - optparse-applicative == 0.13.1.0    # purescript 0.10.7
-  - http-client == 0.4.31.2             # purescript 0.10.7
-  - http-client-tls == 0.2.4.1          # purescript 0.10.7
-  - pipes == 4.2.0                      # purescript 0.10.7
-  - websockets == 0.9.8.2               # purescript 0.10.7
 
 package-maintainers:
   peti:
diff --git a/pkgs/development/haskell-modules/hackage-packages.nix b/pkgs/development/haskell-modules/hackage-packages.nix
index f7969b977a48..1ad74866c1d4 100644
--- a/pkgs/development/haskell-modules/hackage-packages.nix
+++ b/pkgs/development/haskell-modules/hackage-packages.nix
@@ -74123,9 +74123,13 @@ self: {
          bup curl git gnupg lsof openssh perl rsync wget which
        ];
        preConfigure = "export HOME=$TEMPDIR; patchShebangs .";
-       postBuild = "ln -sf dist/build/git-annex/git-annex git-annex";
        installPhase = "make PREFIX=$out BUILDER=: install";
-       checkPhase = "./git-annex test";
+       checkPhase = ''
+         ln -sf dist/build/git-annex/git-annex git-annex
+         ln -sf git-annex git-annex-shell
+         export PATH+=":$PWD"
+         git-annex test
+       '';
        enableSharedExecutables = false;
        homepage = "http://git-annex.branchable.com/";
        description = "manage files with git, without checking their contents into git";
diff --git a/pkgs/development/libraries/vcg/default.nix b/pkgs/development/libraries/vcg/default.nix
index 9e85ad7413d0..6225fb18e280 100644
--- a/pkgs/development/libraries/vcg/default.nix
+++ b/pkgs/development/libraries/vcg/default.nix
@@ -1,12 +1,14 @@
-{ stdenv, fetchsvn, eigen }:
+{ stdenv, fetchFromGitHub, eigen }:
 
 stdenv.mkDerivation rec {
-  name = "vcg-2016-02-14";
+  name = "vcg-${version}";
+  version = "1.0.1";
 
-  src = fetchsvn {
-    url = "svn://svn.code.sf.net/p/vcg/code/trunk/vcglib";
-    rev = 5688;
-    sha256 = "0hkvz2d8prrjdcc7h0xhfd9hq86lmqg17ml045x4bkiciimx0w5s";
+  src = fetchFromGitHub {
+    owner = "cnr-isti-vclab";
+    repo = "vcglib";
+    rev = "v${version}";
+    sha256 = "0jh8jc8rn7rci8qr3q03q574fk2hsc3rllysck41j8xkr3rmxz2f";
   };
 
   propagatedBuildInputs = [ eigen ];
diff --git a/pkgs/development/python-modules/whoosh/default.nix b/pkgs/development/python-modules/whoosh/default.nix
new file mode 100644
index 000000000000..7e2a571b1bba
--- /dev/null
+++ b/pkgs/development/python-modules/whoosh/default.nix
@@ -0,0 +1,30 @@
+{ stdenv, buildPythonPackage, fetchPypi, pytest }:
+
+buildPythonPackage rec {
+  name = "${pname}-${version}";
+  pname = "Whoosh";
+  version = "2.7.4";
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "10qsqdjpbc85fykc1vgcs8xwbgn4l2l52c8d83xf1q59pwyn79bw";
+  };
+  buildInputs = [ pytest ];
+
+  # Wrong encoding
+  postPatch = ''
+    rm tests/test_reading.py
+  '';
+  checkPhase =  ''
+    # FIXME: test_minimize_dfa fails on python 3.6
+    py.test -k "not test_timelimit and not test_minimize_dfa"
+  '';
+
+  meta = with stdenv.lib; {
+    description = "Fast, pure-Python full text indexing, search, and spell
+checking library.";
+    homepage    = "http://bitbucket.org/mchaput/whoosh";
+    license     = licenses.bsd2;
+    maintainers = with maintainers; [ nand0p ];
+    platforms   = platforms.all;
+  };
+}
diff --git a/pkgs/development/tools/build-managers/buildbot/default.nix b/pkgs/development/tools/build-managers/buildbot/default.nix
index a4fb9a8b8bf8..64ab960c88b1 100644
--- a/pkgs/development/tools/build-managers/buildbot/default.nix
+++ b/pkgs/development/tools/build-managers/buildbot/default.nix
@@ -13,11 +13,11 @@ let
   package = pythonPackages.buildPythonApplication (rec {
     name = "${pname}-${version}";
     pname = "buildbot";
-    version = "0.9.6";
+    version = "0.9.7";
 
     src = pythonPackages.fetchPypi {
       inherit pname version;
-      sha256 = "0d6ys1wjwsv4jg4bja1cqhy279hhrl1c9kwyx126srf45slcvg1w";
+      sha256 = "0cwy39ap2v9kni3zm92633cnqf7qsnb4zlargx060pbfagkg1jwg";
     };
 
     buildInputs = with pythonPackages; [
@@ -70,25 +70,13 @@ let
     ];
 
     patches = [
-      # This patch disables the test that tries to reat /etc/os-release which
+      # This patch disables the test that tries to read /etc/os-release which
       # is not accessible in sandboxed builds.
       ./skip_test_linux_distro.patch
     ];
 
     postPatch = ''
       substituteInPlace buildbot/scripts/logwatcher.py --replace '/usr/bin/tail' "$(type -P tail)"
-
-      # NOTE: secrets management tests currently broken
-      rm -fv buildbot/test/integration/test_integration_secrets.py
-      rm -fv buildbot/test/integration/test_integration_secrets_with_vault.py
-      rm -fv buildbot/test/unit/test_fake_secrets_manager.py
-      rm -fv buildbot/test/unit/test_interpolate_secrets.py
-      rm -fv buildbot/test/unit/test_secret_in_file.py
-      rm -fv buildbot/test/unit/test_secret_in_vault.py
-
-      # Remove this line after next update. See
-      # https://github.com/buildbot/buildbot/commit/e7fc8c8eba903c2aa6d7e6393499e5b9bffc2334
-      rm -fv buildbot/test/unit/test_mq_wamp.py
     '';
 
     passthru = { inherit withPlugins; };
diff --git a/pkgs/development/tools/build-managers/buildbot/plugins.nix b/pkgs/development/tools/build-managers/buildbot/plugins.nix
index 77e97ed7ac3c..3c15e256a3f6 100644
--- a/pkgs/development/tools/build-managers/buildbot/plugins.nix
+++ b/pkgs/development/tools/build-managers/buildbot/plugins.nix
@@ -4,11 +4,11 @@ let
   buildbot-pkg = pythonPackages.buildPythonPackage rec {
     name = "${pname}-${version}";
     pname = "buildbot-pkg";
-    version = "0.9.5";
+    version = "0.9.7";
 
     src = pythonPackages.fetchPypi {
       inherit pname version;
-      sha256 = "1xpi4w0lc6z97pmmms85dvdspacbzlvs8zi3kv1r4rypk3znwmi1";
+      sha256 = "0p351r10y42gwgxb2qg7xlsbhmnzdmqp6h4922l0yfii3pzmrdzv";
     };
 
     propagatedBuildInputs = with pythonPackages; [ setuptools ];
@@ -25,14 +25,14 @@ in {
   www = pythonPackages.buildPythonPackage rec {
     name = "${pname}-${version}";
     pname = "buildbot_www";
-    version = "0.9.5";
+    version = "0.9.7";
 
     # NOTE: wheel is used due to buildbot circular dependency
     format = "wheel";
 
     src = pythonPackages.fetchPypi {
       inherit pname version format;
-      sha256 = "1d7yjxka6slflm3wbdpq4sr1kagmgbqdv2zgx9bq77jvjh7ga0py";
+      sha256 = "1wf2spnilm0dkyw95vf57lca453sbly4r6ak3lxa8bpwhxb6lkdn";
     };
 
     meta = with stdenv.lib; {
@@ -46,11 +46,11 @@ in {
   console-view = pythonPackages.buildPythonPackage rec {
     name = "${pname}-${version}";
     pname = "buildbot-console-view";
-    version = "0.9.5";
+    version = "0.9.7";
 
     src = pythonPackages.fetchPypi {
       inherit pname version;
-      sha256 = "1s6mvw955dsgk7hvb1xa32bbd7w2yma62py5s0vmi5shv8nwq3hb";
+      sha256 = "1iv77886rbbn0wlzl5qiqc08rgbymxirqh3vmimqwsabbh7fhzkm";
     };
 
     propagatedBuildInputs = with pythonPackages; [ buildbot-pkg ];
@@ -66,11 +66,11 @@ in {
   waterfall-view = pythonPackages.buildPythonPackage rec {
     name = "${pname}-${version}";
     pname = "buildbot-waterfall-view";
-    version = "0.9.5";
+    version = "0.9.7";
 
     src = pythonPackages.fetchPypi {
       inherit pname version;
-      sha256 = "116846d987wp1bz78f0h4lypqcns5073vzhb4vsqbf08sppgr67k";
+      sha256 = "1q42l25cryx0yp6lbbl0mxnxkb9h24wawhzhi1wkc3kj8zs5sifn";
     };
 
     propagatedBuildInputs = with pythonPackages; [ buildbot-pkg ];
diff --git a/pkgs/development/tools/build-managers/buildbot/worker.nix b/pkgs/development/tools/build-managers/buildbot/worker.nix
index 145221c63537..28fb719d84a0 100644
--- a/pkgs/development/tools/build-managers/buildbot/worker.nix
+++ b/pkgs/development/tools/build-managers/buildbot/worker.nix
@@ -3,11 +3,11 @@
 pythonPackages.buildPythonApplication (rec {
   name = "${pname}-${version}";
   pname = "buildbot-worker";
-  version = "0.9.5";
+  version = "0.9.7";
 
   src = pythonPackages.fetchPypi {
     inherit pname version;
-    sha256 = "1al7jam351sf781axj4kfhj70cc0g21zv81ynk410kdccjyxp2dy";
+    sha256 = "0s62i808l13a8dprmrb2dikh7d1xvvdnw3pfhl6im0i9fc64w6x4";
   };
 
   buildInputs = with pythonPackages; [ setuptoolsTrial mock ];
diff --git a/pkgs/development/tools/misc/checkbashisms/default.nix b/pkgs/development/tools/misc/checkbashisms/default.nix
index b00b9cc9910b..563d76930880 100644
--- a/pkgs/development/tools/misc/checkbashisms/default.nix
+++ b/pkgs/development/tools/misc/checkbashisms/default.nix
@@ -1,33 +1,26 @@
 { stdenv, fetchurl, perl }:
 stdenv.mkDerivation rec {
-  inherit perl;
-
-  name = "checkbashisms";
   version = "2.0.0.2";
+  name = "checkbashisms-${version}";
 
   src = fetchurl {
-    url = "mirror://sourceforge/project/checkbaskisms/${version}/${name}";
+    url = "mirror://sourceforge/project/checkbaskisms/${version}/checkbashisms";
     sha256 = "1vm0yykkg58ja9ianfpm3mgrpah109gj33b41kl0jmmm11zip9jd";
   };
 
+  buildInputs = [ perl ];
+
   # The link returns directly the script. No need for unpacking
   unpackPhase = "true";
 
   installPhase = ''
-    mkdir -p $out/bin
-    cp $src $out/bin/checkbashisms
-    chmod 755 $out/bin/checkbashisms
-  '';
-
-  # Makes sure to point to the proper perl version
-  fixupPhase = ''
-    sed -e "s#/usr/bin/perl#$perl/bin/perl#" -i $out/bin/checkbashisms
+    install -D -m755 $src $out/bin/checkbashisms
   '';
 
   meta = {
     homepage = http://sourceforge.net/projects/checkbaskisms/;
     description = "Check shell scripts for non-portable syntax";
     license = stdenv.lib.licenses.gpl2;
-    platforms = stdenv.lib.platforms.linux;
+    platforms = stdenv.lib.platforms.unix;
   };
 }