summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorMatthew Daiter <matthew@nomoko.camera>2016-11-21 18:13:49 +0100
committerMatthew Daiter <matthew@nomoko.camera>2016-11-21 18:16:38 +0100
commitbbb32994094021162495253fb9cb027536a2c991 (patch)
tree5272ee2480ad9e43097f2a75f634629d82c7f683 /pkgs/development
parent18316620735c9d5f5fc00f340b5e964dd513dd6c (diff)
downloadnixlib-bbb32994094021162495253fb9cb027536a2c991.tar
nixlib-bbb32994094021162495253fb9cb027536a2c991.tar.gz
nixlib-bbb32994094021162495253fb9cb027536a2c991.tar.bz2
nixlib-bbb32994094021162495253fb9cb027536a2c991.tar.lz
nixlib-bbb32994094021162495253fb9cb027536a2c991.tar.xz
nixlib-bbb32994094021162495253fb9cb027536a2c991.tar.zst
nixlib-bbb32994094021162495253fb9cb027536a2c991.zip
erlang: added dirty scheduler support
erlang: formatting
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/interpreters/erlang/R18.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/pkgs/development/interpreters/erlang/R18.nix b/pkgs/development/interpreters/erlang/R18.nix
index 10e5313ce8bb..f9b6edc3fa4b 100644
--- a/pkgs/development/interpreters/erlang/R18.nix
+++ b/pkgs/development/interpreters/erlang/R18.nix
@@ -6,6 +6,7 @@
 , javacSupport ? false, openjdk ? null
 , enableHipe ? true
 , enableDebugInfo ? false
+, enableDirtySchedulers ? false
 }:
 
 assert wxSupport -> (if stdenv.isDarwin
@@ -64,6 +65,7 @@ stdenv.mkDerivation rec {
   configureFlags= [
     "--with-ssl=${openssl.dev}"
   ] ++ optional enableHipe "--enable-hipe"
+    ++ optional enableDirtySchedulers "--enable-dirty-schedulers"
     ++ optional wxSupport "--enable-wx"
     ++ optional odbcSupport "--with-odbc=${unixODBC}"
     ++ optional javacSupport "--with-javac"