summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorFrederik Rietdijk <freddyrietdijk@fridh.nl>2017-12-30 11:55:47 +0000
committerGitHub <noreply@github.com>2017-12-30 11:55:47 +0000
commitbb729316dd95d8e7e31e089a769239846371f241 (patch)
tree88a71f0fb337dc2c921b0b5ae13a27a44e2f824d /pkgs/development
parentf0f6515bb8902f851cd9b271b179e8075832eaaa (diff)
parentaa6a18a6d932b4a29b990d7ff0857133831f09b4 (diff)
downloadnixlib-bb729316dd95d8e7e31e089a769239846371f241.tar
nixlib-bb729316dd95d8e7e31e089a769239846371f241.tar.gz
nixlib-bb729316dd95d8e7e31e089a769239846371f241.tar.bz2
nixlib-bb729316dd95d8e7e31e089a769239846371f241.tar.lz
nixlib-bb729316dd95d8e7e31e089a769239846371f241.tar.xz
nixlib-bb729316dd95d8e7e31e089a769239846371f241.tar.zst
nixlib-bb729316dd95d8e7e31e089a769239846371f241.zip
Merge pull request #33201 from rnhmjoj/steamcontroller
Add Steam controller userspace driver
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/libusb1/default.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/libusb1/default.nix b/pkgs/development/python-modules/libusb1/default.nix
new file mode 100644
index 000000000000..adf1bc236183
--- /dev/null
+++ b/pkgs/development/python-modules/libusb1/default.nix
@@ -0,0 +1,26 @@
+{ stdenv, lib, buildPythonPackage, fetchPypi, libusb1 }:
+
+buildPythonPackage rec {
+  pname = "libusb1";
+  version = "1.6.4";
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "03b7xrz8vqg8w0za5r503jhcmbd1ls5610jcja1rqz833nf0v4wc";
+  };
+
+  postPatch = lib.optionalString stdenv.isLinux ''
+    substituteInPlace usb1/libusb1.py --replace \
+      "ctypes.util.find_library(base_name)" \
+      "'${libusb1}/lib/libusb${stdenv.hostPlatform.extensions.sharedLibrary}'"
+  '';
+
+  buildInputs = [ libusb1 ];
+
+  meta = with stdenv.lib; {
+    homepage    = https://github.com/vpelletier/python-libusb1;
+    description = "Python ctype-based wrapper around libusb1";
+    license     = licenses.lgpl2Plus;
+    maintainers = with maintainers; [ rnhmjoj ];
+  };
+}