summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorvbgl <vbgl@users.noreply.github.com>2015-08-06 09:11:34 +0200
committervbgl <vbgl@users.noreply.github.com>2015-08-06 09:11:34 +0200
commitb8a1e16f81c5904e82dbfbdaa78583b05b08ce47 (patch)
tree5de630ecb50c5a55747ae578024425174ccf7eea /pkgs/development
parent863fa55cc183c35533cdfd73a8046a30f1085f2c (diff)
parent37d0d8ac7411af01761dbaf58bfa7d673453af2a (diff)
downloadnixlib-b8a1e16f81c5904e82dbfbdaa78583b05b08ce47.tar
nixlib-b8a1e16f81c5904e82dbfbdaa78583b05b08ce47.tar.gz
nixlib-b8a1e16f81c5904e82dbfbdaa78583b05b08ce47.tar.bz2
nixlib-b8a1e16f81c5904e82dbfbdaa78583b05b08ce47.tar.lz
nixlib-b8a1e16f81c5904e82dbfbdaa78583b05b08ce47.tar.xz
nixlib-b8a1e16f81c5904e82dbfbdaa78583b05b08ce47.tar.zst
nixlib-b8a1e16f81c5904e82dbfbdaa78583b05b08ce47.zip
Merge pull request #9028 from samuelrivas/update-utop-and-camlp4
Update utop and camlp4
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/ocaml/camlp4/default.nix16
-rw-r--r--pkgs/development/tools/ocaml/utop/default.nix12
2 files changed, 14 insertions, 14 deletions
diff --git a/pkgs/development/tools/ocaml/camlp4/default.nix b/pkgs/development/tools/ocaml/camlp4/default.nix
index a8043a9fc5ee..20373c923e7e 100644
--- a/pkgs/development/tools/ocaml/camlp4/default.nix
+++ b/pkgs/development/tools/ocaml/camlp4/default.nix
@@ -1,15 +1,17 @@
-{stdenv, fetchurl, which, ocaml}:
+{stdenv, fetchzip, which, ocaml}:
 let
   ocaml_version = (stdenv.lib.getVersion ocaml);
+  version = "4.02+6";
+
 in
 
 assert stdenv.lib.versionAtLeast ocaml_version "4.02";
 
 stdenv.mkDerivation {
-  name = "camlp4-4.02.0+1";
-  src = fetchurl {
-    url = https://github.com/ocaml/camlp4/archive/4.02.0+1.tar.gz;
-    sha256 = "0055f4jiz82rgn581xhq3mr4qgq2qgdxqppmp8i2x1xnsim4h9pn";
+  name = "camlp4-${version}";
+  src = fetchzip {
+    url = "https://github.com/ocaml/camlp4/archive/${version}.tar.gz";
+    sha256 = "06yl4q0qazl7g25b0axd1gdkfd4qpqzs1gr5fkvmkrcbz113h1hj";
   };
 
   buildInputs = [ which ocaml ];
@@ -27,10 +29,6 @@ stdenv.mkDerivation {
   postConfigure = ''
     substituteInPlace camlp4/META.in \
     --replace +camlp4 $out/lib/ocaml/${ocaml_version}/site-lib/camlp4
-    substituteInPlace camlp4/config/Camlp4_config.ml \
-    --replace \
-      "Filename.concat ocaml_standard_library" \
-      "Filename.concat \"$out/lib/ocaml/${ocaml_version}/site-lib\""
   '';
 
 
diff --git a/pkgs/development/tools/ocaml/utop/default.nix b/pkgs/development/tools/ocaml/utop/default.nix
index c5c0ac9a3ed8..c9addf55312c 100644
--- a/pkgs/development/tools/ocaml/utop/default.nix
+++ b/pkgs/development/tools/ocaml/utop/default.nix
@@ -1,22 +1,24 @@
 {stdenv, fetchurl, ocaml, findlib, lambdaTerm, ocaml_lwt, makeWrapper,
- ocaml_react, camomile, zed
+ ocaml_react, camomile, zed, cppo, camlp4
 }:
 
 stdenv.mkDerivation rec {
-  version = "1.15";
+  version = "1.17";
   name = "utop-${version}";
 
   src = fetchurl {
-    url = https://github.com/diml/utop/archive/1.15.tar.gz;
-    sha256 = "106v0x6sa2x10zgmjf73mpzws7xiqanxswivd00iqnpc0bcpkmrr";
+    url = "https://github.com/diml/utop/archive/${version}.tar.gz";
+    sha256 = "0l9lz2nypl2ls3kqzmp738m02yvscabhsfpj70ckp0p98pimnnfd";
   };
 
-  buildInputs = [ ocaml findlib makeWrapper];
+  buildInputs = [ ocaml findlib makeWrapper cppo camlp4 ];
 
   propagatedBuildInputs = [ lambdaTerm ocaml_lwt ];
 
   createFindlibDestdir = true;
 
+  configureFlags = "--enable-camlp4";
+
   buildPhase = ''
     make
     make doc