summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorLancelot SIX <lsix@lancelotsix.com>2015-08-03 09:31:21 +0000
committerLancelot SIX <lsix@lancelotsix.com>2015-08-03 09:31:21 +0000
commitb867cc62a78221de7378a3e416d44151a8303251 (patch)
treeb019b0b149794ccad84d3d66b9b3f32b39aae5ec /pkgs/development
parenteda7843cab45ad4fab16896aa04a93e06745d21f (diff)
downloadnixlib-b867cc62a78221de7378a3e416d44151a8303251.tar
nixlib-b867cc62a78221de7378a3e416d44151a8303251.tar.gz
nixlib-b867cc62a78221de7378a3e416d44151a8303251.tar.bz2
nixlib-b867cc62a78221de7378a3e416d44151a8303251.tar.lz
nixlib-b867cc62a78221de7378a3e416d44151a8303251.tar.xz
nixlib-b867cc62a78221de7378a3e416d44151a8303251.tar.zst
nixlib-b867cc62a78221de7378a3e416d44151a8303251.zip
poezio: 0.8.1 -> 0.9
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/poezio/fix_requirements.patch11
-rw-r--r--pkgs/development/python-modules/poezio/make_default_config_writable.patch34
2 files changed, 17 insertions, 28 deletions
diff --git a/pkgs/development/python-modules/poezio/fix_requirements.patch b/pkgs/development/python-modules/poezio/fix_requirements.patch
deleted file mode 100644
index 99b022c0e782..000000000000
--- a/pkgs/development/python-modules/poezio/fix_requirements.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/setup.py	2014-03-20 22:27:14.000000000 +0100
-+++ b/setup.py	2015-07-10 21:18:30.156196111 +0200
-@@ -49,7 +49,7 @@
-        scripts = ['scripts/poezio'],
-        data_files = [('share/man/man1/', ['data/poezio.1'])],
- 
--       install_requires = ['sleekxmpp==1.2.4',
-+       install_requires = ['sleekxmpp==1.2.5',
-                            'dnspython3>=1.11.1'],
-        extras_require = {'OTR plugin': 'python-potr>=1.0',
-                          'Screen autoaway plugin': 'pyinotify==0.9.4'}
diff --git a/pkgs/development/python-modules/poezio/make_default_config_writable.patch b/pkgs/development/python-modules/poezio/make_default_config_writable.patch
index aa431dcc928f..03d732e256c4 100644
--- a/pkgs/development/python-modules/poezio/make_default_config_writable.patch
+++ b/pkgs/development/python-modules/poezio/make_default_config_writable.patch
@@ -1,25 +1,25 @@
 diff -ruN a/src/config.py b/src/config.py
---- a/src/config.py	2014-03-20 22:27:05.000000000 +0100
-+++ b/src/config.py	2015-07-10 21:24:37.583136078 +0200
-@@ -18,6 +18,7 @@
+--- a/src/config.py	2015-07-31 19:35:37.000000000 +0000
++++ b/src/config.py	2015-08-03 09:23:34.322098081 +0000
+@@ -14,6 +14,7 @@
  
+ import logging.config
  import os
- import logging
 +import stat
+ import sys
+ import pkg_resources
  
- from configparser import RawConfigParser, NoOptionError, NoSectionError
- from os import environ, makedirs, path, remove
-@@ -279,6 +280,13 @@
-         copy2(default, options.filename)
-     elif path.isfile(other):
-         copy2(other, options.filename)
+@@ -563,6 +564,13 @@
+             copy2(default, options.filename)
+         elif path.isfile(other):
+             copy2(other, options.filename)
 +
-+    # Inside the nixstore, the reference file is readonly, so is the copy.
-+    # Make it writable by the user who just created it.
-+    if os.path.exists(options.filename):
-+        os.chmod(options.filename,
-+                 os.stat(options.filename).st_mode | stat.S_IWUSR)
++        # Inside the nixstore, the reference file is readonly, so is the copy.
++        # Make it writable by the user who just created it.
++        if os.path.exists(options.filename):
++            os.chmod(options.filename,
++                     os.stat(options.filename).st_mode | stat.S_IWUSR)
 +
-     firstrun = True
+         global firstrun
+         firstrun = True
  
- try: