summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorAlexander Ried <ried@mytum.de>2016-09-18 21:27:59 +0200
committerAlexander Ried <ried@mytum.de>2016-09-22 22:25:43 +0200
commitb82874e6dc78cfc3efe7a8a8f0453de152d05ff0 (patch)
tree2c9bf635e314a7b6b429bd43dc068f0dc243a2f1 /pkgs/development
parentf081a1aaf4ec30f953c8c68ce1be9f687179d4e5 (diff)
downloadnixlib-b82874e6dc78cfc3efe7a8a8f0453de152d05ff0.tar
nixlib-b82874e6dc78cfc3efe7a8a8f0453de152d05ff0.tar.gz
nixlib-b82874e6dc78cfc3efe7a8a8f0453de152d05ff0.tar.bz2
nixlib-b82874e6dc78cfc3efe7a8a8f0453de152d05ff0.tar.lz
nixlib-b82874e6dc78cfc3efe7a8a8f0453de152d05ff0.tar.xz
nixlib-b82874e6dc78cfc3efe7a8a8f0453de152d05ff0.tar.zst
nixlib-b82874e6dc78cfc3efe7a8a8f0453de152d05ff0.zip
webkitgtk214x: init at 2.14.0
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/webkitgtk/2.14.nix63
1 files changed, 63 insertions, 0 deletions
diff --git a/pkgs/development/libraries/webkitgtk/2.14.nix b/pkgs/development/libraries/webkitgtk/2.14.nix
new file mode 100644
index 000000000000..fca358ed4305
--- /dev/null
+++ b/pkgs/development/libraries/webkitgtk/2.14.nix
@@ -0,0 +1,63 @@
+{ stdenv, fetchurl, perl, python, ruby, bison, gperf, cmake
+, pkgconfig, gettext, gobjectIntrospection, libnotify, gnutls
+, gtk2, gtk3, wayland, libwebp, enchant, xlibs, libxkbcommon, epoxy, at_spi2_core
+, libxml2, libsoup, libsecret, libxslt, harfbuzz, libpthreadstubs
+, enableGeoLocation ? true, geoclue2, sqlite
+, gst-plugins-base
+}:
+
+assert enableGeoLocation -> geoclue2 != null;
+
+with stdenv.lib;
+stdenv.mkDerivation rec {
+  name = "webkitgtk-${version}";
+  version = "2.14.0";
+
+  meta = {
+    description = "Web content rendering engine, GTK+ port";
+    homepage = "http://webkitgtk.org/";
+    license = licenses.bsd2;
+    platforms = platforms.linux;
+    hydraPlatforms = [];
+    maintainers = with maintainers; [ ];
+  };
+
+  preConfigure = "patchShebangs Tools";
+
+  src = fetchurl {
+    url = "http://webkitgtk.org/releases/${name}.tar.xz";
+    sha256 = "02paj0anbnqn1z3hn5c4csmq9nga995rzagiplj3sjk2dj1ss4q5";
+  };
+
+  # see if we can clean this up....
+
+  patches = [ ./finding-harfbuzz-icu.patch ];
+
+  cmakeFlags = [ 
+  "-DPORT=GTK"
+  "-DUSE_LIBHYPHEN=0"
+  "-DENABLE_GLES2=ON"
+  ];
+
+  # XXX: WebKit2 missing include path for gst-plugins-base.
+  # Filled: https://bugs.webkit.org/show_bug.cgi?id=148894
+  #NIX_CFLAGS_COMPILE = "-I${gst-plugins-base.dev}/include/gstreamer-1.0";
+
+  nativeBuildInputs = [
+    cmake perl python ruby bison gperf sqlite
+    pkgconfig gettext gobjectIntrospection
+  ];
+
+  buildInputs = [
+    gtk2 wayland libwebp enchant libnotify gnutls
+    libxml2 libsecret libxslt harfbuzz libpthreadstubs
+    gst-plugins-base libxkbcommon epoxy at_spi2_core
+  ] ++ optional enableGeoLocation geoclue2
+    ++ (with xlibs; [ libXdmcp libXt libXtst ]);
+
+  propagatedBuildInputs = [
+    libsoup gtk3
+  ];
+
+  enableParallelBuilding = true;
+}