summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorbetaboon <betaboon@0x80.ninja>2017-08-31 21:14:00 +0200
committerFrederik Rietdijk <fridh@fridh.nl>2017-09-07 09:28:02 +0200
commitb80cb36cde2e2460674ee6cb4514550f7df00676 (patch)
treeeda83198538a6b01a3554d2b6a2b9a1aa583b0e5 /pkgs/development
parent0b2fc117c1a8406c1c9b3815bb49ce0c9ba4afff (diff)
downloadnixlib-b80cb36cde2e2460674ee6cb4514550f7df00676.tar
nixlib-b80cb36cde2e2460674ee6cb4514550f7df00676.tar.gz
nixlib-b80cb36cde2e2460674ee6cb4514550f7df00676.tar.bz2
nixlib-b80cb36cde2e2460674ee6cb4514550f7df00676.tar.lz
nixlib-b80cb36cde2e2460674ee6cb4514550f7df00676.tar.xz
nixlib-b80cb36cde2e2460674ee6cb4514550f7df00676.tar.zst
nixlib-b80cb36cde2e2460674ee6cb4514550f7df00676.zip
pythonPackages.django-jinja: init at 2.2.2
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/django-jinja2/default.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/django-jinja2/default.nix b/pkgs/development/python-modules/django-jinja2/default.nix
new file mode 100644
index 000000000000..aabfecfcacc7
--- /dev/null
+++ b/pkgs/development/python-modules/django-jinja2/default.nix
@@ -0,0 +1,29 @@
+{ lib, buildPythonPackage, fetchPypi,
+  django, jinja2, pytz, tox
+ }:
+
+buildPythonPackage rec {
+  pname = "django-jinja";
+  name = "${pname}-${version}";
+  version = "2.2.2";
+
+  meta = {
+    description = "Simple and nonobstructive jinja2 integration with Django";
+    homepage = https://github.com/niwinz/django-jinja;
+    license = lib.licenses.bsd3;
+  };
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "099b99iprkvlsndrjmw4v3i3i60i9gm1aq5r88z15r7vgmv6sigj";
+  };
+
+  buildInputs = [ django pytz tox ];
+  propagatedBuildInputs = [ django jinja2 ];
+
+  # python installed: The directory '/homeless-shelter/.cache/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.,appdirs==1.4.3,Django==1.11.1,django-jinja==2.2.2,Jinja2==2.9.6,MarkupSafe==1.0,packaging==16.8,pyparsing==2.2.0,pytz==2017.2,six==1.10.0
+  doCheck = false;
+  checkPhase = ''
+    tox
+  '';
+}