summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2016-07-08 14:54:44 +0200
committerVladimír Čunát <vcunat@gmail.com>2016-07-08 14:54:44 +0200
commitb732af00bb42c7c60f32d4645b5f0b424c72b9f5 (patch)
tree946a1a806638bdf01ac833c199c3911873dd7d7a /pkgs/development
parent56791034f6e9ae696d258e0f28460a65858bcfad (diff)
downloadnixlib-b732af00bb42c7c60f32d4645b5f0b424c72b9f5.tar
nixlib-b732af00bb42c7c60f32d4645b5f0b424c72b9f5.tar.gz
nixlib-b732af00bb42c7c60f32d4645b5f0b424c72b9f5.tar.bz2
nixlib-b732af00bb42c7c60f32d4645b5f0b424c72b9f5.tar.lz
nixlib-b732af00bb42c7c60f32d4645b5f0b424c72b9f5.tar.xz
nixlib-b732af00bb42c7c60f32d4645b5f0b424c72b9f5.tar.zst
nixlib-b732af00bb42c7c60f32d4645b5f0b424c72b9f5.zip
pythonPackages.breathe: init at 4.2.0
It seems to work OK, but I'm not good at packaging python stuff.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/breathe/default.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/breathe/default.nix b/pkgs/development/python-modules/breathe/default.nix
new file mode 100644
index 000000000000..bf53d3302457
--- /dev/null
+++ b/pkgs/development/python-modules/breathe/default.nix
@@ -0,0 +1,21 @@
+{ lib, fetchurl, buildPythonPackage, docutils, six, sphinx }:
+
+buildPythonPackage rec {
+  name = "breathe-${version}";
+  version = "4.2.0";
+
+  src = fetchurl {
+    url = "mirror://pypi/b/breathe/${name}.tar.gz";
+    md5 = "e35f6ce54485663857129370047f6057";
+  };
+
+  propagatedBuildInputs = [ docutils six sphinx ];
+
+  meta = {
+    homepage = https://github.com/michaeljones/breathe;
+    license = lib.licenses.bsd3;
+    description = "Sphinx Doxygen renderer";
+    inherit (sphinx.meta) platforms;
+  };
+}
+